aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnutls/Makefile
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2007-01-02 16:52:38 +0800
committernovel <novel@FreeBSD.org>2007-01-02 16:52:38 +0800
commit9f0ac2eea24cd09e605e738f4acf1453ff7eda0f (patch)
treedce81b63d6bc385272a2b307d6e8a7e7bf59b267 /security/gnutls/Makefile
parent407826ab9726ba6d612eabff2f6b404bb557f036 (diff)
downloadfreebsd-ports-gnome-9f0ac2eea24cd09e605e738f4acf1453ff7eda0f.tar.gz
freebsd-ports-gnome-9f0ac2eea24cd09e605e738f4acf1453ff7eda0f.tar.zst
freebsd-ports-gnome-9f0ac2eea24cd09e605e738f4acf1453ff7eda0f.zip
Update to 1.6.1.
Diffstat (limited to 'security/gnutls/Makefile')
-rw-r--r--security/gnutls/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index fd8891bb227b..87ea912bb406 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnutls
-PORTVERSION= 1.4.5
+PORTVERSION= 1.6.1
CATEGORIES= security net
MASTER_SITES= http://josefsson.org/gnutls/releases/ \
ftp://ftp.gnutls.org/pub/gnutls/ \
@@ -30,7 +30,7 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -fPIC" LDFLAGS="${LDFLAGS}" \
MAKEINFO="${LOCALBASE}/bin/makeinfo"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-included-lzo \
@@ -50,6 +50,13 @@ LIB_DEPENDS+= tasn1.3:${PORTSDIR}/security/libtasn1
BUILD_DEPENDS+= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
.endif
+.if defined(WITHOUT_CXX)
+CONFIGURE_ARGS+= --disable-cxx
+PLIST_SUB+= CXX="@comment "
+.else
+PLIST_SUB+= CXX=""
+.endif
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "