aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnutls/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-01-11 04:33:45 +0800
committermarino <marino@FreeBSD.org>2014-01-11 04:33:45 +0800
commitdd2da7e476e7ea551c5c999bebf0baa0f89cf418 (patch)
treef92e3a291320953a8e443046c4141435ebe09afa /security/gnutls/Makefile
parentba372c50f00c454d2fbd76d768fb8822910657de (diff)
downloadfreebsd-ports-gnome-dd2da7e476e7ea551c5c999bebf0baa0f89cf418.tar.gz
freebsd-ports-gnome-dd2da7e476e7ea551c5c999bebf0baa0f89cf418.tar.zst
freebsd-ports-gnome-dd2da7e476e7ea551c5c999bebf0baa0f89cf418.zip
security/gnutls: Fix hardcoded perl paths
Perl was recently added as a build tool for gnutls, and immediately the port fails to build on systems that do not have the /usr/bin/perl symlink. The cause is harded perl path of "/usr/bin/perl". Shebangfix will fix a couple of these, REINPLACE_CMD will fix the other. Committed under the new "Just fix it" blanket, but it was tested in redports.
Diffstat (limited to 'security/gnutls/Makefile')
-rw-r--r--security/gnutls/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 9a837ba20347..f97b6b81767d 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= nettle:${PORTSDIR}/security/nettle \
CONFLICTS= gnutls-devel-[0-9]*
-USES= pathfix pkgconfig iconv gmake perl5
+USES= pathfix pkgconfig iconv gmake perl5 shebangfix
USE_PERL5= build
USE_BZIP2= yes
USE_GNOME= ltverhack
@@ -27,6 +27,7 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
LIBTOOLFILES= configure lib/configure libextra/configure
+SHEBANG_FILES= doc/scripts/gdoc doc/scripts/sort2.pl
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -fPIC
@@ -79,6 +80,8 @@ PORTEXAMPLES= *.c
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" -type f |\
${XARGS} ${REINPLACE_CMD} -e 's|[$$][(]LTLIBPTHREAD[)]||g'
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PREFIX}/bin/perl|g' \
+ ${WRKSRC}/doc/doxygen/Doxyfile.in
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}