aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnutls/Makefile
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-03-09 07:43:20 +0800
committersergei <sergei@FreeBSD.org>2004-03-09 07:43:20 +0800
commite445bcb9af2b38c53fa75720a8e74c4f7d1d9e72 (patch)
tree539cfc8c95e7f9ca23909b52fd6237d97c7abc15 /security/gnutls/Makefile
parent0fd0d02810480fac72be7d6db32aed971a224e05 (diff)
downloadfreebsd-ports-gnome-e445bcb9af2b38c53fa75720a8e74c4f7d1d9e72.tar.gz
freebsd-ports-gnome-e445bcb9af2b38c53fa75720a8e74c4f7d1d9e72.tar.zst
freebsd-ports-gnome-e445bcb9af2b38c53fa75720a8e74c4f7d1d9e72.zip
- Update to 1.0.8
- Always depend on libtasn1 and opencdk - Add libgcrypt-devel and libgpg-error dependencies - Add explicit USE_ICONV and USE_GETTEXT to properly register shared library dependencies - Add CONFLICTS to prevent installation over gnutls-devel
Diffstat (limited to 'security/gnutls/Makefile')
-rw-r--r--security/gnutls/Makefile28
1 files changed, 13 insertions, 15 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 072f729464c6..8f8c576c9d71 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnutls
-PORTVERSION= 0.8.10
-PORTREVISION= 1
+PORTVERSION= 1.0.8
CATEGORIES= security net
MASTER_SITES= ${MASTER_SITE_GNUPG} \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
@@ -18,8 +17,17 @@ MASTER_SITE_SUBDIR= alpha/gnutls
MAINTAINER= sergei@FreeBSD.org
COMMENT= GNU Transport Layer Security library
-LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gcrypt.10:${PORTSDIR}/security/libgcrypt-devel \
+ gpg-error.1:${PORTSDIR}/security/libgpg-error \
+ opencdk.8:${PORTSDIR}/security/opencdk \
+ tasn1.2:${PORTSDIR}/security/libtasn1
+CONFLICTS= gnutls-devel-*
+
+#USE_GPG?= yes
+SIG_SUFFIX= .sig.asc
+USE_ICONV= yes
+USE_GETTEXT= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -28,18 +36,8 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-included-lzo
-.if defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.2)
-LIB_DEPENDS+= tasn1.2:${PORTSDIR}/security/libtasn1
-.else
-CONFIGURE_ARGS+= --with-included-libtasn1
-.endif
-
-.if defined(WITH_OPENCDK) || exists(${LOCALBASE}/lib/libopencdk.so.6)
-LIB_DEPENDS+= opencdk.6:${PORTSDIR}/security/opencdk
-.else
-CONFIGURE_ARGS+= --disable-openpgp-authentication
-.endif
-
+MAN1= certtool.1 gnutls-cli.1 gnutls-cli-debug.1 \
+ gnutls-serv.1 gnutls-srpcrypt.1
DOCS= AUTHORS NEWS README THANKS doc/tex/*.ps
EXAMPLES= doc/examples/*.c