aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnutls
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2005-02-18 20:14:05 +0800
committersergei <sergei@FreeBSD.org>2005-02-18 20:14:05 +0800
commit7f5600dcb2f6e9031e147c970a5f73ffeb439629 (patch)
treebf6ca6587a4576fb76507b25fff9183049b8dde8 /security/gnutls
parent827a84f2019d407c5c70c0dbb0535396d418398d (diff)
downloadfreebsd-ports-gnome-7f5600dcb2f6e9031e147c970a5f73ffeb439629.tar.gz
freebsd-ports-gnome-7f5600dcb2f6e9031e147c970a5f73ffeb439629.tar.zst
freebsd-ports-gnome-7f5600dcb2f6e9031e147c970a5f73ffeb439629.zip
- Depend on pkg-config to allow for clean package deinstallation
(due to presence of files installed into ${PREFIX}/libdata/pkgconfig) - Remove patches in favor of simpler REINPLACE substitution PR: ports/77279 (based on) Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
Diffstat (limited to 'security/gnutls')
-rw-r--r--security/gnutls/Makefile7
-rw-r--r--security/gnutls/files/patch-lib_Makefile.in11
-rw-r--r--security/gnutls/files/patch-libextra_Makefile.in11
3 files changed, 7 insertions, 22 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index f28a4314b05e..90009b1249c8 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnutls
PORTVERSION= 1.0.24
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= ${MASTER_SITE_GNUPG} \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
@@ -34,6 +35,8 @@ USE_GPG?= yes
SIG_SUFFIX= .sig
USE_ICONV= yes
USE_GETTEXT= yes
+USE_GNOME= pkgconfig
+USE_REINPLACE= yes
USE_INC_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -47,6 +50,10 @@ MAN1= certtool.1 gnutls-cli.1 gnutls-cli-debug.1 \
DOCS= AUTHORS NEWS README THANKS doc/tex/*.ps
EXAMPLES= doc/examples/*.c
+post-patch:
+ @${REINPLACE_CMD} -e 's,(libdir)/pkgconfig,(prefix)/libdata/pkgconfig,' \
+ ${WRKSRC}/lib/Makefile.in ${WRKSRC}/libextra/Makefile.in
+
post-install:
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
diff --git a/security/gnutls/files/patch-lib_Makefile.in b/security/gnutls/files/patch-lib_Makefile.in
deleted file mode 100644
index edc8e9ace966..000000000000
--- a/security/gnutls/files/patch-lib_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Sun Nov 14 00:54:35 2004
-+++ lib/Makefile.in Fri Jan 28 16:11:24 2005
-@@ -296,7 +296,7 @@
- m4data_DATA = libgnutls.m4
-
- # Pkg-config script.
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = gnutls.pc
- DISTCLEANFILES = $(pkgconfig_DATA)
- LIBGNUTLS_EXPORTS = -export-symbols-regex '^(_gnutls|gnutls|_E_).*'
diff --git a/security/gnutls/files/patch-libextra_Makefile.in b/security/gnutls/files/patch-libextra_Makefile.in
deleted file mode 100644
index 3c088dfd7e51..000000000000
--- a/security/gnutls/files/patch-libextra_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- libextra/Makefile.in.orig Fri Jan 28 16:38:05 2005
-+++ libextra/Makefile.in Fri Jan 28 16:38:25 2005
-@@ -306,7 +306,7 @@ m4datadir = $(datadir)/aclocal
- m4data_DATA = libgnutls-extra.m4
-
- # Pkg-config script.
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = gnutls-extra.pc
- DISTCLEANFILES = $(pkgconfig_DATA)
- LIBGNUTLS_EXTRA_EXPORTS = -export-symbols-regex '^gnutls.*'