aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnutls
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2008-07-30 16:52:37 +0800
committerdelphij <delphij@FreeBSD.org>2008-07-30 16:52:37 +0800
commitf9f85e967850801cd072ca2951f6a0b5a83b5e21 (patch)
tree0d8dbb92992a71dcdb5f5f2cdb51c6b725674735 /security/gnutls
parentceb87ef46c7356714e3cb5db7351970d29d25c64 (diff)
downloadfreebsd-ports-gnome-f9f85e967850801cd072ca2951f6a0b5a83b5e21.tar.gz
freebsd-ports-gnome-f9f85e967850801cd072ca2951f6a0b5a83b5e21.tar.zst
freebsd-ports-gnome-f9f85e967850801cd072ca2951f6a0b5a83b5e21.zip
Fix broken header installed by gnutls: it would silently break ports
that makes use of gnutls_certificate_print_formats_t enum.
Diffstat (limited to 'security/gnutls')
-rw-r--r--security/gnutls/Makefile1
-rw-r--r--security/gnutls/files/patch-includes__gnutls__gnutls.h.in11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 56efd3dbe261..bcde592a06b9 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnutls
PORTVERSION= 2.4.1
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= http://josefsson.org/gnutls/releases/ \
ftp://ftp.gnutls.org/pub/gnutls/ \
diff --git a/security/gnutls/files/patch-includes__gnutls__gnutls.h.in b/security/gnutls/files/patch-includes__gnutls__gnutls.h.in
new file mode 100644
index 000000000000..7af3fcf9e17d
--- /dev/null
+++ b/security/gnutls/files/patch-includes__gnutls__gnutls.h.in
@@ -0,0 +1,11 @@
+--- ./includes/gnutls/gnutls.h.in.orig 2008-06-30 13:45:51.000000000 -0700
++++ ./includes/gnutls/gnutls.h.in 2008-07-30 01:39:55.348483886 -0700
+@@ -287,7 +287,7 @@
+ {
+ GNUTLS_CRT_PRINT_FULL,
+ GNUTLS_CRT_PRINT_ONELINE,
+- GNUTLS_CRT_PRINT_UNSIGNED_FULL,
++ GNUTLS_CRT_PRINT_UNSIGNED_FULL
+ } gnutls_certificate_print_formats_t;
+
+ typedef enum