aboutsummaryrefslogtreecommitdiffstats
path: root/security/heimdal
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2009-09-02 11:27:29 +0800
committerbland <bland@FreeBSD.org>2009-09-02 11:27:29 +0800
commit16852c51467b15b5d09daf1cd2776b6641e16813 (patch)
tree3090eecf572ad3e6f49a37478a76ad4f52f4e044 /security/heimdal
parent2c5d5ece87bf03f2c906716bdc3c4c4e1828aa30 (diff)
downloadfreebsd-ports-gnome-16852c51467b15b5d09daf1cd2776b6641e16813.tar.gz
freebsd-ports-gnome-16852c51467b15b5d09daf1cd2776b6641e16813.tar.zst
freebsd-ports-gnome-16852c51467b15b5d09daf1cd2776b6641e16813.zip
Fix invalid malloc in LDAP backend.
PR: 128025
Diffstat (limited to 'security/heimdal')
-rw-r--r--security/heimdal/Makefile1
-rw-r--r--security/heimdal/files/patch-lib__hdb__hdb-ldap.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index fb4912501989..094938c5594f 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= heimdal
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= http://ftp.pdc.kth.se/pub/heimdal/src/ \
ftp://ftp.pdc.kth.se/pub/heimdal/src/ \
diff --git a/security/heimdal/files/patch-lib__hdb__hdb-ldap.c b/security/heimdal/files/patch-lib__hdb__hdb-ldap.c
new file mode 100644
index 000000000000..e26137412ce5
--- /dev/null
+++ b/security/heimdal/files/patch-lib__hdb__hdb-ldap.c
@@ -0,0 +1,11 @@
+--- lib/hdb/hdb-ldap.c 2008-10-12 01:15:38.000000000 +0000
++++ lib/hdb/hdb-ldap.c 2008-10-12 01:15:55.000000000 +0000
+@@ -222,7 +222,7 @@
+
+ (*modlist)[cMods]->mod_bvalues = bv;
+
+- bv[i] = ber_memalloc(sizeof(*bv));;
++ bv[i] = ber_memalloc(sizeof(**bv));;
+ if (bv[i] == NULL)
+ return ENOMEM;
+