aboutsummaryrefslogtreecommitdiffstats
path: root/security/hs-digest-ghc
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2009-01-24 07:47:58 +0800
committerpgj <pgj@FreeBSD.org>2009-01-24 07:47:58 +0800
commit41139906e9dbfe776d429c15e7a685295698fb0d (patch)
treed8f313573e49393c55f751f2615f5874e7c2f84b /security/hs-digest-ghc
parent731ff2acef218dbed7601dca2b8810b59a6b12e7 (diff)
downloadfreebsd-ports-gnome-41139906e9dbfe776d429c15e7a685295698fb0d.tar.gz
freebsd-ports-gnome-41139906e9dbfe776d429c15e7a685295698fb0d.tar.zst
freebsd-ports-gnome-41139906e9dbfe776d429c15e7a685295698fb0d.zip
This package provides efficient cryptographic hash implementations for
strict and lazy bytestrings for the functional programming language Haskell. WWW: http://hackage.haskell.org/cgi-bin/hackage-scripts/package/digest Reviewed by: gabor Approved by: tabthorpe
Diffstat (limited to 'security/hs-digest-ghc')
-rw-r--r--security/hs-digest-ghc/Makefile55
-rw-r--r--security/hs-digest-ghc/distinfo3
-rw-r--r--security/hs-digest-ghc/pkg-descr5
-rw-r--r--security/hs-digest-ghc/pkg-plist13
4 files changed, 76 insertions, 0 deletions
diff --git a/security/hs-digest-ghc/Makefile b/security/hs-digest-ghc/Makefile
new file mode 100644
index 000000000000..a9a5cd77712b
--- /dev/null
+++ b/security/hs-digest-ghc/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: hs-digest-ghc
+# Date created: January 22, 2009
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= digest
+PORTVERSION= 0.0.0.2
+CATEGORIES= security haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+PKGNAMESUFFIX= -ghc
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Efficient cryptographic hash implementations in Haskell
+
+BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+
+GHC_VERSION= 6.8.3
+CABALCMD= ${LOCALBASE}/bin/runghc Setup.hs
+CABALDIR= lib/ghc-${GHC_VERSION}/cabal
+
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${CABALDIR}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= LICENSE html
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${PREFIX}/${CABALDIR} --libsubdir='' --datasubdir=''
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+PLIST_SUB+= RMLIC="@comment "
+.else
+PLIST_SUB+= RMLIC=""
+.endif
+
+do-configure:
+ cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+
+do-build:
+ cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${CABALCMD} haddock
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${CABALCMD} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${CABALDIR}/${PORTNAME}-register.sh
+
+.include <bsd.port.mk>
diff --git a/security/hs-digest-ghc/distinfo b/security/hs-digest-ghc/distinfo
new file mode 100644
index 000000000000..26a631db0ae8
--- /dev/null
+++ b/security/hs-digest-ghc/distinfo
@@ -0,0 +1,3 @@
+MD5 (digest-0.0.0.2.tar.gz) = c093bf8ba6b0e94492e125d2aae710e1
+SHA256 (digest-0.0.0.2.tar.gz) = f91066f0f1c3b7b0126e8bbcf774d8a1d3f4fa78cd28693411cda7a37172b8ac
+SIZE (digest-0.0.0.2.tar.gz) = 44339
diff --git a/security/hs-digest-ghc/pkg-descr b/security/hs-digest-ghc/pkg-descr
new file mode 100644
index 000000000000..c57435d330e6
--- /dev/null
+++ b/security/hs-digest-ghc/pkg-descr
@@ -0,0 +1,5 @@
+This package provides efficient cryptographic hash implementations for
+strict and lazy bytestrings for the functional programming language
+Haskell.
+
+WWW: http://hackage.haskell.org/cgi-bin/hackage-scripts/package/digest
diff --git a/security/hs-digest-ghc/pkg-plist b/security/hs-digest-ghc/pkg-plist
new file mode 100644
index 000000000000..a379656b2624
--- /dev/null
+++ b/security/hs-digest-ghc/pkg-plist
@@ -0,0 +1,13 @@
+%%SUBDIR%%/Data/Digest/Adler32.hi
+%%SUBDIR%%/Data/Digest/CRC32.hi
+%%SUBDIR%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%SUBDIR%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%SUBDIR%%/%%PORTNAME%%-register.sh
+%%RMLIC%%%%DOCSDIR%%/LICENSE
+%%RMLIC%%@dirrm %%DOCSDIR%%
+@dirrmtry %%SUBDIR%%/Data/Digest
+@dirrmtry %%SUBDIR%%/Data
+@exec sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
+@exec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec ghc-pkg unregister %%PORTNAME%%
+@unexec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old