aboutsummaryrefslogtreecommitdiffstats
path: root/security/hs-digest
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 06:27:04 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 06:27:04 +0800
commit6b344a3376b95d240fe4964227ad55fffef31f18 (patch)
treea8ef1fac649d52b5b83d7f0df1b754aae64f4ab2 /security/hs-digest
parentd420a750b5475fbd9dd66ea76b89e70baf792eaa (diff)
downloadfreebsd-ports-gnome-6b344a3376b95d240fe4964227ad55fffef31f18.tar.gz
freebsd-ports-gnome-6b344a3376b95d240fe4964227ad55fffef31f18.tar.zst
freebsd-ports-gnome-6b344a3376b95d240fe4964227ad55fffef31f18.zip
- Update to 0.0.1.1
Obtained from: FreeBSD Haskell
Diffstat (limited to 'security/hs-digest')
-rw-r--r--security/hs-digest/Makefile6
-rw-r--r--security/hs-digest/distinfo4
-rw-r--r--security/hs-digest/pkg-descr6
3 files changed, 9 insertions, 7 deletions
diff --git a/security/hs-digest/Makefile b/security/hs-digest/Makefile
index da2f138c11a5..b61ea190cab0 100644
--- a/security/hs-digest/Makefile
+++ b/security/hs-digest/Makefile
@@ -6,15 +6,17 @@
#
PORTNAME= digest
-PORTVERSION= 0.0.1.0
+PORTVERSION= 0.0.1.1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
-COMMENT= Efficient cryptographic hash implementations in Haskell
+COMMENT= Various cryptographic hashes for Bytestrings
LICENSE= BSD
CABAL_SETUP= Setup.hs
+USE_CABAL= zlib
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/hs-digest/distinfo b/security/hs-digest/distinfo
index 8702ce4e657d..e5d2a836dd9d 100644
--- a/security/hs-digest/distinfo
+++ b/security/hs-digest/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/digest-0.0.1.0.tar.gz) = 40319762afc05823920126f13cba02b06544ba039e08c3f63db2ed084a9a4edc
-SIZE (cabal/digest-0.0.1.0.tar.gz) = 2519
+SHA256 (cabal/digest-0.0.1.1.tar.gz) = 7bb8b85959cfb3c6539aa2f2104c14aec9758a3a5d6039aba975299fdcd704d4
+SIZE (cabal/digest-0.0.1.1.tar.gz) = 3781
diff --git a/security/hs-digest/pkg-descr b/security/hs-digest/pkg-descr
index c57435d330e6..3b66ffa2fdbf 100644
--- a/security/hs-digest/pkg-descr
+++ b/security/hs-digest/pkg-descr
@@ -1,5 +1,5 @@
This package provides efficient cryptographic hash implementations for
-strict and lazy bytestrings for the functional programming language
-Haskell.
+strict and lazy bytestrings. For now, CRC32 and Adler32 are supported;
+they are implemented as FFI bindings to efficient code from zlib.
-WWW: http://hackage.haskell.org/cgi-bin/hackage-scripts/package/digest
+WWW: http://hackage.haskell.org/package/digest