aboutsummaryrefslogtreecommitdiffstats
path: root/security/hydra/Makefile
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2003-10-20 18:48:56 +0800
committerosa <osa@FreeBSD.org>2003-10-20 18:48:56 +0800
commit24dbeeab720c2222aa8bf272b14736d44f275239 (patch)
tree9d6e42838a69f56db7eb1c612bcb74971d53bbc7 /security/hydra/Makefile
parentb360c96177a6cbc7c4d7dd741e4104756cb7d4d4 (diff)
downloadfreebsd-ports-gnome-24dbeeab720c2222aa8bf272b14736d44f275239.tar.gz
freebsd-ports-gnome-24dbeeab720c2222aa8bf272b14736d44f275239.tar.zst
freebsd-ports-gnome-24dbeeab720c2222aa8bf272b14736d44f275239.zip
Fix build on -CURRENT [1]
Respect CC/CFLAGS, fix installation path [2] Bump PORTREVISION. PR: ports/58164 Submitted by: Samy Al Bahra <samy@kerneled.com> [1], osa [2] Approved by: Laurent LEVIER <llevier@argosnet.com> (maintainer)
Diffstat (limited to 'security/hydra/Makefile')
-rw-r--r--security/hydra/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index bf13da86ee54..a476e8088ba1 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -8,6 +8,7 @@
PORTNAME= hydra
PORTVERSION= 2.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.thc.org/releases/ \
${MASTER_SITE_PACKETSTORM}
@@ -16,17 +17,15 @@ MASTER_SITE_SUBDIR= groups/thc
MAINTAINER= llevier@argosnet.com
COMMENT= Bruce Force Attack Utility working on multiple network services
-.include <bsd.port.pre.mk>
-
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|CC = gcc||; \
+ s|-O2|${CFLAGS}|' \
+ ${WRKSRC}/Makefile.am
-.if !target(post-install) && (${PORTNAME} == "hydra")
-post-install:
- @${STRIP_CMD} ${PREFIX}/bin/hydra
-.endif
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/hydra ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>