aboutsummaryrefslogtreecommitdiffstats
path: root/security/hydra
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-11-22 05:56:25 +0800
committerpav <pav@FreeBSD.org>2006-11-22 05:56:25 +0800
commit5273ef0662701584586820f95505b062f5975f71 (patch)
tree44dc36cc215382e71a7355acb21d58204c87efa1 /security/hydra
parentb631b66e7ff6c7dbf1d3bd003d35f62e7961bdff (diff)
downloadfreebsd-ports-gnome-5273ef0662701584586820f95505b062f5975f71.tar.gz
freebsd-ports-gnome-5273ef0662701584586820f95505b062f5975f71.tar.zst
freebsd-ports-gnome-5273ef0662701584586820f95505b062f5975f71.zip
- Update to 5.3
- Fix detection for optional subversion module PR: ports/104891 Submitted by: Nicolas Blais <nb_root@videotron.ca> Approved by: maintainer timeout (3 weeks)
Diffstat (limited to 'security/hydra')
-rw-r--r--security/hydra/Makefile2
-rw-r--r--security/hydra/distinfo6
-rw-r--r--security/hydra/files/patch-configure51
-rw-r--r--security/hydra/files/patch-hydra-pcanywhere.c21
4 files changed, 55 insertions, 25 deletions
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index c39ed865455e..9b2d09dc9e94 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= hydra
-PORTVERSION= 5.2
+PORTVERSION= 5.3
CATEGORIES= security
MASTER_SITES= http://www.thc.org/releases/ \
${MASTER_SITE_PACKETSTORM}
diff --git a/security/hydra/distinfo b/security/hydra/distinfo
index bc3f76345d0d..f3a3ef192345 100644
--- a/security/hydra/distinfo
+++ b/security/hydra/distinfo
@@ -1,3 +1,3 @@
-MD5 (hydra-5.2-src.tar.gz) = 75c27a72ef87daf9026e06992c95d58f
-SHA256 (hydra-5.2-src.tar.gz) = a3793901ab06ebc896a9cb28db9a4da122515151f2227f4e16921d446a5cffe2
-SIZE (hydra-5.2-src.tar.gz) = 189979
+MD5 (hydra-5.3-src.tar.gz) = 9c13a4909387284cebe867587be2fd98
+SHA256 (hydra-5.3-src.tar.gz) = cd64dd23e6f5e21fe3cffbbeefeb7f4f6fd5ac8339add63fd102886694e7028a
+SIZE (hydra-5.3-src.tar.gz) = 207043
diff --git a/security/hydra/files/patch-configure b/security/hydra/files/patch-configure
new file mode 100644
index 000000000000..27f225fcb9df
--- /dev/null
+++ b/security/hydra/files/patch-configure
@@ -0,0 +1,51 @@
+--- configure.orig Sat Oct 28 19:51:24 2006
++++ configure Sat Oct 28 19:42:03 2006
+@@ -118,11 +118,11 @@
+ echo " ... NOT found, module postgres disabled"
+ fi
+
+-echo "Checking for SVN (ibsvn_client-1 libapr-0.so libaprutil-0.so) ..."
++echo "Checking for SVN (ibsvn_client-1 libapr-1.so libaprutil-1.so) ..."
+ for i in $LIBDIRS /lib /usr/lib /usr/local/lib /opt/local/lib .
+ do
+ if [ "X" = "X$SVN_PATH" ]; then
+- if [ -f "$i/libsvn_client-1.so" ]&&[ -f "$i/libapr-0.so" ]&&[ -f "$i/libaprutil-0.so" ]; then
++ if [ -f "$i/libsvn_client-1.so" ]&&[ -f "$i/libapr-1.so" ]&&[ -f "$i/libaprutil-1.so" ]; then
+ SVN_PATH="$i"
+ fi
+ fi
+@@ -202,8 +202,8 @@
+ fi
+ fi
+ if [ "X" = "X$APR_IPATH" ]; then
+- if [ -d "$i/apr-0" ]; then
+- APR_IPATH="$i/apr-0"
++ if [ -d "$i/apr-1" ]; then
++ APR_IPATH="$i/apr-1"
+ fi
+ fi
+ done
+@@ -220,8 +220,8 @@
+ fi
+ fi
+ if [ "X" = "X$APR_IPATH" ]; then
+- if [ -d "$i/apr-0" ]; then
+- APR_IPATH="$i/apr-0"
++ if [ -d "$i/apr-1" ]; then
++ APR_IPATH="$i/apr-1"
+ fi
+ fi
+ done
+@@ -379,10 +379,10 @@
+ XLIBS="$XLIBS -lpq"
+ fi
+ if [ -n "$SVN_PATH" ]; then
+- XLIBS="$XLIBS -lsvn_client-1 -lapr-0 -laprutil-0"
++ XLIBS="$XLIBS -lsvn_client-1 -lapr-1 -laprutil-1"
+ fi
+ if [ -n "$SVN_PATH" ]; then
+- XLIBS="$XLIBS -lsvn_client-1 -lapr-0 -laprutil-0"
++ XLIBS="$XLIBS -lsvn_client-1 -lapr-1 -laprutil-1"
+ fi
+ if [ -n "$SSH_PATH" ]; then
+ XLIBS="$XLIBS -lssh"
diff --git a/security/hydra/files/patch-hydra-pcanywhere.c b/security/hydra/files/patch-hydra-pcanywhere.c
deleted file mode 100644
index ef1b59b7cb59..000000000000
--- a/security/hydra/files/patch-hydra-pcanywhere.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- hydra-pcanywhere.c.orig Wed Sep 7 21:59:26 2005
-+++ hydra-pcanywhere.c Mon Oct 10 20:22:28 2005
-@@ -111,8 +111,9 @@
- char clogin[128]="";
- char cpass[128]="";
- int ret,i;
--
-+ char *server[5];
- char *client[4];
-+
- int clientsize[4];
- client[0]="\x00\x00\x00\x00";
- clientsize[0]=4;
-@@ -123,7 +124,6 @@
- client[3]="\x6f\x62\x01\x02\x00\x00\x00";
- clientsize[3]=7;
-
-- char *server[5];
- server[0]= "nter";
- server[1]="\x1B\x61";
- server[2]="\0x1B\0x62";