aboutsummaryrefslogtreecommitdiffstats
path: root/security/john
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-10-06 05:48:44 +0800
committerkris <kris@FreeBSD.org>2002-10-06 05:48:44 +0800
commit13cddbdeb404d374704b3e9d858178c2530e8a6e (patch)
tree991c289caa7db2a0df077207c2c23d01ac5ade25 /security/john
parentf24f959a4a39fdbd03113b0735bfd21e83b2461b (diff)
downloadfreebsd-ports-gnome-13cddbdeb404d374704b3e9d858178c2530e8a6e.tar.gz
freebsd-ports-gnome-13cddbdeb404d374704b3e9d858178c2530e8a6e.tar.zst
freebsd-ports-gnome-13cddbdeb404d374704b3e9d858178c2530e8a6e.zip
Switch over to using <bsd.cpu.mk> feature tests to enable asm
optimization. Approved by: maintainer timeout
Diffstat (limited to 'security/john')
-rw-r--r--security/john/Makefile27
1 files changed, 9 insertions, 18 deletions
diff --git a/security/john/Makefile b/security/john/Makefile
index ccf8a6ed350d..8a98570960f7 100644
--- a/security/john/Makefile
+++ b/security/john/Makefile
@@ -21,26 +21,17 @@ MAINTAINER= dominic_marks@btinternet.com
OSNAME= ${OPSYS:S/F/f/:S/N/n/:S/O/o/:S/B/b/:S/S/s/:S/D/d/}
-.if (${ARCH} == "i386")
+.if ${MACHINE_ARCH} == "i386"
ARCHNAME= x86
+. if ${MACHINE_CPU:Mk6}
+ALL_TARGET= ${OSNAME}-${ARCHNAME}-k6-elf
+. elif ${MACHINE_CPU:Mmmx}
+ALL_TARGET= ${OSNAME}-${ARCHNAME}-mmx-elf
+. else
+ALL_TARGET= ${OSNAME}-${ARCHNAME}-any-elf
+. endif
.else
-ARCHNAME= ${ARCH}
-.endif
-
-# could do something w/
-# if sysctl -n hw.model | grep AMD >/dev/null ; then echo AMD ; fi
-.if defined(HAVE_K6)
-ALL_TARGET= ${OSNAME}-${ARCHNAME}-k6-BINFMT
-.elif defined(HAVE_MMX)
-ALL_TARGET= ${OSNAME}-${ARCHNAME}-mmx-BINFMT
-.else
-ALL_TARGET= ${OSNAME}-${ARCHNAME}-any-BINFMT
-.endif
-
-.if ${PORTOBJFORMAT} == "elf"
-ALL_TARGET:= ${ALL_TARGET:S/BINFMT$/${PORTOBJFORMAT}/}
-.else
-ALL_TARGET:= ${ALL_TARGET:S/BINFMT$/a.out/}
+ARCHNAME= ${MACHINE_ARCH}
.endif
WRKSRC= ${WRKDIR}/${DISTNAME}/src