aboutsummaryrefslogtreecommitdiffstats
path: root/security/libbeid
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-05-17 03:16:36 +0800
committertijl <tijl@FreeBSD.org>2017-05-17 03:16:36 +0800
commit0f61213528d75ab6e3b9e1bc8e679f8c0b558d24 (patch)
tree0f06636830310ad51743f9d53bc39a7b99d7f45f /security/libbeid
parent147c05406f9c6b4c0b38ffa6c5486dc583b3678f (diff)
downloadfreebsd-ports-gnome-0f61213528d75ab6e3b9e1bc8e679f8c0b558d24.tar.gz
freebsd-ports-gnome-0f61213528d75ab6e3b9e1bc8e679f8c0b558d24.tar.zst
freebsd-ports-gnome-0f61213528d75ab6e3b9e1bc8e679f8c0b558d24.zip
Update to 4.2.8.
Diffstat (limited to 'security/libbeid')
-rw-r--r--security/libbeid/Makefile29
-rw-r--r--security/libbeid/distinfo6
-rw-r--r--security/libbeid/files/patch-Makefile.am6
-rw-r--r--security/libbeid/files/patch-cardlayer75
-rw-r--r--security/libbeid/files/patch-common80
-rw-r--r--security/libbeid/files/patch-configure.ac35
-rw-r--r--security/libbeid/files/patch-dialogs166
-rw-r--r--security/libbeid/files/patch-pkcs1182
-rw-r--r--security/libbeid/pkg-plist5
9 files changed, 82 insertions, 402 deletions
diff --git a/security/libbeid/Makefile b/security/libbeid/Makefile
index da52937bfb09..4edb4ccc3741 100644
--- a/security/libbeid/Makefile
+++ b/security/libbeid/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= libbeid
-PORTVERSION= 4.1.19
+PORTVERSION= 4.2.8
DISTVERSIONPREFIX= v
CATEGORIES= security
@@ -17,21 +17,26 @@ USE_GITHUB= yes
GH_ACCOUNT= Fedict
GH_PROJECT= eid-mw
-USES= autoreconf dos2unix libtool pkgconfig
+USES= autoreconf gettext-tools libtool pkgconfig
USE_GNOME= gtk30
-DOS2UNIX_FILES= cardcomm/pkcs11/src/common/datafile.cpp \
- cardcomm/pkcs11/src/common/logbase.cpp \
- cardcomm/pkcs11/src/common/util.cpp \
- cardcomm/pkcs11/src/dialogs/dialogs.h \
- cardcomm/pkcs11/src/log.h
-
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-static --with-gtkvers=3
+CONFIGURE_ARGS= --disable-p11kit --disable-static --with-gtkvers=3
INSTALL_TARGET= install-strip
-post-patch:
- @${REINPLACE_CMD} '/^libbeidpkcs11_la_LIBADD =/s/-ldl//' \
- ${WRKSRC}/cardcomm/pkcs11/src/Makefile.am
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime
+
+post-install:
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/pkgconfig
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/pkcs11
+ ${LN} -s ../libbeidpkcs11.so.0 \
+ ${STAGEDIR}${PREFIX}/lib/pkcs11/beidpkcs11.so
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/p11-kit/modules
+ ${INSTALL_DATA} ${WRKSRC}/cardcomm/pkcs11/src/beid.module \
+ ${STAGEDIR}${PREFIX}/share/p11-kit/modules
.include <bsd.port.mk>
diff --git a/security/libbeid/distinfo b/security/libbeid/distinfo
index b4dc4b6a8446..ef7863692427 100644
--- a/security/libbeid/distinfo
+++ b/security/libbeid/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1479827204
-SHA256 (Fedict-eid-mw-v4.1.19_GH0.tar.gz) = a9af2a99f3d2a93934cad44530a99a403c83ddfbe9caddc2db0b3e4f9a8b5758
-SIZE (Fedict-eid-mw-v4.1.19_GH0.tar.gz) = 7625904
+TIMESTAMP = 1494948688
+SHA256 (Fedict-eid-mw-v4.2.8_GH0.tar.gz) = 6b998bd14897f640e29f9140ee457ea963162a409c7aff646e3346b0b0ae2e65
+SIZE (Fedict-eid-mw-v4.2.8_GH0.tar.gz) = 7076407
diff --git a/security/libbeid/files/patch-Makefile.am b/security/libbeid/files/patch-Makefile.am
index 7fade5f12b2e..4f49e6c29d14 100644
--- a/security/libbeid/files/patch-Makefile.am
+++ b/security/libbeid/files/patch-Makefile.am
@@ -1,10 +1,10 @@
---- Makefile.am.orig 2015-02-19 13:59:02 UTC
+--- Makefile.am.orig 2017-05-10 13:28:54 UTC
+++ Makefile.am
@@ -1,7 +1,7 @@
ACLOCAL_AMFLAGS = -I scripts/m4
- EXTRA_DIST = scripts/build-aux/config.rpath debian build-debian.sh rpm doc
+ EXTRA_DIST = scripts/build-aux/config.rpath scripts/build-aux/genver.sh .version debian rpm doc
--SUBDIRS=cardcomm/pkcs11/src tests/unit plugins_tools/xpi plugins_tools/aboutmw/gtk
+-SUBDIRS=cardcomm/pkcs11/src doc/sdk/include/rsaref220 plugins_tools/util tests/unit plugins_tools/xpi plugins_tools/aboutmw/gtk plugins_tools/eid-viewer
+SUBDIRS=cardcomm/pkcs11/src
xpipackage:
diff --git a/security/libbeid/files/patch-cardlayer b/security/libbeid/files/patch-cardlayer
index 6e1f30695493..e8214e344e28 100644
--- a/security/libbeid/files/patch-cardlayer
+++ b/security/libbeid/files/patch-cardlayer
@@ -1,65 +1,6 @@
---- cardcomm/pkcs11/src/cardlayer/card.cpp.orig 2015-10-09 08:01:44 UTC
-+++ cardcomm/pkcs11/src/cardlayer/card.cpp
-@@ -160,7 +160,7 @@ tCacheInfo CCard::GetCacheInfo(const std
- {
- // By default no caching, card must implement this method
- // to allow certain files to be cached (in a certain way).
-- tCacheInfo dontCache = {DONT_CACHE};
-+ tCacheInfo dontCache = {DONT_CACHE,0};
-
- return dontCache;
- }
---- cardcomm/pkcs11/src/cardlayer/pkcs15.cpp.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/cardlayer/pkcs15.cpp
-@@ -27,7 +27,7 @@ namespace eIDMW
- {
-
- const static tPin PinInvalid = {false, "",0,0,0,0,0,0, 0, 0, 0, 0, 0,PIN_ENC_BCD,"",""};
-- const static tCert CertInvalid = {false, "", 0, 0,0,0};
-+ const static tCert CertInvalid = {false, "", 0, 0,0,0,false,false,""};
- const static tPrivKey PrivKeyInvalid = {false, "", 0,0,0,0,0,0,0,"", 0,false};
-
- // Hardcoded Beid V1 PINs, keys, certs -- to be removed
-@@ -59,13 +59,12 @@ namespace eIDMW
- const std::string defaultEFODF = "3F00DF005031";
-
-
-- CPKCS15::CPKCS15(void) : m_poContext(NULL), m_poParser(NULL)
-+ CPKCS15::CPKCS15(void) : m_poParser(NULL)
- {
- Clear();
- }
-
- CPKCS15::CPKCS15(CContext *poContext) :
-- m_poContext(poContext),
- m_poParser(NULL)
- {
- Clear();
---- cardcomm/pkcs11/src/cardlayer/pkcs15.h.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/cardlayer/pkcs15.h
-@@ -90,7 +90,6 @@ namespace eIDMW
-
- private:
- CCard *m_poCard;
-- CContext *m_poContext;
- PKCS15Parser *m_poParser;
-
- #ifdef WIN32
---- cardcomm/pkcs11/src/cardlayer/reader.cpp.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/cardlayer/reader.cpp
-@@ -284,8 +284,7 @@ std::string CReader::GetSerialNr()
- }
- catch(CMWException &e)
- {
-- unsigned long err = e.GetError();
-- err = err;
-+ (void)e.GetError();
- return m_oPKCS15.GetSerialNr();
- }
- }
---- cardcomm/pkcs11/src/cardlayer/threadpool.cpp.orig 2015-02-19 13:59:02 UTC
+--- cardcomm/pkcs11/src/cardlayer/threadpool.cpp.orig 2017-05-10 13:28:54 UTC
+++ cardcomm/pkcs11/src/cardlayer/threadpool.cpp
-@@ -81,7 +81,7 @@ void CEventCallbackThread::Run()
+@@ -90,7 +90,7 @@ void CEventCallbackThread::Run()
m_bRunning = false;
}
@@ -68,14 +9,14 @@
{
m_bStop = true;
}
---- cardcomm/pkcs11/src/cardlayer/threadpool.h.orig 2015-02-19 13:59:02 UTC
+--- cardcomm/pkcs11/src/cardlayer/threadpool.h.orig 2017-05-10 13:28:54 UTC
+++ cardcomm/pkcs11/src/cardlayer/threadpool.h
-@@ -42,7 +42,7 @@ public:
+@@ -47,7 +47,7 @@ public:
- void Run();
+ void Run();
-- void Stop();
-+ void Stop(unsigned long ulSleepFrequency=100);
+- void Stop();
++ void Stop(unsigned long ulSleepFrequency=100);
- bool HasStopped();
+ bool HasStopped();
diff --git a/security/libbeid/files/patch-common b/security/libbeid/files/patch-common
index 34d9e2854c8b..4bb5ca0972c0 100644
--- a/security/libbeid/files/patch-common
+++ b/security/libbeid/files/patch-common
@@ -1,65 +1,21 @@
---- cardcomm/pkcs11/src/common/datafile.cpp.orig 2015-06-02 08:02:25 UTC
-+++ cardcomm/pkcs11/src/common/datafile.cpp
-@@ -249,8 +249,7 @@ bool CDataFile::Load(bool bLock)
- while ( !bDone )
- {
- memset(buffer, 0, MAX_BUFFER_LEN);
-- wchar_t* tmp = fgetws( buffer, MAX_BUFFER_LEN, m_stream);
-- tmp=tmp; // avoid warning
-+ (void)fgetws( buffer, MAX_BUFFER_LEN, m_stream);
-
- szLine = buffer;
- Trim(szLine);
-@@ -1011,8 +1010,7 @@ int WriteLn(FILE * stream, wchar_t* fmt,
- if ( buf[nLength] != '\n' && buf[nLength] != '\r' )
- buf[nLength++] = '\n';
-
-- size_t tmp = fwrite(buf, sizeof( wchar_t ), nLength, stream);
-- tmp = tmp; // avoid warning
-+ (void)fwrite(buf, sizeof( wchar_t ), nLength, stream);
-
- return nLength;
- }
---- cardcomm/pkcs11/src/common/logbase.cpp.orig 2015-06-02 08:02:25 UTC
+--- cardcomm/pkcs11/src/common/logbase.cpp.orig 2017-05-16 16:28:03 UTC
+++ cardcomm/pkcs11/src/common/logbase.cpp
-@@ -30,11 +30,7 @@
-
- #ifndef WIN32
- #include <stdlib.h>
--#ifdef LINUX
- #include "wintypes.h"
--#else
--#include "PCSC/wintypes.h"
--#endif
- #include "sys/stat.h"
- #include "util.h"
-
-@@ -575,6 +571,7 @@ bool CLog::open(bool bWchar)
- else
- err = fopen_s(&m_f,utilStringNarrow(filename).c_str(),"a");
+@@ -639,6 +639,7 @@ namespace eIDMW
+ utilStringNarrow(filename).
+ c_str(), "a");
#else
-+ (void)bWchar;
- m_f = fopen(utilStringNarrow(filename).c_str(),"a, ccs=UTF-8");
- if (m_f == NULL) err=errno;
- #endif
---- cardcomm/pkcs11/src/common/mw_util.h.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/common/mw_util.h
-@@ -38,7 +38,6 @@
- #endif
-
- #if !defined __APPLE__ && !defined USE_WINERROR
--#include "error.h"
- #endif
-
- #ifndef HAVE_ERRNO_T
---- cardcomm/pkcs11/src/common/util.cpp.orig 2015-06-02 08:02:25 UTC
++ (void)bWchar;
+ m_f = fopen(utilStringNarrow(filename).c_str(),
+ "a, ccs=UTF-8");
+ if (m_f == NULL)
+--- cardcomm/pkcs11/src/common/util.cpp.orig 2017-05-16 16:28:03 UTC
+++ cardcomm/pkcs11/src/common/util.cpp
-@@ -376,7 +376,7 @@ void GetProcessName(wchar_t *wBuffer,uns
- /* Get our PID and build the name of the link in /proc */
- pid = getpid();
-
-- if (snprintf(linkname, sizeof(linkname), "/proc/%i/exe", pid) < 0)
-+ if (snprintf(linkname, sizeof(linkname), "/proc/%i/file", pid) < 0)
- {
- /* This should only happen on large word systems. I'm not sure
- what the proper response is here.
+@@ -221,7 +221,7 @@ namespace eIDMW
+ pid = getpid();
+
+ if (snprintf
+- (linkname, sizeof(linkname), "/proc/%i/exe",
++ (linkname, sizeof(linkname), "/proc/%i/file",
+ pid) < 0)
+ {
+ /* This should only happen on large word systems. I'm not sure
diff --git a/security/libbeid/files/patch-configure.ac b/security/libbeid/files/patch-configure.ac
index 9ecc7005906e..500a90738da5 100644
--- a/security/libbeid/files/patch-configure.ac
+++ b/security/libbeid/files/patch-configure.ac
@@ -1,27 +1,28 @@
---- configure.ac.orig 2016-10-14 12:10:30 UTC
+--- configure.ac.orig 2017-05-10 13:28:54 UTC
+++ configure.ac
@@ -1,6 +1,6 @@
AC_PREREQ([2.61])
AC_INIT([eid-mw],
-- m4_esyscmd_s(echo "4.1.18-"$(git describe --dirty|sed -e 's/-/./g')),
-+ [4.1.19-release],
+- m4_esyscmd_s(scripts/build-aux/genver.sh),
++ [4.2.8-release],
[servicedesk@fedict.be],,
[http://eid.belgium.be])
-@@ -26,7 +26,6 @@ AS_VAR_IF([GXX],[yes],[],AC_MSG_ERROR([G
- # Checks for header files.
- AC_CHECK_HEADERS([fcntl.h float.h limits.h netinet/in.h stdlib.h string.h sys/file.h sys/ioctl.h sys/time.h unistd.h malloc.h memory.h sys/timeb.h termios.h])
-
--AM_GNU_GETTEXT([external])
-
- ###### pcsc-lite ##########
- PKG_CHECK_MODULES([PCSC],[libpcsclite >= 1.4.4],
-@@ -104,7 +103,6 @@ MAINVERSION=$(echo $PACKAGE_VERSION|sed
- AC_DEFINE_UNQUOTED([MAINVERSION], $MAINVERSION, [do not change this])
- AC_SUBST(MAINVERSION)
-
--AC_CONFIG_FILES([Makefile cardcomm/pkcs11/src/Makefile tests/unit/Makefile plugins_tools/aboutmw/gtk/Makefile plugins_tools/aboutmw/gtk/about-eid-mw.desktop.sh plugins_tools/aboutmw/gtk/po/Makefile.in rpm/eid-mw.spec])
+@@ -159,16 +159,6 @@ AC_CONFIG_FILES([Makefile
+ cardcomm/pkcs11/src/Makefile
+ cardcomm/pkcs11/src/libbeidpkcs11.pc
+ cardcomm/pkcs11/src/dialogs/dialogsgtk/po/Makefile.in
+- doc/sdk/include/rsaref220/Makefile
+- tests/unit/Makefile
+- plugins_tools/util/Makefile
+- plugins_tools/aboutmw/gtk/Makefile
+- plugins_tools/aboutmw/gtk/po/Makefile.in
+- plugins_tools/eid-viewer/Makefile
+- plugins_tools/eid-viewer/test/Makefile
+- plugins_tools/eid-viewer/gtk/po/Makefile.in
+- plugins_tools/eid-viewer/gtk/eid-viewer.desktop.sh
+- rpm/eid-mw.spec])
-AC_CONFIG_SUBDIRS([plugins_tools/xpi])
-+AC_CONFIG_FILES([Makefile cardcomm/pkcs11/src/Makefile])
++ ])
AC_OUTPUT
diff --git a/security/libbeid/files/patch-dialogs b/security/libbeid/files/patch-dialogs
index e0f1837a4df8..3e49310c0027 100644
--- a/security/libbeid/files/patch-dialogs
+++ b/security/libbeid/files/patch-dialogs
@@ -1,157 +1,11 @@
---- cardcomm/pkcs11/src/dialogs/dialogs.h.orig 2015-06-02 08:02:25 UTC
-+++ cardcomm/pkcs11/src/dialogs/dialogs.h
-@@ -27,6 +27,7 @@
- #ifndef __DIALOGS_H__
- #define __DIALOGS_H__
-
-+#include <sys/types.h>
- #include <string>
-
- #ifdef WIN32
---- cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-askaccess.c.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-askaccess.c
-@@ -31,7 +31,7 @@
-
-
- enum { MSG_ACCESS_CARD_TITLE=1, MSG_ACCESS_CARD_QUESTION };
--char* beid_messages[4][3]={
-+static char const *const beid_messages[4][3]={
- {"en", "beID: Card Access", "The application [%s] wants to access the eID card. Do you want to accept it?"},
- {"nl", "beID: Lezen Kaart", "Het Programma [%s] vraagt toegang tot de eID kaart. Wil U dit toelaten?"},
- {"fr", "beID: Lecture de Carte", "l'application [%s] essaye d'accéder à la carte eID. Acceptez-vous?"},
---- cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-askpin.c.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-askpin.c
-@@ -34,7 +34,7 @@
- #define EXIT_ERROR 2
-
- enum { MSG_PIN_CODE_REQUIRED=1, MSG_PLEASE_ENTER_PIN };
--char* beid_messages[4][3]={
-+static char const *const beid_messages[4][3]={
- {"en", "beID: PIN Code Required", "The application\n[%s]\nrequests your eID PIN code."},
- {"nl", "beID: PINcode Vereist", "Het programma\n[%s]\nvraagt uw eID PINcode"},
- {"fr", "beID: Code PIN Necessaire", "l'application\n[%s]\nvous demande votre code PIN eID"},
-@@ -57,7 +57,7 @@ typedef struct
- ///////////////////////////////////////////////////////////////////////////////////////////
- void update_pin_label(PinDialogInfo *pindialog)
- {
-- int i;
-+ size_t i;
- gchar tmp[MAX_PIN_LENGTH*6];
- tmp[0]='\0';
- for(i=0;i<strlen(pindialog->pin);i++)
---- cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-badpin.c.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-badpin.c
-@@ -16,6 +16,7 @@
- * http://www.gnu.org/licenses/.
- **************************************************************************** */
-
-+#include <ctype.h>
- #include <gtk/gtk.h>
- #include <gdk/gdkkeysyms.h>
- #include <glib.h>
-@@ -30,7 +31,7 @@
- #define EXIT_ERROR 2
-
- enum msgs { MSG_INCORRECT_PIN_CODE=1, MSG_N_ATTEMPTS_LEFT, MSG_LAST_ATTEMPT };
--char* beid_messages[4][4]={
-+static char const *const beid_messages[4][4]={
- {"en", "beID: Incorrect PIN Code", "You have entered an incorrect PIN code.\nPlease note that you have only %d attempts left before your PIN is blocked.", "You have entered an incorrect PIN code.\nPlease note that at the next incorrect entry your PIN code will be blocked."},
- {"nl", "beID: Foutive PINcode", "U hebt een foutive PIN code ingegeven.\nGelieve te noteren dat u nog slechts %d pogingen hebt alvorens uw PIN code geblokkeerd wordt.", "U hebt een foutive PIN code ingegeven.\nGelieve te noteren dat bij de volgende incorrecte ingave uw PIN code geblokkeerd wordt."},
- {"fr", "beID: Code PIN incorrect", "Vous avez entré un code PIN incorrect.\nVeuillez noter qu'il ne vous reste plus que %d tentatives avant que votre PIN soit bloqué", "Vous avez entré un code PIN incorrect.\nVieullez noter qu'a la prochaine entree incorrecte votre code PIN sera bloqué"},
---- cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-changepin.c.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-changepin.c
-@@ -17,6 +17,7 @@
- * http://www.gnu.org/licenses/.
-
- **************************************************************************** */
-+#include <ctype.h>
- #include <gtk/gtk.h>
- #include <gdk/gdkkeysyms.h>
- #include <glib.h>
-@@ -36,7 +37,7 @@
- #define EXIT_ERROR 2
-
- enum { MSG_CHANGE_PIN_CODE=1, MSG_PLEASE_ENTER_OLD_AND_NEW_PINS, MSG_CURRENT_PIN, MSG_NEW_PIN, MSG_NEW_PIN_AGAIN };
--char* beid_messages[4][6]={
-+static char const *const beid_messages[4][6]={
- {"en", "beID: Change PIN Code", "Request from Application [%s]:\n\nPlease enter your current eID PIN, followed by your new eID PIN (twice)", "Current PIN:", "New PIN:", "New PIN (again):"},
- {"nl", "beID: PIN Code Wijzigen", "Verzoek van programma [%s]:\n\nGelieve Uw bestaande eID PIN code, en tweemaal uw nieuwe eID PINcode in te voeren.", "Huidige PIN:", "Nieuwe PIN:", "Nieuwe PIN (opnieuw):"},
- {"fr", "beID: Changement de code PIN", "Demande de l'application [%s]:\n\nVeuillez entrer votre code PIN eID existant, suivi de votre nouveau code PIN eID (2 fois)", "Code PIN existant:", "Nouveau code PIN:","Nouveau code PIN (verification):"},
---- cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-i18n.h.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-i18n.h
-@@ -1,7 +1,7 @@
--char* _MSG_(int msgnum)
-+char const *_MSG_(int msgnum)
- {
-- char* message=beid_messages[0][msgnum]; // default=English
-- char* lang=getenv("LANG");
-+ char const *message=beid_messages[0][msgnum]; // default=English
-+ char const *lang=getenv("LANG");
- if(lang!=NULL && strlen(lang)==5 && lang[2]=='_')
- {
- int i;
---- cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-spr-askpin.c.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-spr-askpin.c
-@@ -33,7 +33,7 @@
- #define EXIT_ERROR 2
-
- enum { MSG_PIN_CODE_REQUIRED=1, MSG_PLEASE_ENTER_PIN };
--char* beid_messages[4][3]={
-+static char const* const beid_messages[4][3]={
- {"en", "beID: PIN Code Required", "The application [%s] requests your eID PIN code on the secure pinpad reader:\n[%s].."},
- {"nl", "beID: PINcode Vereist", "Het programma [%s] vraagt uw eID PIN code in te geven op de beveiligde kaartlezer:\n[%s]."},
- {"fr", "beID: Code PIN Necessaire", "l'application [%s] vous demande d'entrer votre code PIN eID sur le lecteur securise\n[%s].."},
---- cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-spr-changepin.c.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-spr-changepin.c
-@@ -33,7 +33,7 @@
- #define EXIT_ERROR 2
-
- enum { MSG_CHANGE_PIN_CODE=1, MSG_PLEASE_CHANGE_PIN };
--char* beid_messages[4][3]={
-+static char const *const beid_messages[4][3]={
- {"en", "beID: Change PIN Code", "Request from Application [%s]:\n\nPlease change your eID PIN code on the secure pinpad reader:\n[%s].."},
- {"nl", "beID: Wijziging PINcode", "Verzoek van programma [%s]:\n\nGelieve uw eID PIN code op de beveiligde kaartlezer:\n[%s]\nte willen wijzigen."},
- {"fr", "beID: Changement de code PIN", "Demande de l'application [%s]:\n\nVeuillez changer votre code PIN eID sur le lecteur securise\n[%s].."},
---- cardcomm/pkcs11/src/dialogs/dialogsgtk/dlgs_gtk.cpp.orig 2015-10-09 08:01:44 UTC
-+++ cardcomm/pkcs11/src/dialogs/dialogsgtk/dlgs_gtk.cpp
-@@ -48,12 +48,14 @@ extern "C"
- void dlg_log_error(const char* label);
- }
-
-+static
- bool MW_PERROR(tLevel level, tModule mod, const char* comment)
- {
- char err_txt[256],log_txt[1024];
- wchar_t wide_log_txt[1024];
-
-- snprintf(log_txt,sizeof(log_txt),"%s:%s",comment,strerror_r(errno,err_txt,sizeof(err_txt)));
-+ strerror_r(errno,err_txt,sizeof(err_txt));
-+ snprintf(log_txt,sizeof(log_txt),"%s:%s",comment,err_txt);
- mbstowcs(wide_log_txt,log_txt,sizeof(wide_log_txt)/sizeof(wchar_t));
- return MWLOG(level,mod,wide_log_txt);
- }
---- cardcomm/pkcs11/src/dialogs/dialogsgtk/parent.c.orig 2015-02-19 13:59:02 UTC
+--- cardcomm/pkcs11/src/dialogs/dialogsgtk/parent.c.orig 2017-05-10 13:28:54 UTC
+++ cardcomm/pkcs11/src/dialogs/dialogsgtk/parent.c
-@@ -1,4 +1,6 @@
-+#include <stdio.h>
- #include <stdlib.h>
-+#include <unistd.h>
- #include "config.h"
- #include "parent.h"
- #include <unistd.h>
-@@ -11,7 +13,7 @@ ssize_t get_parent_path(char* exec_path,
- char proc_path[32];
- ssize_t exec_path_len=-1;
-
-- snprintf(proc_path,sizeof(proc_path)-1,"/proc/%d/exe",getppid());
-+ snprintf(proc_path,sizeof(proc_path)-1,"/proc/%d/file",getppid());
- if((exec_path_len=readlink(proc_path,exec_path,exec_path_size-1))!=-1)
- exec_path[exec_path_len]='\0';
- return exec_path_len;
---- cardcomm/pkcs11/src/dialogs/dialogsgtk/parent.h.orig 2015-02-19 13:59:02 UTC
-+++ cardcomm/pkcs11/src/dialogs/dialogsgtk/parent.h
-@@ -1,2 +1,4 @@
-+#include <sys/types.h>
-+
- ssize_t get_parent_path(char* exec_path, size_t exec_path_size);
-
+@@ -12,7 +12,7 @@ ssize_t get_parent_path(char *exec_path,
+ ssize_t exec_path_len = -1;
+ pid_t ppid = getppid();
+
+- snprintf(proc_path, sizeof(proc_path) - 1, "/proc/%d/exe", ppid);
++ snprintf(proc_path, sizeof(proc_path) - 1, "/proc/%d/file", ppid);
+ if ((exec_path_len = readlink(proc_path, exec_path, exec_path_size - 1)) != -1) {
+ exec_path[exec_path_len] = '\0';
+ } else {
diff --git a/security/libbeid/files/patch-pkcs11 b/security/libbeid/files/patch-pkcs11
deleted file mode 100644
index 99828ff97a1d..000000000000
--- a/security/libbeid/files/patch-pkcs11
+++ /dev/null
@@ -1,82 +0,0 @@
---- cardcomm/pkcs11/src/log.h.orig 2015-10-21 10:16:26 UTC
-+++ cardcomm/pkcs11/src/log.h
-@@ -64,42 +64,42 @@ typedef struct P11_MAP_TYPE
-
- static P11_MAP_TYPE const P11_CLASS_TYPES[]=
- {
-- { CKO_DATA, "CKO_DATA" },
-- { CKO_CERTIFICATE, "CKO_CERTIFICATE" },
-- { CKO_PUBLIC_KEY, "CKO_PUBLIC_KEY" },
-- { CKO_PRIVATE_KEY, "CKO_PRIVATE_KEY" },
-- { CKO_SECRET_KEY, "CKO_SECRET_KEY" },
-- { CKO_HW_FEATURE, "CKO_HW_FEATURE" },
-- { CKO_DOMAIN_PARAMETERS, "CKO_DOMAIN_PARAMETERS" },
-- { CKO_VENDOR_DEFINED, "CKO_VENDOR_DEFINED" },
-- {0,0}
-+ { CKO_DATA, "CKO_DATA", 0 },
-+ { CKO_CERTIFICATE, "CKO_CERTIFICATE", 0 },
-+ { CKO_PUBLIC_KEY, "CKO_PUBLIC_KEY", 0 },
-+ { CKO_PRIVATE_KEY, "CKO_PRIVATE_KEY", 0 },
-+ { CKO_SECRET_KEY, "CKO_SECRET_KEY", 0 },
-+ { CKO_HW_FEATURE, "CKO_HW_FEATURE", 0 },
-+ { CKO_DOMAIN_PARAMETERS, "CKO_DOMAIN_PARAMETERS", 0 },
-+ { CKO_VENDOR_DEFINED, "CKO_VENDOR_DEFINED", 0 },
-+ {0,0,0}
- };
-
- static P11_MAP_TYPE const P11_CERTIFICATE_TYPES[]=
- {
-- { CKC_X_509, "CKC_X_509" },
-- { CKC_X_509_ATTR_CERT, "CKC_X_509_ATTR_CERT" },
-- {0,0}
-+ { CKC_X_509, "CKC_X_509", 0 },
-+ { CKC_X_509_ATTR_CERT, "CKC_X_509_ATTR_CERT", 0 },
-+ {0,0,0}
- };
-
- static P11_MAP_TYPE const P11_KEY_TYPES[]=
- {
-- { CKK_RSA, "CKK_RSA" },
-- { CKK_DSA, "CKK_DSA" },
-- { CKK_DH, "CKK_DH" },
-- { CKK_ECDSA, "CKK_ECDSA" },
-- { CKK_EC, "CKK_EC" },
-- { CKK_RC2, "CKK_RC2" },
-- { CKK_RC4, "CKK_RC4" },
-- { CKK_RC5, "CKK_RC5" },
-- { CKK_DES, "CKK_DES" },
-- { CKK_DES3, "CKK_DES3" },
-- { CKK_CAST, "CKK_CAST" },
-- { CKK_CAST3, "CKK_CAST3" },
-- { CKK_CAST128, "CKK_CAST128" },
-- { CKK_IDEA, "CKK_IDEA" },
-- { CKK_AES, "CKK_AES" },
-- {0,0}
-+ { CKK_RSA, "CKK_RSA", 0 },
-+ { CKK_DSA, "CKK_DSA", 0 },
-+ { CKK_DH, "CKK_DH", 0 },
-+ { CKK_ECDSA, "CKK_ECDSA", 0 },
-+ { CKK_EC, "CKK_EC", 0 },
-+ { CKK_RC2, "CKK_RC2", 0 },
-+ { CKK_RC4, "CKK_RC4", 0 },
-+ { CKK_RC5, "CKK_RC5", 0 },
-+ { CKK_DES, "CKK_DES", 0 },
-+ { CKK_DES3, "CKK_DES3", 0 },
-+ { CKK_CAST, "CKK_CAST", 0 },
-+ { CKK_CAST3, "CKK_CAST3", 0 },
-+ { CKK_CAST128, "CKK_CAST128", 0 },
-+ { CKK_IDEA, "CKK_IDEA", 0 },
-+ { CKK_AES, "CKK_AES", 0 },
-+ {0,0,0}
- };
-
- static P11_MAP_TYPE const P11_ATTR_TYPES[]= {
-@@ -163,7 +163,7 @@ static P11_MAP_TYPE const P11_ATTR_TYPES
- { CKA_RESET_ON_INIT, "CKA_RESET_ON_INIT", 0 },
- { CKA_HAS_RESET, "CKA_HAS_RESET", 0 },
- { CKA_VENDOR_DEFINED, "CKA_VENDOR_DEFINED", 0 },
-- {0,0}
-+ {0,0,0}
- };
-
-
diff --git a/security/libbeid/pkg-plist b/security/libbeid/pkg-plist
index a0ee0056ed86..8aaded95149a 100644
--- a/security/libbeid/pkg-plist
+++ b/security/libbeid/pkg-plist
@@ -1,9 +1,14 @@
lib/libbeidpkcs11.so
lib/libbeidpkcs11.so.0
lib/libbeidpkcs11.so.0.0.0
+lib/pkcs11/beidpkcs11.so
libexec/beid-askaccess
libexec/beid-askpin
libexec/beid-badpin
libexec/beid-changepin
libexec/beid-spr-askpin
libexec/beid-spr-changepin
+%%NLS%%share/locale/de/LC_MESSAGES/dialogs-beid.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/dialogs-beid.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/dialogs-beid.mo
+share/p11-kit/modules/beid.module