aboutsummaryrefslogtreecommitdiffstats
path: root/security/libparanoia
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-14 21:33:30 +0800
committermiwi <miwi@FreeBSD.org>2006-12-14 21:33:30 +0800
commita8a8321de8c4ae52d2f511069c6327295de2ba5d (patch)
treeeb78a70034182ba72e9bed3672916adb6c186dba /security/libparanoia
parent58af33ce58e8d9617a8b1801c0905ed4edbc7f16 (diff)
downloadfreebsd-ports-gnome-a8a8321de8c4ae52d2f511069c6327295de2ba5d.tar.gz
freebsd-ports-gnome-a8a8321de8c4ae52d2f511069c6327295de2ba5d.tar.zst
freebsd-ports-gnome-a8a8321de8c4ae52d2f511069c6327295de2ba5d.zip
- Update to 1.4.1
PR: 106679 Submitted by: TAKAHASHI Kaoru <kaoru@kaisei.org>
Diffstat (limited to 'security/libparanoia')
-rw-r--r--security/libparanoia/Makefile19
-rw-r--r--security/libparanoia/distinfo6
-rw-r--r--security/libparanoia/files/patch-aa10
-rw-r--r--security/libparanoia/files/patch-ab14
-rw-r--r--security/libparanoia/files/vsnprintf-current.patch11
5 files changed, 9 insertions, 51 deletions
diff --git a/security/libparanoia/Makefile b/security/libparanoia/Makefile
index f489f9c69458..dffac25024d1 100644
--- a/security/libparanoia/Makefile
+++ b/security/libparanoia/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= libparanoia
-PORTVERSION= 1.4
-PORTREVISION= 3
+PORTVERSION= 1.4.1
CATEGORIES= security
MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/snar/
@@ -15,26 +14,20 @@ COMMENT= Safe (in the mean of stack smashing) reincarnation of strcpy et al
ONLY_FOR_ARCHS= i386
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
# this library depends on system-defined headers "SYS.h" and "DEFS.h"
# which may differ from release to release.
.if !exists(/usr/src/lib/libc)
-IGNORE= You need to have libc sources installed in /usr/src/lib/libc \
- before compiling.
+IGNORE= you need to have libc sources installed in /usr/src/lib/libc \
+ before compiling
.endif
.include <bsd.port.pre.mk>
-pre-patch:
- @${REINPLACE_CMD} -e 's|\(SIGSEGV\),\(getpid()\)|\2,\1|; \
- s|#include <varargs.h>||' \
+do-patch:
+ @${REINPLACE_CMD} -e 's|#include <varargs.h>||' \
${WRKSRC}/stentry.c
-.if ${OSVERSION} >= 500039
-post-patch:
- @(cd ${_DISTDIR};${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/vsnprintf-current.patch)
-.endif
-
.include <bsd.port.post.mk>
diff --git a/security/libparanoia/distinfo b/security/libparanoia/distinfo
index b12f9420f980..f18721f47e98 100644
--- a/security/libparanoia/distinfo
+++ b/security/libparanoia/distinfo
@@ -1,3 +1,3 @@
-MD5 (libparanoia-1.4.tar.gz) = c615cc5db41d8aee1e659d122f5ce631
-SHA256 (libparanoia-1.4.tar.gz) = dbc94d9998d813234276df9132d25a3349a7ffda0501dbaa9d829a4243755633
-SIZE (libparanoia-1.4.tar.gz) = 10162
+MD5 (libparanoia-1.4.1.tar.gz) = 9090f2eedd08e031094501c999c639b7
+SHA256 (libparanoia-1.4.1.tar.gz) = 3eb3183f47a32d5ae3efb6fef4a3773de4a3979020a3de357f487af8b4c00861
+SIZE (libparanoia-1.4.1.tar.gz) = 10231
diff --git a/security/libparanoia/files/patch-aa b/security/libparanoia/files/patch-aa
deleted file mode 100644
index aaaa53bf33d5..000000000000
--- a/security/libparanoia/files/patch-aa
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.orig Sat Apr 29 20:56:31 2000
-+++ Makefile Sat Apr 29 20:56:43 2000
-@@ -7,6 +7,7 @@
- SHLIB_MAJOR=1
- SHLIB_MINOR=4
- CFLAGS+=-I/usr/src/lib/libc/locale -I/usr/src/lib/libc/stdio/
-+NOPROFILE=yes
-
- #you should add -DPARANOIDAL_ROOT to CFLAGS. In that case, only
- #setugid(2) processes and processes with uid or euid == 0 will
diff --git a/security/libparanoia/files/patch-ab b/security/libparanoia/files/patch-ab
deleted file mode 100644
index 43ff3e9a36ef..000000000000
--- a/security/libparanoia/files/patch-ab
+++ /dev/null
@@ -1,14 +0,0 @@
---- gets.c.orig Wed Dec 30 17:05:40 1998
-+++ gets.c Fri Mar 22 23:29:05 2002
-@@ -68,8 +68,10 @@
- }
- for (s = buf; (c = getchar()) != '\n';)
- if (c == EOF)
-- if (s == buf)
-+ if (s == buf) {
-+ exit_violation();
- return (NULL);
-+ }
- else
- break;
- else
diff --git a/security/libparanoia/files/vsnprintf-current.patch b/security/libparanoia/files/vsnprintf-current.patch
deleted file mode 100644
index c6fb894ba86c..000000000000
--- a/security/libparanoia/files/vsnprintf-current.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- vsprintf.c.orig Sun Oct 20 17:23:01 2002
-+++ vsprintf.c Sun Oct 20 17:23:32 2002
-@@ -52,7 +52,7 @@
- vsprintf(str, fmt, ap)
- char *str;
- const char *fmt;
-- _BSD_VA_LIST_ ap;
-+ va_list ap;
- {
- int ret;
- FILE f;