aboutsummaryrefslogtreecommitdiffstats
path: root/security/lsh
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-12-18 11:49:07 +0800
committerdinoex <dinoex@FreeBSD.org>2002-12-18 11:49:07 +0800
commita03670e35b7f333e8868e3b684fc6cb9a0317de6 (patch)
tree3dbaed1f875adcdfe2fca6303884ab4db8e88552 /security/lsh
parent11efed0bfc31841ce55159444c9024a238c3d508 (diff)
downloadfreebsd-ports-gnome-a03670e35b7f333e8868e3b684fc6cb9a0317de6.tar.gz
freebsd-ports-gnome-a03670e35b7f333e8868e3b684fc6cb9a0317de6.tar.zst
freebsd-ports-gnome-a03670e35b7f333e8868e3b684fc6cb9a0317de6.zip
- Fix some of the build problems on CURRENT, not all.
- make PREFIX aware - mark BROKEN for conflicts with getopt.h - take maintainership
Diffstat (limited to 'security/lsh')
-rw-r--r--security/lsh/Makefile16
-rw-r--r--security/lsh/files/patch-argp-help.c21
-rw-r--r--security/lsh/files/patch-lsh-authorize (renamed from security/lsh/files/patch-ac)0
3 files changed, 31 insertions, 6 deletions
diff --git a/security/lsh/Makefile b/security/lsh/Makefile
index 29da366058b0..2dd212cf64c5 100644
--- a/security/lsh/Makefile
+++ b/security/lsh/Makefile
@@ -11,24 +11,28 @@ MASTER_SITES= ftp://ftp.lysator.liu.se/pub/security/lsh/%SUBDIR%/
MASTER_SITE_SUBDIR= . old
DISTNAME= ${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dinoex@FreeBSD.org
RESTRICTED= "Crypto; export-controlled"
GNU_CONFIGURE= yes
INSTALL_TARGET= install
+MAN1= lsh_writekey.1 lsh_keygen.1 lsh.1
+MAN5= DSA.5 secsh.5 SHA.5 SPKI.5
+MAN8= lshd.8
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400014
-CONFIGURE_ARGS+=--without-ipv6
+CONFIGURE_ARGS+= --without-ipv6
.endif
.if ${OSVERSION} >= 500000
BUILD_DEPENDS+= ${LOCALBASE}/include/gmp.h:${PORTSDIR}/math/libgmp4
+CONFIGURE_ARGS+= --with-include-path=${LOCALBASE}/include
+CONFIGURE_ARGS+= --with-lib-path=${LOCALBASE}/lib
+.endif
+.if ${OSVERSION} >= 500043
+BROKEN= conflicts with /usr/include/getopt.h
.endif
-
-MAN1= lsh_writekey.1 lsh_keygen.1 lsh.1
-MAN5= DSA.5 secsh.5 SHA.5 SPKI.5
-MAN8= lshd.8
post-install:
.for BIN in lsh lsh_keygen lsh_writekey sexp-conv srp-gen lsh-decode-key
diff --git a/security/lsh/files/patch-argp-help.c b/security/lsh/files/patch-argp-help.c
new file mode 100644
index 000000000000..ea25b96b774f
--- /dev/null
+++ b/security/lsh/files/patch-argp-help.c
@@ -0,0 +1,21 @@
+--- src/argp/argp-help.c.orig Wed Feb 2 15:14:31 2000
++++ src/argp/argp-help.c Tue Dec 17 13:08:02 2002
+@@ -56,7 +56,9 @@
+ #include <string.h>
+ #include <assert.h>
+ #include <stdarg.h>
++#ifndef __FreeBSD__
+ #include <malloc.h>
++#endif
+ #include <ctype.h>
+
+ #ifndef _
+@@ -182,7 +184,7 @@
+ { "header-col", 0, offsetof (struct uparams, header_col) },
+ { "usage-indent", 0, offsetof (struct uparams, usage_indent) },
+ { "rmargin", 0, offsetof (struct uparams, rmargin) },
+- { 0 }
++ { 0, 0, 0 }
+ };
+
+ /* Read user options from the environment, and fill in UPARAMS appropiately. */
diff --git a/security/lsh/files/patch-ac b/security/lsh/files/patch-lsh-authorize
index fd367474558e..fd367474558e 100644
--- a/security/lsh/files/patch-ac
+++ b/security/lsh/files/patch-lsh-authorize