aboutsummaryrefslogtreecommitdiffstats
path: root/security/matrixssl
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-11-20 17:00:15 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-11-20 17:00:15 +0800
commit576749219b43137d917559407166087c56d3f401 (patch)
tree13f28030aa588320a2fe1e50cc07c417e55cea03 /security/matrixssl
parent5f65379cedf8e69b413ea68af104cc72e241eec3 (diff)
downloadfreebsd-ports-gnome-576749219b43137d917559407166087c56d3f401.tar.gz
freebsd-ports-gnome-576749219b43137d917559407166087c56d3f401.tar.zst
freebsd-ports-gnome-576749219b43137d917559407166087c56d3f401.zip
- Switch to options helpers
Diffstat (limited to 'security/matrixssl')
-rw-r--r--security/matrixssl/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/security/matrixssl/Makefile b/security/matrixssl/Makefile
index 956e407ea8e7..55e110c3e108 100644
--- a/security/matrixssl/Makefile
+++ b/security/matrixssl/Makefile
@@ -14,14 +14,14 @@ COMMENT= Small alternative SSL implementation
LICENSE= GPLv2+
-OPTIONS_DEFINE= DOCS EXAMPLES
-
WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}-${PORTVERSION:S/./-/g}-open
USES= gmake tar:tgz
MAKE_ARGS= CC="${CC}" DFLAGS="${CFLAGS}" STRIP="${TEST}"
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.pre.mk>
.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == mips64 || ${ARCH} == powerpc64 || ${ARCH} == sparc64
@@ -50,11 +50,12 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/core/*.h ${STAGEDIR}${PREFIX}/include/matrixssl/core
@${MKDIR} ${STAGEDIR}${PREFIX}/include/matrixssl/crypto
${INSTALL_DATA} ${WRKSRC}/crypto/*.h ${STAGEDIR}${PREFIX}/include/matrixssl/crypto
-.if ${PORT_OPTIONS:MDOCS}
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
+
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/apps
${INSTALL_DATA} ${WRKSRC}/apps/Makefile ${STAGEDIR}${EXAMPLESDIR}/apps
${INSTALL_DATA} ${WRKSRC}/apps/*.c ${STAGEDIR}${EXAMPLESDIR}/apps
@@ -62,6 +63,5 @@ do-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sampleCerts
${INSTALL_DATA} ${WRKSRC}/sampleCerts/*.h ${STAGEDIR}${EXAMPLESDIR}/sampleCerts
${INSTALL_DATA} ${WRKSRC}/sampleCerts/*.pem ${STAGEDIR}${EXAMPLESDIR}/sampleCerts
-.endif
.include <bsd.port.post.mk>