aboutsummaryrefslogtreecommitdiffstats
path: root/security/nessus-libnasl
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-01-30 23:29:12 +0800
committerMichael Scheidell <scheidell@FreeBSD.org>2012-01-30 23:29:12 +0800
commit90a318b5dbbb3c3666e5745b68864be887112402 (patch)
tree27cd9ee2b3eca490ea4047fb19e6318a4f4b4e23 /security/nessus-libnasl
parentb394eeec150bce38425d1b94ed2ecf11877ea791 (diff)
downloadfreebsd-ports-gnome-90a318b5dbbb3c3666e5745b68864be887112402.tar.gz
freebsd-ports-gnome-90a318b5dbbb3c3666e5745b68864be887112402.tar.zst
freebsd-ports-gnome-90a318b5dbbb3c3666e5745b68864be887112402.zip
- Fix build due to libtool updates. [1]
- Edit makefile in nessus-libraries to remove bpf40 check, not needed on modern kernels [2] - Edit makefile in nessus-libraries allow package building [2] PR: ports/164595 Submitted by: Udo Schweigert <udo.schweigert@siemens.com> (maintainer) [1] Reviewed by: scheidell [2] Approved by: maintainer, gabor (implicit)
Diffstat (limited to 'security/nessus-libnasl')
-rw-r--r--security/nessus-libnasl/files/patch-libtool21
1 files changed, 21 insertions, 0 deletions
diff --git a/security/nessus-libnasl/files/patch-libtool b/security/nessus-libnasl/files/patch-libtool
new file mode 100644
index 000000000000..1e190cc05a32
--- /dev/null
+++ b/security/nessus-libnasl/files/patch-libtool
@@ -0,0 +1,21 @@
+--- nasl/Makefile.orig 2005-02-10 17:03:51.000000000 +0100
++++ nasl/Makefile 2012-01-29 10:29:13.000000000 +0100
+@@ -88,7 +88,8 @@
+ nasl_server.c \
+ nasl_debug.c
+
+-COMPILE = $(LIBTOOL) $(CC) $(CFLAGS) $(NESSUS_INCLUDE)
++COMPILE = $(LIBTOOL) --mode compile $(CC) $(CFLAGS) $(NESSUS_INCLUDE)
++LINK = $(LIBTOOL) --mode link $(CC) $(CFLAGS) $(NESSUS_INCLUDE)
+ all : cflags libnasl.la nasl
+
+ .c.o:
+@@ -101,7 +102,7 @@
+ $(CC) $(CFLAGS) $(NESSUS_INCLUDE) $(include) -o nasl -DVERSION=\"$(VERSION)\" nasl.c $(OBJS) $(NESSUS_LIBS)
+
+ libnasl.la : cflags $(OBJS)
+- $(COMPILE) $(NESSUS_LIBS) -o libnasl.la $(LO_OBJS) -rpath ${libdir} \
++ $(LINK) $(NESSUS_LIBS) -o libnasl.la $(LO_OBJS) -rpath ${libdir} \
+ -version-info ${PACKAGE_VERSION}
+
+ install : libnasl.la nasl