aboutsummaryrefslogtreecommitdiffstats
path: root/security/nikto/Makefile
diff options
context:
space:
mode:
authorniels <niels@FreeBSD.org>2010-08-19 05:20:40 +0800
committerniels <niels@FreeBSD.org>2010-08-19 05:20:40 +0800
commit086a175e4b097c12120179c60c2fad04ea2c0be1 (patch)
tree3d969757feeea9d273992f457f48a1d7bddfa1b8 /security/nikto/Makefile
parent52f7963d7fbdee311cf90daf56375e20fb9b6d25 (diff)
downloadfreebsd-ports-gnome-086a175e4b097c12120179c60c2fad04ea2c0be1.tar.gz
freebsd-ports-gnome-086a175e4b097c12120179c60c2fad04ea2c0be1.tar.zst
freebsd-ports-gnome-086a175e4b097c12120179c60c2fad04ea2c0be1.zip
- Removed nmap dependency
- Fixed typo /RUN_DEPENEDS/RUN_DEPENDS/ - Updated nikto.conf patching - Bumped PORTREVISION Approved by: itetcu (mentor, implicit) Submitted by: Anderson Eduardo <anderson@secover.com.br> PR: ports/149769
Diffstat (limited to 'security/nikto/Makefile')
-rw-r--r--security/nikto/Makefile33
1 files changed, 11 insertions, 22 deletions
diff --git a/security/nikto/Makefile b/security/nikto/Makefile
index eac8b488b97c..037846aa84ac 100644
--- a/security/nikto/Makefile
+++ b/security/nikto/Makefile
@@ -9,6 +9,7 @@
PORTNAME= nikto
PORTVERSION= 2.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security www
MASTER_SITES= http://www.cirt.net/${PORTNAME}/ \
@@ -26,28 +27,20 @@ NO_BUILD= yes
PORTDOCS= CHANGES.txt LICENSE.txt nikto.dtd nikto_manual.html
OPTIONS+= SSLEAY "Use NET::SSLeay for ssl scanning" on
-OPTIONS+= NMAP "Use security/nmap for port scanning" on
.include <bsd.port.pre.mk>
.ifdef(WITH_SSLEAY)
-RUN_DEPENEDS+= p5-Net-SSLeay>0:${PORTSDIR}/security/p5-Net-SSLeay
-.endif
-
-.ifdef(WITH_NMAP)
-RUN_DEPENEDS+= nmap:${PORTSDIR}/security/nmap
+RUN_DEPENDS+= p5-Net-SSLeay>0:${PORTSDIR}/security/p5-Net-SSLeay
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|/usr/local/bin/perl|${PERL}|" ${WRKSRC}/nikto.pl
- @${REINPLACE_CMD} -e "s|/etc/nikto.conf|${PREFIX}/etc/nikto.conf|" ${WRKSRC}/nikto.pl
- @${REINPLACE_CMD} -Ee "s|/usr/bin/nmap|${LOCALBASE}/bin/nmap|g" \
- -e "s|# (EXECDIR=)/usr/local/nikto|\1${DATADIR}|g" \
- ${WRKSRC}/nikto.conf
- @${REINPLACE_CMD} -e 's:\$NIKTO{plugindir}/../docs/CHANGES.txt:\$NIKTO{plugindir}/../../docs/nikto/CHANGES.txt:' \
- -e 's:\$NIKTO{plugindir}/../CHANGES.txt:\$NIKTO{plugindir}/../../docs/nikto/CHANGES.txt:' \
- ${WRKSRC}/plugins/nikto_core.plugin
- @${RM} ${WRKSRC}/plugins/*.bak
+ @${REINPLACE_CMD} -e "s|/usr/local/bin/perl|${PERL}|" \
+ -e "s|/etc/nikto.conf|${PREFIX}/etc/nikto.conf|" ${WRKSRC}/nikto.pl
+ @${REINPLACE_CMD} -Ee "s|# (EXECDIR=)/usr/local/nikto|\1${DATADIR}|g" \
+ -e "s|# (PLUGINDIR=)/opt/nikto/plugins|\1${DATADIR}/plugins|g" \
+ -e "s|# (TEMPLATEDIR=)/opt/nikto/templates|\1${DATADIR}/templates|g" \
+ -e "s|# (DOCDIR=)/opt/nikto/docs|\1${DOCSDIR}|g" ${WRKSRC}/nikto.conf
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/nikto.pl ${PREFIX}/bin/nikto
@@ -55,13 +48,9 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/docs/nikto.1 ${PREFIX}/man/man1/
[ -f ${PREFIX}/etc/nikto.conf ] || \
${INSTALL_DATA} ${WRKSRC}/nikto.conf ${PREFIX}/etc/nikto.conf
- @${MKDIR} ${DATADIR}
- @${MKDIR} ${DATADIR}/plugins
- @${MKDIR} ${DATADIR}/templates
- ${INSTALL_DATA} ${WRKSRC}/plugins/LW2.pm ${DATADIR}/plugins
- ${INSTALL_DATA} ${WRKSRC}/plugins/db_* ${DATADIR}/plugins
- ${INSTALL_DATA} ${WRKSRC}/plugins/*.plugin ${DATADIR}/plugins
- ${INSTALL_DATA} ${WRKSRC}/templates/*.tmpl ${DATADIR}/templates
+
+ ( cd ${WRKSRC}/plugins && ${COPYTREE_SHARE} . ${DATADIR}/plugins )
+ ( cd ${WRKSRC}/templates && ${COPYTREE_SHARE} . ${DATADIR}/templates )
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
. for i in ${PORTDOCS}