aboutsummaryrefslogtreecommitdiffstats
path: root/security/nikto/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-22 06:39:50 +0800
committerpav <pav@FreeBSD.org>2004-05-22 06:39:50 +0800
commitf610dd0dc84c1f98fa844453b8807fb957145a53 (patch)
tree77f507836af144b38631180da9b98b2e20158e4e /security/nikto/Makefile
parentd1252614215048e822b94df6cd1e90a8767f993e (diff)
downloadfreebsd-ports-gnome-f610dd0dc84c1f98fa844453b8807fb957145a53.tar.gz
freebsd-ports-gnome-f610dd0dc84c1f98fa844453b8807fb957145a53.tar.zst
freebsd-ports-gnome-f610dd0dc84c1f98fa844453b8807fb957145a53.zip
- Install docs
PR: ports/66953 (based on) Submitted by: Jimmie James <h2g2_jimmiejaz@yahoo.com>
Diffstat (limited to 'security/nikto/Makefile')
-rw-r--r--security/nikto/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/security/nikto/Makefile b/security/nikto/Makefile
index 32019a17266f..016c68da1e80 100644
--- a/security/nikto/Makefile
+++ b/security/nikto/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nikto
PORTVERSION= 1.32
+PORTREVISION= 1
CATEGORIES= security www
MAINTAINER= ports@FreeBSD.org
@@ -21,6 +22,8 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net
NO_BUILD= yes
USE_REINPLACE= yes
+PORTDOCS= nikto_usage.txt nikto_usage.html CHANGES.txt README_plugins.txt
+
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/nikto.pl ${PREFIX}/bin/nikto
@${MKDIR} ${PREFIX}/etc/nikto && ${CHMOD} 755 ${PREFIX}/etc/nikto
@@ -32,5 +35,11 @@ do-install:
do \
${INSTALL_SCRIPT} ${WRKSRC}/plugins/$$i ${PREFIX}/share/nikto; \
done
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>