aboutsummaryrefslogtreecommitdiffstats
path: root/security/nmap
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2015-09-27 18:32:29 +0800
committerohauer <ohauer@FreeBSD.org>2015-09-27 18:32:29 +0800
commit97e94d08f7a5a294478d0f11850133b78c580221 (patch)
tree37cbde6ecbb4f7eb8e2dce09cc667ef7b203b0a0 /security/nmap
parente071c3769b8942975123e864d32362dda8e8eeea (diff)
downloadfreebsd-ports-gnome-97e94d08f7a5a294478d0f11850133b78c580221.tar.gz
freebsd-ports-gnome-97e94d08f7a5a294478d0f11850133b78c580221.tar.zst
freebsd-ports-gnome-97e94d08f7a5a294478d0f11850133b78c580221.zip
- update to 6.49BETA5
- use DOCS instead PORTDOCS - remove gcc workaround [1] - (hopefully) use the correct __FreeBSD_version for SOCK_RAW Changelog: https://nmap.org/changelog.html PR: 196065 [1] PR: 200558 [2] PR: 202139 [3] Submitted by: sbruno@ , mikael.urankar@gmail.com [1] Submitted by: truckman@ [2] Submitted by: trasz@ [3]
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile24
-rw-r--r--security/nmap/distinfo4
-rw-r--r--security/nmap/files/patch-Makefile.in6
-rw-r--r--security/nmap/files/patch-configure15
-rw-r--r--security/nmap/files/patch-libdnet-stripped__configure6
-rw-r--r--security/nmap/files/patch-libdnet-stripped__src__eth-bsd.c6
-rw-r--r--security/nmap/files/patch-liblua-lua52325
-rw-r--r--security/nmap/files/patch-liblua__Makefile13
-rw-r--r--security/nmap/files/patch-liblua__liolib.c10
-rw-r--r--security/nmap/files/patch-libnetutil_netutil.cc20
-rw-r--r--security/nmap/files/patch-nmap.cc8
-rw-r--r--security/nmap/files/patch-output.cc6
-rw-r--r--security/nmap/files/patch-tcpip.cc6
-rw-r--r--security/nmap/pkg-plist40
14 files changed, 117 insertions, 72 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index d1483cae3c36..170fff8a4da0 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nmap
-DISTVERSION= 6.47
+DISTVERSION= 6.49BETA5
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
@@ -19,7 +19,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
-USES= tar:bzip2 gmake cpe compiler
+USES= tar:bzip2 gmake cpe
GNU_CONFIGURE= yes
OPTIONS_SUB= yes
@@ -40,7 +40,7 @@ IPV6_CONFIGURE_OFF= --with-libpcap=${LOCALBASE}/IPv6
LIB_DEPENDS+= libpcap.so:${PORTSDIR}/net/libpcap
.endif
-PORTDOCS= CHANGELOG HACKING
+DOCS= CHANGELOG HACKING
STRIP_FILES= nmap nping
.if ${PORT_OPTIONS:MSSL}
@@ -54,15 +54,6 @@ CONFIGURE_ARGS+=--without-localdirs \
--with-liblua=included \
--without-nmap-update
-.include <bsd.port.pre.mk>
-
-# fix for gcc from ports
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-GCCLIBDIR_CMDS= ${CC} -print-file-name=libstdc++.so | ${SED} -e 's/libstdc++.so//'
-CONFIGURE_ARGS+=LDFLAGS="-L$$(${GCCLIBDIR_CMDS})"
-NOT_BASE_CC= true
-.endif
-
# XXX limit results if we do a grep in the sources!
post-extract:
@${RM} -rf ${WRKSRC}/mswin32
@@ -76,11 +67,6 @@ pre-install:
post-install:
${STRIP_CMD} ${STRIP_FILES:S|^|${STAGEDIR}${PREFIX}/bin/|}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-
-# gcc from ports is in use
-.if defined(NOT_BASE_CC)
- @${ECHO_MSG} do not forget to adjust libnmap.conf
-.endif
+ ${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index 15891037c09c..76f54c3aeb2c 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nmap-6.47.tar.bz2) = 8fa11e9e203ce2d81a207db5ca4f110a525f6c01c1dd0018325a7112a51aa591
-SIZE (nmap-6.47.tar.bz2) = 7878122
+SHA256 (nmap-6.49BETA5.tar.bz2) = 747a961d735da518cb00884c46c13e73ee1d06253d03c176ce54dde1f6681c36
+SIZE (nmap-6.49BETA5.tar.bz2) = 8816982
diff --git a/security/nmap/files/patch-Makefile.in b/security/nmap/files/patch-Makefile.in
index ce17a6a2581f..6f27f5d37f60 100644
--- a/security/nmap/files/patch-Makefile.in
+++ b/security/nmap/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2009-06-24 23:35:54.000000000 +0200
-+++ Makefile.in 2009-07-03 19:32:31.000000000 +0200
-@@ -11,7 +11,7 @@
+--- Makefile.in.orig 2015-06-25 13:01:27 UTC
++++ Makefile.in
+@@ -13,7 +13,7 @@ mandir = @mandir@
top_srcdir = @top_srcdir@
srcdir = @srcdir@
nmapdatadir = @datadir@/nmap
diff --git a/security/nmap/files/patch-configure b/security/nmap/files/patch-configure
index 964667c756c4..2bb31bc80d65 100644
--- a/security/nmap/files/patch-configure
+++ b/security/nmap/files/patch-configure
@@ -1,6 +1,15 @@
---- ./configure.orig 2010-09-29 18:09:26.000000000 +0200
-+++ ./configure 2011-01-07 19:27:04.000000000 +0100
-@@ -3367,7 +3367,7 @@
+--- configure.orig 2015-06-16 13:47:16 UTC
++++ configure
+@@ -2545,7 +2545,7 @@ ac_link='$CC -o conftest$ac_exeext $CFLA
+ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+ if test -n "$ac_tool_prefix"; then
+ # Extract the first word of "${ac_tool_prefix}gcc", so it can be a program name with args.
+-set dummy ${ac_tool_prefix}gcc; ac_word=$2
++set dummy ${ac_tool_prefix}$CXX; ac_word=$2
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+ $as_echo_n "checking for $ac_word... " >&6; }
+ if ${ac_cv_prog_CC+:} false; then :
+@@ -3378,7 +3378,7 @@ ac_link='$CC -o conftest$ac_exeext $CFLA
ac_compiler_gnu=$ac_cv_c_compiler_gnu
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}gcc", so it can be a program name with args.
diff --git a/security/nmap/files/patch-libdnet-stripped__configure b/security/nmap/files/patch-libdnet-stripped__configure
index a3ab337bf43c..0d381c5cacce 100644
--- a/security/nmap/files/patch-libdnet-stripped__configure
+++ b/security/nmap/files/patch-libdnet-stripped__configure
@@ -1,6 +1,6 @@
---- ./libdnet-stripped/configure.orig 2010-05-07 23:08:32.000000000 +0200
-+++ ./libdnet-stripped/configure 2011-01-29 22:22:39.000000000 +0100
-@@ -14342,11 +14342,8 @@
+--- libdnet-stripped/configure.orig 2011-09-28 06:55:47 UTC
++++ libdnet-stripped/configure
+@@ -14344,11 +14344,8 @@ $as_echo_n "checking for Berkeley Packet
if test "${ac_cv_dnet_bsd_bpf+set}" = set; then
$as_echo_n "(cached) " >&6
else
diff --git a/security/nmap/files/patch-libdnet-stripped__src__eth-bsd.c b/security/nmap/files/patch-libdnet-stripped__src__eth-bsd.c
index 4f615c58e0f0..24d538b095f8 100644
--- a/security/nmap/files/patch-libdnet-stripped__src__eth-bsd.c
+++ b/security/nmap/files/patch-libdnet-stripped__src__eth-bsd.c
@@ -1,6 +1,6 @@
---- ./libdnet-stripped/src/eth-bsd.c.orig 2009-11-09 05:49:32.000000000 +0100
-+++ ./libdnet-stripped/src/eth-bsd.c 2010-09-03 21:04:29.000000000 +0200
-@@ -45,7 +45,7 @@
+--- libdnet-stripped/src/eth-bsd.c.orig 2009-11-09 04:49:32 UTC
++++ libdnet-stripped/src/eth-bsd.c
+@@ -45,7 +45,7 @@ eth_open(const char *device)
int i;
if ((e = calloc(1, sizeof(*e))) != NULL) {
diff --git a/security/nmap/files/patch-liblua-lua523 b/security/nmap/files/patch-liblua-lua523
deleted file mode 100644
index 6818b9730920..000000000000
--- a/security/nmap/files/patch-liblua-lua523
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -nruEbw -I'[$]Id:.*' ./liblua/Makefile ./liblua/Makefile
---- ./liblua/Makefile 2013-05-02 16:59:06.000000000 +0200
-+++ ./liblua/Makefile 2014-01-12 15:13:44.000000000 +0100
-@@ -6,8 +6,8 @@
- # Your platform. See PLATS for possible values.
- PLAT= none
-
--CC= gcc
--CFLAGS= -O2 -Wall -DLUA_COMPAT_ALL $(SYSCFLAGS) $(MYCFLAGS)
-+CC?= gcc
-+CFLAGS= -Wall -DLUA_COMPAT_ALL $(SYSCFLAGS) $(MYCFLAGS)
- LDFLAGS= $(SYSLDFLAGS) $(MYLDFLAGS)
- LIBS= -lm $(SYSLIBS) $(MYLIBS)
-
-diff -nruEbw -I'[$]Id:.*' ./liblua/liolib.c ./liblua/liolib.c
---- ./liblua/liolib.c 2013-05-02 16:59:06.000000000 +0200
-+++ ./liblua/liolib.c 2014-01-12 15:13:21.000000000 +0100
-@@ -19,6 +19,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <unistd.h>
-
- #define liolib_c
- #define LUA_LIB
diff --git a/security/nmap/files/patch-liblua__Makefile b/security/nmap/files/patch-liblua__Makefile
new file mode 100644
index 000000000000..89e40bdea4da
--- /dev/null
+++ b/security/nmap/files/patch-liblua__Makefile
@@ -0,0 +1,13 @@
+--- liblua/Makefile.orig 2014-01-02 15:33:55 UTC
++++ liblua/Makefile
+@@ -6,8 +6,8 @@
+ # Your platform. See PLATS for possible values.
+ PLAT= none
+
+-CC= gcc
+-CFLAGS= -O2 -Wall -DLUA_COMPAT_ALL $(SYSCFLAGS) $(MYCFLAGS)
++CC?= gcc
++CFLAGS= -Wall -DLUA_COMPAT_ALL $(SYSCFLAGS) $(MYCFLAGS)
+ LDFLAGS= $(SYSLDFLAGS) $(MYLDFLAGS)
+ LIBS= -lm $(SYSLIBS) $(MYLIBS)
+
diff --git a/security/nmap/files/patch-liblua__liolib.c b/security/nmap/files/patch-liblua__liolib.c
new file mode 100644
index 000000000000..b62f4ae63ad5
--- /dev/null
+++ b/security/nmap/files/patch-liblua__liolib.c
@@ -0,0 +1,10 @@
+--- liblua/liolib.c.orig 2014-01-02 15:33:55 UTC
++++ liblua/liolib.c
+@@ -19,6 +19,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+
+ #define liolib_c
+ #define LUA_LIB
diff --git a/security/nmap/files/patch-libnetutil_netutil.cc b/security/nmap/files/patch-libnetutil_netutil.cc
new file mode 100644
index 000000000000..23df9e6c5ed9
--- /dev/null
+++ b/security/nmap/files/patch-libnetutil_netutil.cc
@@ -0,0 +1,20 @@
+--- libnetutil/netutil.cc.orig 2015-09-21 19:57:10 UTC
++++ libnetutil/netutil.cc
+@@ -3604,7 +3604,7 @@ int send_ip_packet_sd(int sd, const stru
+ must deal with it here rather than when building the packet,
+ because they should be in NBO when I'm sending over raw
+ ethernet */
+-#if (defined(FREEBSD) && (__FreeBSD_version < 1000022)) || BSDI || NETBSD || DEC || MACOSX
++#if (defined(FREEBSD) && (__FreeBSD_version < 1100030)) || BSDI || NETBSD || DEC || MACOSX
+ ip->ip_len = ntohs(ip->ip_len);
+ ip->ip_off = ntohs(ip->ip_off);
+ #endif
+@@ -3614,7 +3614,7 @@ int send_ip_packet_sd(int sd, const stru
+ (int) sizeof(struct sockaddr_in));
+
+ /* Undo the byte order switching. */
+-#if (defined(FREEBSD) && (__FreeBSD_version < 1000022)) || BSDI || NETBSD || DEC || MACOSX
++#if (defined(FREEBSD) && (__FreeBSD_version < 1100030)) || BSDI || NETBSD || DEC || MACOSX
+ ip->ip_len = htons(ip->ip_len);
+ ip->ip_off = htons(ip->ip_off);
+ #endif
diff --git a/security/nmap/files/patch-nmap.cc b/security/nmap/files/patch-nmap.cc
index 56e9dfd8afd4..a4168eba94b2 100644
--- a/security/nmap/files/patch-nmap.cc
+++ b/security/nmap/files/patch-nmap.cc
@@ -1,8 +1,8 @@
---- nmap.cc.orig Sat Dec 22 07:32:03 2007
-+++ nmap.cc Thu Jan 10 20:41:30 2008
-@@ -99,6 +99,7 @@
+--- nmap.cc.orig 2015-09-21 13:49:51 UTC
++++ nmap.cc
+@@ -123,6 +123,7 @@
- /* $Id: nmap.cc 6633 2007-12-22 06:32:03Z fyodor $ */
+ /* $Id: nmap.cc 35268 2015-09-21 13:49:51Z dmiller $ */
+#include <getopt.h>
#include "nmap.h"
diff --git a/security/nmap/files/patch-output.cc b/security/nmap/files/patch-output.cc
index b64921477b93..2ad25a620acc 100644
--- a/security/nmap/files/patch-output.cc
+++ b/security/nmap/files/patch-output.cc
@@ -1,6 +1,6 @@
---- ./output.cc.orig 2011-09-19 20:31:46.000000000 +0200
-+++ ./output.cc 2011-09-23 22:11:50.000000000 +0200
-@@ -114,6 +114,7 @@
+--- output.cc.orig 2015-06-16 13:59:33 UTC
++++ output.cc
+@@ -146,6 +146,7 @@
#include <set>
#include <vector>
#include <list>
diff --git a/security/nmap/files/patch-tcpip.cc b/security/nmap/files/patch-tcpip.cc
index bfd32d785532..3357b0708d66 100644
--- a/security/nmap/files/patch-tcpip.cc
+++ b/security/nmap/files/patch-tcpip.cc
@@ -1,6 +1,6 @@
---- tcpip.cc.orig Fri Dec 8 04:01:19 2006
-+++ tcpip.cc Wed Jan 3 17:15:05 2007
-@@ -133,6 +133,8 @@
+--- tcpip.cc.orig 2015-06-16 13:59:33 UTC
++++ tcpip.cc
+@@ -154,6 +154,8 @@
#endif /* NETINET_IF_ETHER_H */
#endif /* HAVE_NETINET_IF_ETHER_H */
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
index 7c33abe3da22..d02bc9053060 100644
--- a/security/nmap/pkg-plist
+++ b/security/nmap/pkg-plist
@@ -18,6 +18,8 @@ man/ro/man1/nmap.1.gz
man/ru/man1/nmap.1.gz
man/sk/man1/nmap.1.gz
man/zh/man1/nmap.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/HACKING
%%SSL%%share/ncat/ca-bundle.crt
%%DATADIR%%/nmap-mac-prefixes
%%DATADIR%%/nmap-os-db
@@ -32,6 +34,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/afp.lua
%%DATADIR%%/nselib/ajp.lua
%%DATADIR%%/nselib/amqp.lua
+%%DATADIR%%/nselib/anyconnect.lua
%%DATADIR%%/nselib/asn1.lua
%%DATADIR%%/nselib/base32.lua
%%DATADIR%%/nselib/base64.lua
@@ -48,6 +51,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/cvs.lua
%%DATADIR%%/nselib/data/dns-srv-names
%%DATADIR%%/nselib/data/drupal-modules.lst
+%%DATADIR%%/nselib/data/enterprise_numbers.txt
%%DATADIR%%/nselib/data/favicon-db
%%DATADIR%%/nselib/data/http-default-accounts-fingerprints.lua
%%DATADIR%%/nselib/data/http-devframework-fingerprints.lua
@@ -80,13 +84,14 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/data/psexec/pwdump.lua
%%DATADIR%%/nselib/data/rtsp-urls.txt
%%DATADIR%%/nselib/data/snmpcommunities.lst
-%%DATADIR%%/nselib/data/ssl-ciphers
%%DATADIR%%/nselib/data/ssl-fingerprints
+%%DATADIR%%/nselib/data/targets-ipv6-wordlist
%%DATADIR%%/nselib/data/tftplist.txt
%%DATADIR%%/nselib/data/usernames.lst
%%DATADIR%%/nselib/data/vhosts-default.lst
%%DATADIR%%/nselib/data/vhosts-full.lst
%%DATADIR%%/nselib/data/wp-plugins.lst
+%%DATADIR%%/nselib/data/wp-themes.lst
%%DATADIR%%/nselib/datafiles.lua
%%DATADIR%%/nselib/dhcp.lua
%%DATADIR%%/nselib/dhcp6.lua
@@ -115,6 +120,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/ldap.lua
%%DATADIR%%/nselib/lfs.luadoc
%%DATADIR%%/nselib/listop.lua
+%%DATADIR%%/nselib/lpeg-utility.lua
%%DATADIR%%/nselib/match.lua
%%DATADIR%%/nselib/membase.lua
%%DATADIR%%/nselib/mobileme.lua
@@ -141,6 +147,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/pppoe.lua
%%DATADIR%%/nselib/proxy.lua
%%DATADIR%%/nselib/rdp.lua
+%%DATADIR%%/nselib/re.lua
%%DATADIR%%/nselib/redis.lua
%%DATADIR%%/nselib/rmi.lua
%%DATADIR%%/nselib/rpc.lua
@@ -199,6 +206,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/auth-spoof.nse
%%DATADIR%%/scripts/backorifice-brute.nse
%%DATADIR%%/scripts/backorifice-info.nse
+%%DATADIR%%/scripts/bacnet-info.nse
%%DATADIR%%/scripts/banner.nse
%%DATADIR%%/scripts/bitcoin-getaddr.nse
%%DATADIR%%/scripts/bitcoin-info.nse
@@ -253,7 +261,6 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/daap-get-library.nse
%%DATADIR%%/scripts/daytime.nse
%%DATADIR%%/scripts/db2-das-info.nse
-%%DATADIR%%/scripts/db2-discover.nse
%%DATADIR%%/scripts/dhcp-discover.nse
%%DATADIR%%/scripts/dict-info.nse
%%DATADIR%%/scripts/distcc-cve2004-2687.nse
@@ -275,6 +282,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/dns-update.nse
%%DATADIR%%/scripts/dns-zeustracker.nse
%%DATADIR%%/scripts/dns-zone-transfer.nse
+%%DATADIR%%/scripts/docker-version.nse
%%DATADIR%%/scripts/domcon-brute.nse
%%DATADIR%%/scripts/domcon-cmd.nse
%%DATADIR%%/scripts/domino-enum-users.nse
@@ -283,8 +291,10 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/drda-info.nse
%%DATADIR%%/scripts/duplicates.nse
%%DATADIR%%/scripts/eap-info.nse
+%%DATADIR%%/scripts/enip-info.nse
%%DATADIR%%/scripts/epmd-info.nse
%%DATADIR%%/scripts/eppc-enum-processes.nse
+%%DATADIR%%/scripts/fcrdns.nse
%%DATADIR%%/scripts/finger.nse
%%DATADIR%%/scripts/firewalk.nse
%%DATADIR%%/scripts/firewall-bypass.nse
@@ -318,6 +328,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-apache-negotiation.nse
%%DATADIR%%/scripts/http-auth-finder.nse
%%DATADIR%%/scripts/http-auth.nse
+%%DATADIR%%/scripts/http-avaya-ipoffice-users.nse
%%DATADIR%%/scripts/http-awstatstotals-exec.nse
%%DATADIR%%/scripts/http-axis2-dir-traversal.nse
%%DATADIR%%/scripts/http-backup-finder.nse
@@ -325,10 +336,12 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-brute.nse
%%DATADIR%%/scripts/http-cakephp-version.nse
%%DATADIR%%/scripts/http-chrono.nse
+%%DATADIR%%/scripts/http-cisco-anyconnect.nse
%%DATADIR%%/scripts/http-coldfusion-subzero.nse
%%DATADIR%%/scripts/http-comments-displayer.nse
%%DATADIR%%/scripts/http-config-backup.nse
%%DATADIR%%/scripts/http-cors.nse
+%%DATADIR%%/scripts/http-crossdomainxml.nse
%%DATADIR%%/scripts/http-csrf.nse
%%DATADIR%%/scripts/http-date.nse
%%DATADIR%%/scripts/http-default-accounts.nse
@@ -382,6 +395,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-robtex-reverse-ip.nse
%%DATADIR%%/scripts/http-robtex-shared-ns.nse
%%DATADIR%%/scripts/http-server-header.nse
+%%DATADIR%%/scripts/http-shellshock.nse
%%DATADIR%%/scripts/http-sitemap-generator.nse
%%DATADIR%%/scripts/http-slowloris-check.nse
%%DATADIR%%/scripts/http-slowloris.nse
@@ -398,6 +412,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-virustotal.nse
%%DATADIR%%/scripts/http-vlcstreamer-ls.nse
%%DATADIR%%/scripts/http-vmware-path-vuln.nse
+%%DATADIR%%/scripts/http-vuln-cve2006-3392.nse
%%DATADIR%%/scripts/http-vuln-cve2009-3960.nse
%%DATADIR%%/scripts/http-vuln-cve2010-0738.nse
%%DATADIR%%/scripts/http-vuln-cve2010-2861.nse
@@ -405,12 +420,20 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-vuln-cve2011-3368.nse
%%DATADIR%%/scripts/http-vuln-cve2012-1823.nse
%%DATADIR%%/scripts/http-vuln-cve2013-0156.nse
-%%DATADIR%%/scripts/http-vuln-zimbra-lfi.nse
+%%DATADIR%%/scripts/http-vuln-cve2013-7091.nse
+%%DATADIR%%/scripts/http-vuln-cve2014-2126.nse
+%%DATADIR%%/scripts/http-vuln-cve2014-2127.nse
+%%DATADIR%%/scripts/http-vuln-cve2014-2128.nse
+%%DATADIR%%/scripts/http-vuln-cve2014-2129.nse
+%%DATADIR%%/scripts/http-vuln-cve2015-1427.nse
+%%DATADIR%%/scripts/http-vuln-cve2015-1635.nse
+%%DATADIR%%/scripts/http-vuln-misfortune-cookie.nse
+%%DATADIR%%/scripts/http-vuln-wnr1000-creds.nse
%%DATADIR%%/scripts/http-waf-detect.nse
%%DATADIR%%/scripts/http-waf-fingerprint.nse
%%DATADIR%%/scripts/http-wordpress-brute.nse
%%DATADIR%%/scripts/http-wordpress-enum.nse
-%%DATADIR%%/scripts/http-wordpress-plugins.nse
+%%DATADIR%%/scripts/http-wordpress-users.nse
%%DATADIR%%/scripts/http-xssed.nse
%%DATADIR%%/scripts/iax2-brute.nse
%%DATADIR%%/scripts/iax2-version.nse
@@ -457,6 +480,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/metasploit-info.nse
%%DATADIR%%/scripts/metasploit-msgrpc-brute.nse
%%DATADIR%%/scripts/metasploit-xmlrpc-brute.nse
+%%DATADIR%%/scripts/mikrotik-routeros-brute.nse
%%DATADIR%%/scripts/mmouse-brute.nse
%%DATADIR%%/scripts/mmouse-exec.nse
%%DATADIR%%/scripts/modbus-discover.nse
@@ -511,6 +535,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/ntp-monlist.nse
%%DATADIR%%/scripts/omp2-brute.nse
%%DATADIR%%/scripts/omp2-enum-targets.nse
+%%DATADIR%%/scripts/omron-info.nse
%%DATADIR%%/scripts/openlookup-info.nse
%%DATADIR%%/scripts/openvas-otp-brute.nse
%%DATADIR%%/scripts/oracle-brute-stealth.nse
@@ -552,6 +577,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/rsync-list-modules.nse
%%DATADIR%%/scripts/rtsp-methods.nse
%%DATADIR%%/scripts/rtsp-url-brute.nse
+%%DATADIR%%/scripts/s7-info.nse
%%DATADIR%%/scripts/samba-vuln-cve-2012-1182.nse
%%DATADIR%%/scripts/script.db
%%DATADIR%%/scripts/servicetags.nse
@@ -591,6 +617,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/sniffer-detect.nse
%%DATADIR%%/scripts/snmp-brute.nse
%%DATADIR%%/scripts/snmp-hh3c-logins.nse
+%%DATADIR%%/scripts/snmp-info.nse
%%DATADIR%%/scripts/snmp-interfaces.nse
%%DATADIR%%/scripts/snmp-ios-config.nse
%%DATADIR%%/scripts/snmp-netstat.nse
@@ -606,23 +633,28 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/ssh-hostkey.nse
%%DATADIR%%/scripts/ssh2-enum-algos.nse
%%DATADIR%%/scripts/sshv1.nse
+%%DATADIR%%/scripts/ssl-ccs-injection.nse
%%DATADIR%%/scripts/ssl-cert.nse
%%DATADIR%%/scripts/ssl-date.nse
%%DATADIR%%/scripts/ssl-enum-ciphers.nse
%%DATADIR%%/scripts/ssl-google-cert-catalog.nse
%%DATADIR%%/scripts/ssl-heartbleed.nse
%%DATADIR%%/scripts/ssl-known-key.nse
+%%DATADIR%%/scripts/ssl-poodle.nse
%%DATADIR%%/scripts/sslv2.nse
%%DATADIR%%/scripts/sstp-discover.nse
%%DATADIR%%/scripts/stun-info.nse
%%DATADIR%%/scripts/stun-version.nse
%%DATADIR%%/scripts/stuxnet-detect.nse
+%%DATADIR%%/scripts/supermicro-ipmi-conf.nse
%%DATADIR%%/scripts/svn-brute.nse
%%DATADIR%%/scripts/targets-asn.nse
+%%DATADIR%%/scripts/targets-ipv6-map4to6.nse
%%DATADIR%%/scripts/targets-ipv6-multicast-echo.nse
%%DATADIR%%/scripts/targets-ipv6-multicast-invalid-dst.nse
%%DATADIR%%/scripts/targets-ipv6-multicast-mld.nse
%%DATADIR%%/scripts/targets-ipv6-multicast-slaac.nse
+%%DATADIR%%/scripts/targets-ipv6-wordlist.nse
%%DATADIR%%/scripts/targets-sniffer.nse
%%DATADIR%%/scripts/targets-traceroute.nse
%%DATADIR%%/scripts/teamspeak2-version.nse