aboutsummaryrefslogtreecommitdiffstats
path: root/security/oinkmaster
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
committermat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
commit9e7703aff1c96dce4c11180df6bfd80c536b777a (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /security/oinkmaster
parentfbcb74cea8547a229eabdb6530aecdeb2689cf82 (diff)
downloadfreebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.gz
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.zst
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'security/oinkmaster')
-rw-r--r--security/oinkmaster/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/security/oinkmaster/Makefile b/security/oinkmaster/Makefile
index d81a9fb70e54..0627823a8afb 100644
--- a/security/oinkmaster/Makefile
+++ b/security/oinkmaster/Makefile
@@ -17,8 +17,9 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
OPTIONS_DEFINE= DOCS
NO_BUILD= yes
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
+SHEBANG_FILES= oinkmaster.pl
PLIST_FILES= bin/oinkmaster \
etc/oinkmaster.conf.sample \
@@ -26,11 +27,6 @@ PLIST_FILES= bin/oinkmaster \
PORTDOCS= README
-post-patch:
- @${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},g' \
- -e 's,"tPf","tf",' \
- ${WRKSRC}/oinkmaster.pl
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/oinkmaster.pl ${STAGEDIR}${PREFIX}/bin/oinkmaster
${INSTALL_DATA} ${WRKSRC}/oinkmaster.conf ${STAGEDIR}${PREFIX}/etc/oinkmaster.conf.sample