aboutsummaryrefslogtreecommitdiffstats
path: root/security/opencryptoki
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-07-31 23:45:20 +0800
committerhrs <hrs@FreeBSD.org>2013-07-31 23:45:20 +0800
commit34f6e0af43933ded5d810b9f733be8bca7ac2f05 (patch)
treecb9416fc0e435e34df1d93bf9fac92e737281b0a /security/opencryptoki
parentd05665ce8bba1881abc888e6552cd3298c6b6366 (diff)
downloadfreebsd-ports-gnome-34f6e0af43933ded5d810b9f733be8bca7ac2f05.tar.gz
freebsd-ports-gnome-34f6e0af43933ded5d810b9f733be8bca7ac2f05.tar.zst
freebsd-ports-gnome-34f6e0af43933ded5d810b9f733be8bca7ac2f05.zip
- Fix LIB_DEPENDS.
- Style cleanups. - Take maintainership.
Diffstat (limited to 'security/opencryptoki')
-rw-r--r--security/opencryptoki/Makefile35
-rw-r--r--security/opencryptoki/pkg-descr2
-rw-r--r--security/opencryptoki/pkg-plist1
3 files changed, 18 insertions, 20 deletions
diff --git a/security/opencryptoki/Makefile b/security/opencryptoki/Makefile
index 10f838efe923..30cbf9303889 100644
--- a/security/opencryptoki/Makefile
+++ b/security/opencryptoki/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= hrs@FreeBSD.org
COMMENT= Open PKCS\#11 implementation library
LICENSE= CPL
@@ -15,25 +15,13 @@ LICENSE_NAME= Common Public License
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-LIB_DEPENDS= libtspi.so:${PORTSDIR}/security/trousers
+LIB_DEPENDS= tspi:${PORTSDIR}/security/trousers
-USE_BZIP2= YES
USES= gmake
+USE_BZIP2= YES
USE_LDCONFIG= YES
USE_AUTOTOOLS= autoconf libtool automake
-
-USE_RC_SUBR= pkcsslotd
-SUB_FILES= pkg-message
-SUB_LIST= USERS=${USERS} GROUPS=${GROUPS}
-
-MAN1= pkcs11_startup.1 pkcsconf.1
-MAN5= pk_config_data.5
-MAN7= opencryptoki.7
-MAN8= pkcsslotd.8
-
-USERS= _pkcs11
-GROUPS= _pkcs11
-
+HAS_CONFIGURE= YES
CONFIGURE_ARGS= --enable-swtok --enable-tpmtok \
--disable-crtok --disable-aeptok \
--disable-ccatok --disable-bcomtok \
@@ -43,11 +31,18 @@ CONFIGURE_ARGS= --enable-swtok --enable-tpmtok \
--localstatedir=${PREFIX}/var \
--with-pkcs11user=${USERS} \
--with-pkcs11group=${GROUPS}
+CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+USE_RC_SUBR= pkcsslotd
+SUB_FILES= pkg-message
+SUB_LIST= USERS=${USERS} GROUPS=${GROUPS}
+USERS= _pkcs11
+GROUPS= _pkcs11
-.include <bsd.port.pre.mk>
-
-CFLAGS+= -I${LOCALBASE}/include
+MAN1= pkcs11_startup.1 pkcsconf.1
+MAN5= pk_config_data.5
+MAN7= opencryptoki.7
+MAN8= pkcsslotd.8
run-autotools: run-autotools-autoreconf
@@ -58,4 +53,4 @@ post-install:
@cd ${PREFIX}/lib && ${LN} -s opencryptoki/libopencryptoki* .
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/opencryptoki/pkg-descr b/security/opencryptoki/pkg-descr
index cdaa8827a684..5d6551d3c11b 100644
--- a/security/opencryptoki/pkg-descr
+++ b/security/opencryptoki/pkg-descr
@@ -1 +1,3 @@
openCryptoki is a PKCS#11 implementation.
+
+WWW: http://sourceforge.net/projects/opencryptoki/
diff --git a/security/opencryptoki/pkg-plist b/security/opencryptoki/pkg-plist
index 438579c9ed7e..7ea0d3d5d1d0 100644
--- a/security/opencryptoki/pkg-plist
+++ b/security/opencryptoki/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
include/opencryptoki/apiclient.h
include/opencryptoki/pkcs11.h
include/opencryptoki/pkcs11types.h