aboutsummaryrefslogtreecommitdiffstats
path: root/security/opensc
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2019-07-12 10:25:07 +0800
committerlinimon <linimon@FreeBSD.org>2019-07-12 10:25:07 +0800
commit59bb9171a907de6de27397b000cf6807bcd5cbe7 (patch)
treeae010486371dd984317b78c829a6c1566d322249 /security/opensc
parent37e2eea0c32d87940ca94d66a1af7811ebab434a (diff)
downloadfreebsd-ports-gnome-59bb9171a907de6de27397b000cf6807bcd5cbe7.tar.gz
freebsd-ports-gnome-59bb9171a907de6de27397b000cf6807bcd5cbe7.tar.zst
freebsd-ports-gnome-59bb9171a907de6de27397b000cf6807bcd5cbe7.zip
Prepare for powerpc-on-clang by deleting hard-coded tests for libstdc++.so
as a stand-in for "are we running on gcc". For people already testing powerpc on clang, it is possible that they already have both compilers in base. Thus, the assumption that "gcc is in base" (e.g. libstdc++.so exists) always means "force use of GCC" is already broken. It will be for everyone on -CURRENT once the switch is made. While here, standardize on compiler:c++11-lang instead of -lib (they are equivalent these days), pet portlint, and do some other cleanup. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'security/opensc')
-rw-r--r--security/opensc/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index 7288a2feb491..4a1206059b55 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -11,7 +11,7 @@ COMMENT= Libraries and utilities to access smart cards
LICENSE= LGPL21
-USES= libtool pkgconfig gmake ssl autoreconf
+USES= autoreconf compiler gmake libtool pkgconfig ssl
OPTIONS_SINGLE= BACKEND
OPTIONS_SINGLE_BACKEND=PCSC OPENCT CTAPI
@@ -66,10 +66,12 @@ CONFIGURE_ENV+= XSLTPROC="${FALSE}"
CONFIGURE_ARGS+=--without-xsl-stylesheetsdir
.endif
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
post-patch:
-.if exists(/usr/lib/libstdc++.so)
${REINPLACE_CMD} -e '/-Wno-unused-but-set-variable/d' \
${WRKSRC}/src/tools/Makefile.am
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>