aboutsummaryrefslogtreecommitdiffstats
path: root/security/openscep
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2011-02-14 06:06:37 +0800
committerohauer <ohauer@FreeBSD.org>2011-02-14 06:06:37 +0800
commit22ed16a49bbe46e2dd28a3f671d1197c2906714d (patch)
treef3054b85552da3a852820c652a6e1d0a4d2eec86 /security/openscep
parent6101a38660a7e5df1c7adbb825c4573533e681f8 (diff)
downloadfreebsd-ports-gnome-22ed16a49bbe46e2dd28a3f671d1197c2906714d.tar.gz
freebsd-ports-gnome-22ed16a49bbe46e2dd28a3f671d1197c2906714d.tar.zst
freebsd-ports-gnome-22ed16a49bbe46e2dd28a3f671d1197c2906714d.zip
- fix leftover if APACHE_VERSION > 13
PR: ports/147009
Diffstat (limited to 'security/openscep')
-rw-r--r--security/openscep/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/security/openscep/Makefile b/security/openscep/Makefile
index 2080f812147b..a82538e29b85 100644
--- a/security/openscep/Makefile
+++ b/security/openscep/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openscep
PORTVERSION= 0.4.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= http://openscep.othello.ch/download/
@@ -24,6 +24,12 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} > 13
+PLIST_DIRSTRY= www/cgi-bin
+.endif
+
CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV= CPPFLAGS=${CPPFLAGS} LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-html-install-dir="${PREFIX}/www/openscep" \
@@ -72,4 +78,4 @@ post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>