aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2017-08-19 23:11:03 +0800
committerbrnrd <brnrd@FreeBSD.org>2017-08-19 23:11:03 +0800
commit84efd252cbeab77cc1dd003065dd710dbfb08aed (patch)
tree470c76a2f9b2a609edb5ebb496647aa234c23901 /security/openssl/Makefile
parent7aca053c58791069fa99fed8b2eeee98d71aefda (diff)
downloadfreebsd-ports-gnome-84efd252cbeab77cc1dd003065dd710dbfb08aed.tar.gz
freebsd-ports-gnome-84efd252cbeab77cc1dd003065dd710dbfb08aed.tar.zst
freebsd-ports-gnome-84efd252cbeab77cc1dd003065dd710dbfb08aed.zip
security/openssl: Fix build on MIPS
- gcc 4.2.1 on MIPS fails on -Werror PR: 221620 Submitted by: Fukang Chen <loader@FreeBSD.org> MFH: 2017Q3
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index a931caf512ad..b1f62f5eaf8a 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -57,7 +57,7 @@ SSL2_DESC= SSLv2 protocol support
SSL3_DESC= SSLv3 protocol support
ZLIB_DESC= zlib compression support
-USES= cpe perl5
+USES= compiler cpe perl5
USE_PERL5= build
MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
MAKE_ENV+= LIBRPATH="${PREFIX}/lib" GREP_OPTIONS=
@@ -100,10 +100,12 @@ THREADS_CONFIGURE_OFF= no-threads
ZLIB_CONFIGURE_ON= zlib zlib-dynamic
ZLIB_CONFIGURE_OFF= no-zlib no-zlib-dynamic
-CFLAGS+= -Werror -Qunused-arguments
-
.include <bsd.port.pre.mk>
+.if ${CHOSEN_COMPILER_TYPE} != gcc && ${COMPILER_VERSION} != 42
+CFLAGS+= -Werror -Qunused-arguments
+.endif
+
.if ${PREFIX} == /usr
IGNORE= the OpenSSL port can not be installed over the base version
.endif