aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2010-01-05 20:13:56 +0800
committerale <ale@FreeBSD.org>2010-01-05 20:13:56 +0800
commit038aae04093ee789024876f33ce4e503be63ba3e (patch)
tree49e245571d8f3c0f2bf0ce3b30755ec3e51df5fa /security/openssl
parent572f8ea4e0f59173c231d2320b3111d9cb689b75 (diff)
downloadfreebsd-ports-gnome-038aae04093ee789024876f33ce4e503be63ba3e.tar.gz
freebsd-ports-gnome-038aae04093ee789024876f33ce4e503be63ba3e.tar.zst
freebsd-ports-gnome-038aae04093ee789024876f33ce4e503be63ba3e.zip
Don't link unneeded PTHREAD_LIBS.
Approved by: portmgr
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile3
-rw-r--r--security/openssl/files/patch-Configure2
2 files changed, 3 insertions, 2 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index aa6e5828e197..810d1e10d3e2 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.8l
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
@@ -925,7 +926,7 @@ do-configure:
.endif
cd ${WRKSRC} \
&& ${SETENV} CC="${CC}" FREEBSDCC="${CC}" CFLAGS="${CFLAGS}" PERL="${PERL}" \
- PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS} \
+ PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
./config --prefix=${PREFIX} --openssldir=${OPENSSLDIR} \
-L${PREFIX}/lib ${EXTRACONFIGURE}
.if defined(WITH_FIPS)
diff --git a/security/openssl/files/patch-Configure b/security/openssl/files/patch-Configure
index 691fe7b848af..45e9385cab7d 100644
--- a/security/openssl/files/patch-Configure
+++ b/security/openssl/files/patch-Configure
@@ -5,7 +5,7 @@
# sometimes -D_REENTRANT. FreeBSD 5.x expands it as -lc_r, which
# seems to be sufficient?
-my $BSDthreads="-pthread -D_THREAD_SAFE -D_REENTRANT";
-+my $BSDthreads="$ENV{'PTHREAD_LIBS'} -D_REENTRANT $ENV{'PTHREAD_CFLAGS'}";
++my $BSDthreads="$ENV{'PTHREAD_CFLAGS'}";
#config-string $cc : $cflags : $unistd : $thread_cflag : $sys_id : $lflags : $bn_ops : $cpuid_obj : $bn_obj : $des_obj : $aes_obj : $bf_obj : $md5_obj : $sha1_obj : $cast_obj : $rc4_obj : $rmd160_obj : $rc5_obj : $dso_scheme : $shared_target : $shared_cflag : $shared_ldflag : $shared_extension : $ranlib : $arflags