aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2016-04-05 03:09:39 +0800
committerdinoex <dinoex@FreeBSD.org>2016-04-05 03:09:39 +0800
commit1ebc8706a38d84d120ee4f91330148f8c2a6af65 (patch)
tree15484149c805db174b0b91977758802bbff9b542 /security/openssl
parentacbd74a8e0d176c751a2e3c202d8a286b30990b3 (diff)
downloadfreebsd-ports-gnome-1ebc8706a38d84d120ee4f91330148f8c2a6af65.tar.gz
freebsd-ports-gnome-1ebc8706a38d84d120ee4f91330148f8c2a6af65.tar.zst
freebsd-ports-gnome-1ebc8706a38d84d120ee4f91330148f8c2a6af65.zip
- remove NOPRECIOUS*
- make portlint happier
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 473318137540..3aba813ab971 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -14,15 +14,18 @@ DIST_SUBDIR= ${DISTNAME}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= SSL and crypto library
-.ifdef USE_OPENSSL
-.error You have `USE_OPENSSL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
-.endif
+LICENSE= OpenSSL
+LICENSE_FILE= ${WRKSRC}/LICENSE
-CONFLICTS?= libressl-[0-9]* \
+MAKE_JOBS_UNSAFE= yes
+CPE_VERSION= ${PORTVERSION}${DISTVERSIONSUFFIX}
+CONFLICTS= libressl-[0-9]* \
libressl-devel-[0-9]* \
openssl-devel-[0-9]*
-LICENSE= OpenSSL
-LICENSE_FILE= ${WRKSRC}/LICENSE
+
+.ifdef USE_OPENSSL
+.error You have `USE_OPENSSL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
OPTIONS_DEFINE= SHARED THREADS I386 SSE2 ASM PADLOCK ZLIB GMP SCTP SSL2 SSL3 RFC3779 MD2 RC5 EXPCIPHERS DOCS MAN3
OPTIONS_DEFAULT=SHARED THREADS SSE2 SCTP SSL2 SSL3 MD2 MAN3
@@ -56,18 +59,12 @@ MAN3_DESC?= Install API manpages (section 3)
GMP_LIB_DEPENDS= libgmp.so:math/gmp
-MAKE_JOBS_UNSAFE= yes
-NOPRECIOUSMAKEVARS= Too many _MLINKS for fetch
-NOPRECIOUSSOFTMAKEVARS= Too many _MLINKS for fetch
-
USES= perl5 cpe
USE_PERL5= build
MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
MAKE_ENV+= LIBRPATH="${PREFIX}/lib" GREP_OPTIONS=
SUB_FILES= pkg-message
-CPE_VERSION= ${PORTVERSION}${DISTVERSIONSUFFIX}
-
.include <bsd.port.pre.mk>
.if ${PREFIX} == /usr