aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-07-22 01:51:43 +0800
committerdinoex <dinoex@FreeBSD.org>2009-07-22 01:51:43 +0800
commit2f2f44c0191d50a679e83c8decc2c98b9074e373 (patch)
treecfbcedc8568afa4bcdc8294ce41f9e77475bdcfb /security/openssl
parentb57d234717d531efea67ceba89761f00d4bfa915 (diff)
downloadfreebsd-ports-gnome-2f2f44c0191d50a679e83c8decc2c98b9074e373.tar.gz
freebsd-ports-gnome-2f2f44c0191d50a679e83c8decc2c98b9074e373.tar.zst
freebsd-ports-gnome-2f2f44c0191d50a679e83c8decc2c98b9074e373.zip
- fix build for OSVERSION 800105
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 7523ae8d5095..040740560401 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -855,7 +855,11 @@ MLINKS= dgst.1 md4.1 \
OPENSSL_BASE_SONAME!= readlink ${DESTDIR}/usr/lib/libcrypto.so || true
OPENSSL_SHLIBVER_BASE= ${OPENSSL_BASE_SONAME:E}
OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}
+.if ( ${OSVERSION} >= 800105 )
+OPENSSL_SHLIBVER?= 6
+.else
OPENSSL_SHLIBVER?= 5
+.endif
.if !defined(WITHOUT_SSE2)
# disable runtime SSE2 detection