aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-03-03 21:58:50 +0800
committerfeld <feld@FreeBSD.org>2016-03-03 21:58:50 +0800
commit7f423f3bfa82e3ea8526c4c79743c94f185c95ce (patch)
tree0523ef02caf630fbae25f228451746bad32bf984 /security/openssl
parentc77402bd8ab26e48580096359b035708811b7996 (diff)
downloadfreebsd-ports-gnome-7f423f3bfa82e3ea8526c4c79743c94f185c95ce.tar.gz
freebsd-ports-gnome-7f423f3bfa82e3ea8526c4c79743c94f185c95ce.tar.zst
freebsd-ports-gnome-7f423f3bfa82e3ea8526c4c79743c94f185c95ce.zip
security/openssl: Revert disabling of SSLv2 and MD2
Disabling SSLv2 without a shared library bump has a visible impact to some applications. It is unclear at this time if disabling MD2 could cause the same issues, but both are being reverted at the moment to be safe. PR: 195796
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index f01ab990a18c..d31d42c88a88 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -4,7 +4,7 @@
PORTNAME= openssl
PORTVERSION= 1.0.2
DISTVERSIONSUFFIX= g
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -23,7 +23,7 @@ LICENSE= OpenSSL
LICENSE_FILE= ${WRKSRC}/LICENSE
OPTIONS_DEFINE= SHARED THREADS I386 SSE2 ASM PADLOCK ZLIB GMP SCTP SSL2 SSL3 RFC3779 MD2 RC5 EXPCIPHERS DOCS MAN3
-OPTIONS_DEFAULT=SHARED THREADS SSE2 SCTP SSL3 MAN3
+OPTIONS_DEFAULT=SHARED THREADS SSE2 SCTP SSL2 SSL3 MD2 MAN3
.for a in amd64 ia64
OPTIONS_DEFINE_${a}= EC
OPTIONS_DEFAULT_${a}= EC