aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2014-08-11 12:27:53 +0800
committerDirk Meyer <dinoex@FreeBSD.org>2014-08-11 12:27:53 +0800
commit8ba4016c73b3f4324084bf1188f754ad1c9c3d70 (patch)
treeb6d8f4ef2a9f76a4b07ccfaef767d2675adc9c0f /security/openssl
parent2acea30c9bfdd675b3c864072f6814ad003b169d (diff)
downloadfreebsd-ports-gnome-8ba4016c73b3f4324084bf1188f754ad1c9c3d70.tar.gz
freebsd-ports-gnome-8ba4016c73b3f4324084bf1188f754ad1c9c3d70.tar.zst
freebsd-ports-gnome-8ba4016c73b3f4324084bf1188f754ad1c9c3d70.zip
- new options SSL2 SSL3
Suggested by: Velcro Leaf
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index f630fef9aab9..7bc3bf61e86f 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -21,8 +21,8 @@ COMMENT= SSL and crypto library
CONFLICTS?= libressl-*
-OPTIONS_DEFINE= SHARED THREADS I386 SSE2 ASM PADLOCK ZLIB SCTP MD2 RC5 RFC3779 GMP DOCS
-OPTIONS_DEFAULT=SHARED THREADS SSE2 ASM ZLIB SCTP MD2
+OPTIONS_DEFINE= SHARED THREADS I386 SSE2 ASM PADLOCK ZLIB SCTP SSL2 SSL3 MD2 RC5 RFC3779 GMP DOCS
+OPTIONS_DEFAULT=SHARED THREADS SSE2 ASM ZLIB SCTP SSL2 SSL3 MD2
.for a in amd64 ia64
OPTIONS_DEFINE_${a}= EC
OPTIONS_DEFAULT_${a}= EC
@@ -41,6 +41,8 @@ PADLOCK_DESC?= VIA Padlock support
SHARED_DESC?= build of shared libs
ZLIB_DESC?= zlib compression support
SCTP_DESC?= SCTP protocol support
+SSL2_DESC?= SSLv2 protocol support
+SSL3_DESC?= SSLv3 protocol support
MD2_DESC?= MD2 hash (obsolete)
RC5_DESC?= RC5 cipher (patented)
RFC3779_DESC?= RFC3779 support
@@ -137,6 +139,18 @@ EXTRACONFIGURE+= sctp
EXTRACONFIGURE+= no-sctp
.endif
+.if ${PORT_OPTIONS:MSSL2}
+EXTRACONFIGURE+= enable-ssl2
+.else
+EXTRACONFIGURE+= no-ssl2
+.endif
+
+.if ${PORT_OPTIONS:MSSL3}
+EXTRACONFIGURE+= enable-ssl3
+.else
+EXTRACONFIGURE+= no-ssl3
+.endif
+
.if ${PORT_OPTIONS:MMD2}
EXTRACONFIGURE+= enable-md2
.else