aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-01-02 12:17:19 +0800
committerdinoex <dinoex@FreeBSD.org>2003-01-02 12:17:19 +0800
commitc0faa9af7937d20c085556f3d84912b1cc6abce5 (patch)
treeb4f1fbcbb0259963b840d2e126d86b1c3bf8f3f7 /security/openssl
parent00808bbb2b1e97f17e954d42121c2be57da339ef (diff)
downloadfreebsd-ports-gnome-c0faa9af7937d20c085556f3d84912b1cc6abce5.tar.gz
freebsd-ports-gnome-c0faa9af7937d20c085556f3d84912b1cc6abce5.tar.zst
freebsd-ports-gnome-c0faa9af7937d20c085556f3d84912b1cc6abce5.zip
- Update to 0.9.6h
- md5 verified - add test target - make build on sparc64
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile10
-rw-r--r--security/openssl/distinfo2
-rw-r--r--security/openssl/files/patch-ac9
-rw-r--r--security/openssl/files/patch-config18
4 files changed, 31 insertions, 8 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 21e465f60bff..f9736d0dd6b1 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openssl
-PORTVERSION= 0.9.6g
-PORTREVISION= 1
+PORTVERSION= 0.9.6h
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -133,8 +132,10 @@ MAN5= config.5
MAN7= des_modes.7
.if defined(BATCH) || defined(OPENSSL_WITH_386)
+.if ${MACHINE_ARCH} == "i386"
EXTRACONFIGURE= 386
.endif
+.endif
do-configure:
.if exists(/usr/src/crypto/openssl/crypto/des/rnd_keys.c)
@@ -144,7 +145,7 @@ do-configure:
${CP} ${FILESDIR}/rnd_keys.c \
${WRKSRC}/crypto/des/rnd_keys.c
.endif
- @cd ${WRKSRC} \
+ cd ${WRKSRC} \
&& ${SETENV} CC="${CC}" CFLAGS="${CFLAGS}" PERL="${PERL}" \
./config --prefix=${PREFIX} --openssldir=${OPENSSLDIR} \
-L${PREFIX}/lib ${EXTRACONFIGURE}
@@ -162,4 +163,7 @@ post-install:
.endif
@${SED} -e 's#/usr/local#${PREFIX}#g' ${PKGMESSAGE}
+test:
+ cd ${WRKSRC} && ${MAKE} test
+
.include <bsd.port.post.mk>
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index 26834a786e24..a6e39d1c8e83 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -1 +1 @@
-MD5 (openssl-0.9.6g.tar.gz) = 515ed54165a55df83f4eb4e4e9078d3f
+MD5 (openssl-0.9.6h.tar.gz) = 621bef36ad61012bb71945a1cb449073
diff --git a/security/openssl/files/patch-ac b/security/openssl/files/patch-ac
index 8c390d4186a3..7695196e55e4 100644
--- a/security/openssl/files/patch-ac
+++ b/security/openssl/files/patch-ac
@@ -1,15 +1,16 @@
---- Configure.orig Fri May 10 01:05:49 2002
-+++ Configure Fri May 10 19:00:05 2002
-@@ -309,7 +309,7 @@
+--- Configure.orig Fri Nov 15 02:28:38 2002
++++ Configure Wed Dec 11 22:05:06 2002
+@@ -311,7 +311,8 @@
#
# This probably belongs in a different section.
#
-"FreeBSD-alpha","gcc:-DTERMIOS -O -fomit-frame-pointer::(unknown)::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC2::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+"FreeBSD-alpha","$ENV{CC}:-DTERMIOS $ENV{CFLAGS}::(unknown)::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC2:::",
++"FreeBSD-sparc64","$ENV{CC}:-DB_ENDIAN -DTERMIOS -DULTRASPARC -DBN_DIV2W $ENV{CFLAGS}::(unknown)::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL BF_PTR::::asm/md5-sparcv9.o:",
#### Alpha Linux with GNU C and Compaq C setups
# Special notes:
-@@ -348,8 +348,8 @@
+@@ -350,8 +351,8 @@
"NetBSD-sparc", "gcc:-DTERMIOS -O3 -fomit-frame-pointer -mv8 -Wall -DB_ENDIAN::(unknown)::BN_LLONG MD2_CHAR RC4_INDEX DES_UNROLL::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
"NetBSD-m68", "gcc:-DTERMIOS -O3 -fomit-frame-pointer -Wall -DB_ENDIAN::(unknown)::BN_LLONG MD2_CHAR RC4_INDEX DES_UNROLL::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
"NetBSD-x86", "gcc:-DTERMIOS -O3 -fomit-frame-pointer -m486 -Wall::(unknown)::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
diff --git a/security/openssl/files/patch-config b/security/openssl/files/patch-config
new file mode 100644
index 000000000000..8b31a44cfa03
--- /dev/null
+++ b/security/openssl/files/patch-config
@@ -0,0 +1,18 @@
+--- config.orig Thu Nov 14 08:30:29 2002
++++ config Wed Dec 11 23:10:05 2002
+@@ -180,6 +180,7 @@
+ Pentium\ II*) MACH="i686" ;;
+ Pentium* ) MACH="i586" ;;
+ Alpha* ) MACH="alpha" ;;
++ UltraSparc* ) MACH="sparc64" ;;
+ * ) MACH="$MACHINE" ;;
+ esac
+ case ${MACH} in
+@@ -585,6 +586,7 @@
+ *86*-*-solaris2) OUT="solaris-x86-$CC" ;;
+ *-*-sunos4) OUT="sunos-$CC" ;;
+ alpha*-*-freebsd*) OUT="FreeBSD-alpha" ;;
++ sparc64*-*-freebsd*) OUT="FreeBSD-sparc64" ;;
+ *-freebsd[3-9]*) OUT="FreeBSD-elf" ;;
+ *-freebsd[1-2]*) OUT="FreeBSD" ;;
+ *86*-*-netbsd) OUT="NetBSD-x86" ;;