aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-09-19 13:21:20 +0800
committerdinoex <dinoex@FreeBSD.org>2009-09-19 13:21:20 +0800
commitd104f4c832d68376ce27c96d48ea2a8ce5f4a925 (patch)
treef3ebc42795c233d1a8af1c4e67ae1dbc03c73b74 /security/openssl
parent74a76f46eeaf3277861f495a134ce52a83f9fb0b (diff)
downloadfreebsd-ports-gnome-d104f4c832d68376ce27c96d48ea2a8ce5f4a925.tar.gz
freebsd-ports-gnome-d104f4c832d68376ce27c96d48ea2a8ce5f4a925.tar.zst
freebsd-ports-gnome-d104f4c832d68376ce27c96d48ea2a8ce5f4a925.zip
PR: 138881
Obtained from: openssl-1.0.0 Feature safe: yes
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openssl/files/patch-eng_cryptodev.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 0a788dd403fa..1dca1caac600 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.8k
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
diff --git a/security/openssl/files/patch-eng_cryptodev.c b/security/openssl/files/patch-eng_cryptodev.c
index 8b8942c098ff..b8e146cc58be 100644
--- a/security/openssl/files/patch-eng_cryptodev.c
+++ b/security/openssl/files/patch-eng_cryptodev.c
@@ -57,8 +57,8 @@
return (-1);
+ if (retfd == -1)
+ retfd = fd;
-+ else
-+/* close(fd); fix for PR=138881 */
++/* else fix for PR=138881 */
++/* close(fd); fix for PR=138881 */
/* close on exec */
if (fcntl(retfd, F_SETFD, 1) == -1) {