aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-09-17 15:06:24 +0800
committerdinoex <dinoex@FreeBSD.org>2009-09-17 15:06:24 +0800
commitdce16a2b2c8fa250ea15aa548d5c64642ac58662 (patch)
treee22d203e938893ba1826b8f964b9cad65f5cd013 /security/openssl
parent584d6021c919490842d5183b9a0d733de2065d6b (diff)
downloadfreebsd-ports-gnome-dce16a2b2c8fa250ea15aa548d5c64642ac58662.tar.gz
freebsd-ports-gnome-dce16a2b2c8fa250ea15aa548d5c64642ac58662.tar.zst
freebsd-ports-gnome-dce16a2b2c8fa250ea15aa548d5c64642ac58662.zip
- fix Hardware acceleration
PR: 138881 Submitted by: Larry Baird Feature safe: yes
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openssl/files/patch-eng_cryptodev.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 580d2caf7674..0a788dd403fa 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.8k
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
diff --git a/security/openssl/files/patch-eng_cryptodev.c b/security/openssl/files/patch-eng_cryptodev.c
index 89339f988bf4..8b8942c098ff 100644
--- a/security/openssl/files/patch-eng_cryptodev.c
+++ b/security/openssl/files/patch-eng_cryptodev.c
@@ -58,7 +58,7 @@
+ if (retfd == -1)
+ retfd = fd;
+ else
-+ close(fd);
++/* close(fd); fix for PR=138881 */
/* close on exec */
if (fcntl(retfd, F_SETFD, 1) == -1) {