aboutsummaryrefslogtreecommitdiffstats
path: root/security/openvpn-auth-ldap
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-07 10:47:13 +0800
committeredwin <edwin@FreeBSD.org>2007-09-07 10:47:13 +0800
commit59e6d67960244750ef22109aea094da3830e00f2 (patch)
treeb4c110425d122360dd6af4b17abc0b962d828c33 /security/openvpn-auth-ldap
parent0204d03a741fef34e35124f6aed54ed7c76a8d5e (diff)
downloadfreebsd-ports-gnome-59e6d67960244750ef22109aea094da3830e00f2.tar.gz
freebsd-ports-gnome-59e6d67960244750ef22109aea094da3830e00f2.tar.zst
freebsd-ports-gnome-59e6d67960244750ef22109aea094da3830e00f2.zip
New port: security/openvpn-auth-ldap - LDAP authentication plugin for OpenVPN
The OpenVPN Auth-LDAP Plugin implements username/password authentication via LDAP for OpenVPN 2.x. It also includes some integration with the OpenBSD packet filter, supporting adding and removing VPN clients from PF tables. WWW: http://dpw.threerings.net/projects/openvpn-auth-ldap/ PR: ports/113925 Submitted by: Nick Barkas <snb@threerings.net>
Diffstat (limited to 'security/openvpn-auth-ldap')
-rw-r--r--security/openvpn-auth-ldap/Makefile35
-rw-r--r--security/openvpn-auth-ldap/Makefile.bak34
-rw-r--r--security/openvpn-auth-ldap/distinfo3
-rw-r--r--security/openvpn-auth-ldap/pkg-descr5
4 files changed, 77 insertions, 0 deletions
diff --git a/security/openvpn-auth-ldap/Makefile b/security/openvpn-auth-ldap/Makefile
new file mode 100644
index 000000000000..d98396954db0
--- /dev/null
+++ b/security/openvpn-auth-ldap/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: openvpn-auth-ldap
+# Date created: 06 June 2007
+# Whom: Nick Barkas <snb@threerings.net>
+#
+# $FreeBSD$
+
+PORTNAME= openvpn-auth-ldap
+PORTVERSION= 2.0.3
+CATEGORIES= security
+MASTER_SITES= http://dpw.threerings.net/projects/openvpn-auth-ldap/
+DISTNAME= auth-ldap-${PORTVERSION}
+
+MAINTAINER= snb@threerings.net
+COMMENT= LDAP authentication plugin for OpenVPN
+
+BUILD_DEPENDS= re2c:${PORTSDIR}/devel/re2c \
+ ${NONEXISTENT}:${PORTSDIR}/security/openvpn:extract
+
+GNU_CONFIGURE= yes
+USE_OPENLDAP= yes
+OPENVPN_WRKSRC= `cd ${PORTSDIR}/security/openvpn; make -V WRKSRC`
+CONFIGURE_ARGS+= --with-openldap=${LOCALBASE} \
+ --with-openvpn=${OPENVPN_WRKSRC}
+
+PORTDOCS= README
+PLIST_FILES= lib/openvpn-auth-ldap.so
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
+# DO NOT DELETE
diff --git a/security/openvpn-auth-ldap/Makefile.bak b/security/openvpn-auth-ldap/Makefile.bak
new file mode 100644
index 000000000000..a1ce24f0fef3
--- /dev/null
+++ b/security/openvpn-auth-ldap/Makefile.bak
@@ -0,0 +1,34 @@
+# New ports collection makefile for: openvpn-auth-ldap
+# Date created: 06 June 2007
+# Whom: Nick Barkas <snb@threerings.net>
+#
+# $FreeBSD: /tmp/pcvs/ports/security/openvpn-auth-ldap/Attic/Makefile.bak,v 1.1 2007-09-07 02:47:13 edwin Exp $
+
+PORTNAME= openvpn-auth-ldap
+PORTVERSION= 2.0.3
+CATEGORIES= security
+MASTER_SITES= http://dpw.threerings.net/projects/openvpn-auth-ldap/
+DISTNAME= auth-ldap-${PORTVERSION}
+
+MAINTAINER= snb@threerings.net
+COMMENT= LDAP authentication plugin for OpenVPN
+
+BUILD_DEPENDS= re2c:${PORTSDIR}/devel/re2c \
+ ${NONEXISTENT}:${PORTSDIR}/security/openvpn:extract
+
+GNU_CONFIGURE= yes
+USE_OPENLDAP= yes
+OPENVPN_WRKSRC= `cd ${PORTSDIR}/security/openvpn; make -V WRKSRC`
+CONFIGURE_ARGS+= --with-openldap=${LOCALBASE} \
+ --with-openvpn=${OPENVPN_WRKSRC}
+
+PORTDOCS= README
+PLIST_FILES= lib/openvpn-auth-ldap.so
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/openvpn-auth-ldap/distinfo b/security/openvpn-auth-ldap/distinfo
new file mode 100644
index 000000000000..5b88a3ea2b79
--- /dev/null
+++ b/security/openvpn-auth-ldap/distinfo
@@ -0,0 +1,3 @@
+MD5 (auth-ldap-2.0.3.tar.gz) = 03dedc57efc8d4fc2ffe2c014121299d
+SHA256 (auth-ldap-2.0.3.tar.gz) = 2b258610b0f3fe9ce097b0e88b4c78e402e5f3f814b7d327392ba72574d1b63a
+SIZE (auth-ldap-2.0.3.tar.gz) = 261832
diff --git a/security/openvpn-auth-ldap/pkg-descr b/security/openvpn-auth-ldap/pkg-descr
new file mode 100644
index 000000000000..372191710e76
--- /dev/null
+++ b/security/openvpn-auth-ldap/pkg-descr
@@ -0,0 +1,5 @@
+The OpenVPN Auth-LDAP Plugin implements username/password authentication via
+LDAP for OpenVPN 2.x. It also includes some integration with the OpenBSD
+packet filter, supporting adding and removing VPN clients from PF tables.
+
+WWW: http://dpw.threerings.net/projects/openvpn-auth-ldap/