aboutsummaryrefslogtreecommitdiffstats
path: root/security/openvpn
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2009-01-25 16:10:57 +0800
committerbeech <beech@FreeBSD.org>2009-01-25 16:10:57 +0800
commit45963ee40cdb9c08e1f7b24710111ad79bb4b7bf (patch)
tree0868c4f0c7c00c809554a7e8e301815d3f551510 /security/openvpn
parent864db94f14815f17462313e59c78cd840180edfb (diff)
downloadfreebsd-ports-gnome-45963ee40cdb9c08e1f7b24710111ad79bb4b7bf.tar.gz
freebsd-ports-gnome-45963ee40cdb9c08e1f7b24710111ad79bb4b7bf.tar.zst
freebsd-ports-gnome-45963ee40cdb9c08e1f7b24710111ad79bb4b7bf.zip
- Add logging knob
PR: ports/130893 Submitted by: Michael Scheidell <scheidell@secnap.net> Approved by: Matthias Andree <matthias.andree@gmx.de> (maintainer)
Diffstat (limited to 'security/openvpn')
-rw-r--r--security/openvpn/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index af4db0165d5b..152f2075947b 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -43,6 +43,22 @@ SUB_LIST+= OSVERSION=${OSVERSION}
SUB_LIST+= RCSFX=${RC_SUBR_SUFFIX}
+.ifdef (LOG_OPENVPN)
+CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
+.endif
+
+pre-fetch:
+.ifdef (LOG_OPENVPN)
+ @${ECHO} "Building with LOG_OPENVPN=${LOG_OPENVPN}"
+.else
+ @${ECHO} ""
+ @${ECHO} "You may use the following build options:"
+ @${ECHO} ""
+ @${ECHO} " LOG_OPENVPN={Valid syslog facility}"
+ @${ECHO} " EXAMPLE: make LOG_OPENVPN=LOG_DAEMON"
+ @${ECHO} ""
+.endif
+
# NOTE: there is no way to explicitly specify the LZO version to OpenVPN,
# if LZO2 and LZO1 are installed, OpenVPN will pick LZO2.
# So depend on LZO1 only if it's already there and LZO2 isn't.