aboutsummaryrefslogtreecommitdiffstats
path: root/security/openvpn
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2010-08-05 03:53:56 +0800
committerMatthias Andree <mandree@FreeBSD.org>2010-08-05 03:53:56 +0800
commitf33f5a90cac5bebc2a125f102e46c11290fba3da (patch)
treebe5173904b9e168c09e4e0de4b258f487b467811 /security/openvpn
parentb108d6939164e654b6c44352e0a20af0900e95de (diff)
downloadfreebsd-ports-gnome-f33f5a90cac5bebc2a125f102e46c11290fba3da.tar.gz
freebsd-ports-gnome-f33f5a90cac5bebc2a125f102e46c11290fba3da.tar.zst
freebsd-ports-gnome-f33f5a90cac5bebc2a125f102e46c11290fba3da.zip
Support /etc/rc.d/openvpn softrestart
to send SIGUSR1 (rather than SIGHUP) to OpenVPN processes. Suggested by: Nick Hibma (in private email)
Diffstat (limited to 'security/openvpn')
-rw-r--r--security/openvpn/Makefile2
-rw-r--r--security/openvpn/files/openvpn.sh.in15
2 files changed, 13 insertions, 4 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index efb663981b4e..4e6f76580930 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openvpn
DISTVERSION= 2.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security net
# MASTER_SITES points to hosts in distinct data centers,
# so just one MASTER_SITES entry should be OK.
diff --git a/security/openvpn/files/openvpn.sh.in b/security/openvpn/files/openvpn.sh.in
index 050984cdef9c..64f6da0afbe7 100644
--- a/security/openvpn/files/openvpn.sh.in
+++ b/security/openvpn/files/openvpn.sh.in
@@ -2,10 +2,11 @@
#
# openvpn.sh - load tun/tap driver and start OpenVPN daemon
#
-# (C) Copyright 2005 - 2008 by Matthias Andree
+# (C) Copyright 2005 - 2008, 2010 by Matthias Andree
# based on suggestions by Matthias Grimm and Dirk Gouders
# with multi-instance contribution from Denis Shaposhnikov, Gleb Kozyrev
# and Vasil Dimov
+# softrestart feature suggested by Nick Hibma
#
# $FreeBSD$
#
@@ -97,8 +98,16 @@ stop_postcmd()
rm -f "$pidfile" || warn "Could not remove $pidfile."
}
-# support SIGHUP to reparse configuration file
-extra_commands="reload"
+softrestart()
+{
+ sig_reload=USR1 run_rc_command reload
+ exit $?
+}
+
+# reload: support SIGHUP to reparse configuration file
+# softrestart: support SIGUSR1 to reconnect without superuser privileges
+extra_commands="reload softrestart"
+softrestart_cmd="softrestart"
# pidfile
pidfile="/var/run/${name}.pid"