aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-CSP
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-17 07:51:12 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-17 07:51:12 +0800
commit65264c3ea9cddb359390e01f44291c07a3f36b26 (patch)
tree71be7e8a08e36d1bd43fdbf78a4a25f054565c9b /security/p5-CSP
parent5483d0e6e35c48bd5718bd7616a2d2085169eea2 (diff)
downloadfreebsd-ports-gnome-65264c3ea9cddb359390e01f44291c07a3f36b26.tar.gz
freebsd-ports-gnome-65264c3ea9cddb359390e01f44291c07a3f36b26.tar.zst
freebsd-ports-gnome-65264c3ea9cddb359390e01f44291c07a3f36b26.zip
Add p5-CSP.
CSP is a Perl class and script for running multiple CAs. OpenSSL is used for all operations. CSP can also generate a small CA website used to distribute certificates and CRLs. WWW: http://devel.it.su.se/projects/CSP/ PR: ports/79885 Submitted by: David Thiel <lx@redundancy.redundancy.org>
Diffstat (limited to 'security/p5-CSP')
-rw-r--r--security/p5-CSP/Makefile25
-rw-r--r--security/p5-CSP/distinfo2
-rw-r--r--security/p5-CSP/pkg-descr5
-rw-r--r--security/p5-CSP/pkg-plist6
4 files changed, 38 insertions, 0 deletions
diff --git a/security/p5-CSP/Makefile b/security/p5-CSP/Makefile
new file mode 100644
index 000000000000..9416ebccf27a
--- /dev/null
+++ b/security/p5-CSP/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-CSP
+# Date created: 2005-04-13
+# Whom: David Thiel <lx@redundancy.redundancy.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CSP
+PORTVERSION= 0.26
+CATEGORIES= security perl5
+MASTER_SITES= ftp://ftp.it.su.se/pub/users/leifj/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= A Perl tool for managing Certificate Authorities
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
+ ${SITE_PERL}/Term/Prompt.pm:${PORTSDIR}/devel/p5-Term-Prompt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CSP.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-CSP/distinfo b/security/p5-CSP/distinfo
new file mode 100644
index 000000000000..b4e01cdfe9c5
--- /dev/null
+++ b/security/p5-CSP/distinfo
@@ -0,0 +1,2 @@
+MD5 (CSP-0.26.tar.gz) = 37534bb4c06953d0a7f37da7c56e041a
+SIZE (CSP-0.26.tar.gz) = 16963
diff --git a/security/p5-CSP/pkg-descr b/security/p5-CSP/pkg-descr
new file mode 100644
index 000000000000..f961f07e7973
--- /dev/null
+++ b/security/p5-CSP/pkg-descr
@@ -0,0 +1,5 @@
+CSP is a Perl class and script for running multiple CAs. OpenSSL is used
+for all operations. CSP can also generate a small CA website used to
+distribute certificates and CRLs.
+
+WWW: http://devel.it.su.se/projects/CSP/
diff --git a/security/p5-CSP/pkg-plist b/security/p5-CSP/pkg-plist
new file mode 100644
index 000000000000..3ad48bc5d76d
--- /dev/null
+++ b/security/p5-CSP/pkg-plist
@@ -0,0 +1,6 @@
+bin/csp
+%%SITE_PERL%%/CSP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CSP/.packlist
+%%SITE_PERL%%/auto/CSP/autosplit.ix
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CSP
+@dirrm %%SITE_PERL%%/auto/CSP