aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-OpenSSL-DSA
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2002-09-21 04:28:29 +0800
committernork <nork@FreeBSD.org>2002-09-21 04:28:29 +0800
commit0d219795f6adbd8f9005b12b366469a9ac80ff17 (patch)
treea5ede0d00ac3ee7fd726a4cffbfeeb54d056b986 /security/p5-Crypt-OpenSSL-DSA
parent794fbcfcf10ea30bd593637730d04b2a1e9713df (diff)
downloadfreebsd-ports-gnome-0d219795f6adbd8f9005b12b366469a9ac80ff17.tar.gz
freebsd-ports-gnome-0d219795f6adbd8f9005b12b366469a9ac80ff17.tar.zst
freebsd-ports-gnome-0d219795f6adbd8f9005b12b366469a9ac80ff17.zip
Add p5-Crypt-OpenSSL-DSA(0.03), a perl module for DSA signature verification
using OpenSSL. Approved by: knu (mentor)
Diffstat (limited to 'security/p5-Crypt-OpenSSL-DSA')
-rw-r--r--security/p5-Crypt-OpenSSL-DSA/Makefile28
-rw-r--r--security/p5-Crypt-OpenSSL-DSA/distinfo1
-rw-r--r--security/p5-Crypt-OpenSSL-DSA/pkg-comment1
-rw-r--r--security/p5-Crypt-OpenSSL-DSA/pkg-descr2
-rw-r--r--security/p5-Crypt-OpenSSL-DSA/pkg-plist11
5 files changed, 43 insertions, 0 deletions
diff --git a/security/p5-Crypt-OpenSSL-DSA/Makefile b/security/p5-Crypt-OpenSSL-DSA/Makefile
new file mode 100644
index 000000000000..929b721afd77
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-DSA/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Crypt-OpenSSL-DSA
+# Date created: 2002/09/20
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-OpenSSL-DSA
+PORTVERSION= 0.03
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nork@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/OpenSSL/Random.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+RESTRICTED= "Crypto; export-controlled"
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::OpenSSL::DSA.3 Crypt::OpenSSL::DSA::Signature.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-DSA/distinfo b/security/p5-Crypt-OpenSSL-DSA/distinfo
new file mode 100644
index 000000000000..523d53cafffc
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-DSA/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-OpenSSL-DSA-0.03.tar.gz) = 90f0537020c858ef329252465841e367
diff --git a/security/p5-Crypt-OpenSSL-DSA/pkg-comment b/security/p5-Crypt-OpenSSL-DSA/pkg-comment
new file mode 100644
index 000000000000..e2d395541ed2
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-DSA/pkg-comment
@@ -0,0 +1 @@
+Perl5 module to DSA signature verification using OpenSSL
diff --git a/security/p5-Crypt-OpenSSL-DSA/pkg-descr b/security/p5-Crypt-OpenSSL-DSA/pkg-descr
new file mode 100644
index 000000000000..4e4b9e6749ce
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-DSA/pkg-descr
@@ -0,0 +1,2 @@
+Crypt::OpenSSL::DSA implements the DSA (Digital Signature Algorithm)
+signature verification system.
diff --git a/security/p5-Crypt-OpenSSL-DSA/pkg-plist b/security/p5-Crypt-OpenSSL-DSA/pkg-plist
new file mode 100644
index 000000000000..fb0169a3b025
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-DSA/pkg-plist
@@ -0,0 +1,11 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/OpenSSL/DSA.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/OpenSSL/DSA/Signature.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/DSA/DSA.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/DSA/DSA.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/DSA/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/DSA 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/OpenSSL/DSA 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/OpenSSL 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt 2>/dev/null || true