aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-PBKDF2
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-06-07 14:59:09 +0800
committermiwi <miwi@FreeBSD.org>2010-06-07 14:59:09 +0800
commit57d37788f4ff9d5fbf100253b5dda4dce7b29ff0 (patch)
tree3423e6743b64b80d416ee731cab16495edd0ed70 /security/p5-Crypt-PBKDF2
parent9871c645d41a709d7791281aed2d6f04f8f08f70 (diff)
downloadfreebsd-ports-gnome-57d37788f4ff9d5fbf100253b5dda4dce7b29ff0.tar.gz
freebsd-ports-gnome-57d37788f4ff9d5fbf100253b5dda4dce7b29ff0.tar.zst
freebsd-ports-gnome-57d37788f4ff9d5fbf100253b5dda4dce7b29ff0.zip
PBKDF2 is a secure password hashing algorithm that uses the techniques of
"key strengthening" to make the complexity of a brute-force attack arbitrarily high. PBKDF2 uses any other cryptographic hash or cipher (by convention, usually HMAC-SHA1, but Crypt::PBKDF2 is fully pluggable), and allows for an arbitrary number of iterations of the hashing function, and a nearly unlimited output hash size (up to 2**32 - 1 times the size of the output of the backend hash). The hash is salted, as any password hash should be, and the salt may also be of arbitrary size. See also: RFC2898, PKCS#5 version 2.0: http://tools.ietf.org/html/rfc2898 WWW: http://search.cpan.org/dist/Crypt-PBKDF2/ PR: ports/146847 Submitted by: Victor Popov <v.a.popov at gmail.com>
Diffstat (limited to 'security/p5-Crypt-PBKDF2')
-rw-r--r--security/p5-Crypt-PBKDF2/Makefile43
-rw-r--r--security/p5-Crypt-PBKDF2/distinfo3
-rw-r--r--security/p5-Crypt-PBKDF2/pkg-descr12
-rw-r--r--security/p5-Crypt-PBKDF2/pkg-plist12
4 files changed, 70 insertions, 0 deletions
diff --git a/security/p5-Crypt-PBKDF2/Makefile b/security/p5-Crypt-PBKDF2/Makefile
new file mode 100644
index 000000000000..47c3d4a1bb87
--- /dev/null
+++ b/security/p5-Crypt-PBKDF2/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: p5-Crypt-PBKDF2
+# Date created: 2010-05-23
+# Whom: Victor Popov <v.a.popov@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-PBKDF2
+PORTVERSION= 0.101170
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/A/AR/ARODLAND
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= v.a.popov@gmail.com
+COMMENT= The PBKDF2 password hashing algorithm
+
+RUN_DEPENDS= p5-Digest-HMAC>=1.01:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-Moose>=1:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Method-Signatures>=0.30:${PORTSDIR}/devel/p5-MooseX-Method-Signatures \
+ p5-Try-Tiny>=0.04:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::PBKDF2.3 \
+ Crypt::PBKDF2::Hash.3 \
+ Crypt::PBKDF2::Hash::DigestHMAC.3 \
+ Crypt::PBKDF2::Hash::HMACSHA1.3 \
+ Crypt::PBKDF2::Hash::HMACSHA2.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.if ${PERL_LEVEL} < 501001
+RUN_DEPENDS+= p5-Digest>=1.16:${PORTSDIR}/security/p5-Digest
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-PBKDF2/distinfo b/security/p5-Crypt-PBKDF2/distinfo
new file mode 100644
index 000000000000..b5c8a3b650d9
--- /dev/null
+++ b/security/p5-Crypt-PBKDF2/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-PBKDF2-0.101170.tar.gz) = 1fbf8d79172e03383ad19b994affa441
+SHA256 (Crypt-PBKDF2-0.101170.tar.gz) = ff416e3b5f19673af2ca93879639f350e06865065100f1452bb049232d3c0004
+SIZE (Crypt-PBKDF2-0.101170.tar.gz) = 13679
diff --git a/security/p5-Crypt-PBKDF2/pkg-descr b/security/p5-Crypt-PBKDF2/pkg-descr
new file mode 100644
index 000000000000..377e3450bc54
--- /dev/null
+++ b/security/p5-Crypt-PBKDF2/pkg-descr
@@ -0,0 +1,12 @@
+PBKDF2 is a secure password hashing algorithm that uses the techniques of
+"key strengthening" to make the complexity of a brute-force attack arbitrarily
+high. PBKDF2 uses any other cryptographic hash or cipher (by convention,
+usually HMAC-SHA1, but Crypt::PBKDF2 is fully pluggable), and allows for an
+arbitrary number of iterations of the hashing function, and a nearly unlimited
+output hash size (up to 2**32 - 1 times the size of the output of the backend
+hash). The hash is salted, as any password hash should be, and the salt may
+also be of arbitrary size.
+
+See also: RFC2898, PKCS#5 version 2.0: http://tools.ietf.org/html/rfc2898
+
+WWW: http://search.cpan.org/dist/Crypt-PBKDF2/
diff --git a/security/p5-Crypt-PBKDF2/pkg-plist b/security/p5-Crypt-PBKDF2/pkg-plist
new file mode 100644
index 000000000000..18ba8cbe882e
--- /dev/null
+++ b/security/p5-Crypt-PBKDF2/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Crypt/PBKDF2.pm
+%%SITE_PERL%%/Crypt/PBKDF2/Hash.pm
+%%SITE_PERL%%/Crypt/PBKDF2/Hash/DigestHMAC.pm
+%%SITE_PERL%%/Crypt/PBKDF2/Hash/HMACSHA1.pm
+%%SITE_PERL%%/Crypt/PBKDF2/Hash/HMACSHA2.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/PBKDF2/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/PBKDF2
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt
+@dirrmtry %%SITE_PERL%%/Crypt/PBKDF2/Hash
+@dirrmtry %%SITE_PERL%%/Crypt/PBKDF2
+@dirrmtry %%SITE_PERL%%/Crypt