aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-SMIME
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /security/p5-Crypt-SMIME
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'security/p5-Crypt-SMIME')
-rw-r--r--security/p5-Crypt-SMIME/Makefile3
-rw-r--r--security/p5-Crypt-SMIME/pkg-plist7
2 files changed, 5 insertions, 5 deletions
diff --git a/security/p5-Crypt-SMIME/Makefile b/security/p5-Crypt-SMIME/Makefile
index 52510ef82cd3..0fc5477215c0 100644
--- a/security/p5-Crypt-SMIME/Makefile
+++ b/security/p5-Crypt-SMIME/Makefile
@@ -2,6 +2,7 @@
PORTNAME= Crypt-SMIME
PORTVERSION= 0.15
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -22,6 +23,6 @@ USE_OPENSSL= yes
USE_PERL5= configure
post-stage:
- ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Crypt/SMIME/SMIME.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Crypt/SMIME/SMIME.so
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-SMIME/pkg-plist b/security/p5-Crypt-SMIME/pkg-plist
index dec647a1cb2f..7d14ba69175c 100644
--- a/security/p5-Crypt-SMIME/pkg-plist
+++ b/security/p5-Crypt-SMIME/pkg-plist
@@ -1,6 +1,5 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/SMIME/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/SMIME/SMIME.so
-%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/SMIME/JA.pod
-%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/SMIME.pm
+%%SITE_ARCH%%/auto/Crypt/SMIME/SMIME.so
+%%SITE_ARCH%%/Crypt/SMIME/JA.pod
+%%SITE_ARCH%%/Crypt/SMIME.pm
%%PERL5_MAN3%%/SMIME.3.gz
%%PERL5_MAN3%%/SMIME::JA.3.gz