aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Dancer2-Plugin-Auth-Extensible
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-11-21 05:09:16 +0800
committerpi <pi@FreeBSD.org>2014-11-21 05:09:16 +0800
commit545d8b4cfb247a4f8a71e5c6690d0350c3152c69 (patch)
treec945804d4dced4de4d29cb51991b9e1431829335 /security/p5-Dancer2-Plugin-Auth-Extensible
parentdf2821dc5cc08a36e796461eb761b97b764e9805 (diff)
downloadfreebsd-ports-gnome-545d8b4cfb247a4f8a71e5c6690d0350c3152c69.tar.gz
freebsd-ports-gnome-545d8b4cfb247a4f8a71e5c6690d0350c3152c69.tar.zst
freebsd-ports-gnome-545d8b4cfb247a4f8a71e5c6690d0350c3152c69.zip
New port: security/Dancer2-Plugin-Auth-Extensible
A user authentication and authorisation framework plugin for Dancer2 apps. Makes it easy to require a user to be logged in to access certain routes, provides role-based access control, and supports various authentication methods/sources (config file, database, Unix system users, etc). Designed to support multiple authentication realms and to be as extensible as possible, and to make secure password handling easy (the base class for auth providers makes handling `RFC2307'-style hashed passwords really simple, so you have no excuse for storing plain-text passwords). WWW: http://search.cpan.org/dist/Dancer2-Plugin-Auth-Extensible/ PR: 194961 Submitted by: Henk van Oers <hvo.pm@xs4all.nl>
Diffstat (limited to 'security/p5-Dancer2-Plugin-Auth-Extensible')
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible/Makefile31
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible/distinfo2
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible/pkg-descr14
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible/pkg-plist13
4 files changed, 60 insertions, 0 deletions
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible/Makefile b/security/p5-Dancer2-Plugin-Auth-Extensible/Makefile
new file mode 100644
index 000000000000..7d6e387ddb5d
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible/Makefile
@@ -0,0 +1,31 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Dancer2-Plugin-Auth-Extensible
+PORTVERSION= 0.303
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hvo.pm@xs4all.nl
+COMMENT= Extensible authentication framework for Dancer2 apps
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Crypt-SaltedHash>=0:${PORTSDIR}/security/p5-Crypt-SaltedHash \
+ p5-Dancer2>=0.153002:${PORTSDIR}/www/p5-Dancer2
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+OPTIONS_DEFINE= DPAEPD DPAEPU
+DPAEPD_DESC= Extra dependencies for Provider::Database
+DPAEPU_DESC= Extra dependencies for Provider::Unix
+
+DPAEPD_BUILD_DEPENDS= p5-Dancer2-Plugin-Database>=0:${PORTSDIR}/databases/p5-Dancer2-Plugin-Database
+DPAEPU_BUILD_DEPENDS= p5-Authen-Simple-PAM>=0:${PORTSDIR}/security/p5-Authen-Simple-PAM \
+ p5-Unix-Passwd-File>=0:${PORTSDIR}/security/p5-Unix-Passwd-File
+
+.include <bsd.port.mk>
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible/distinfo b/security/p5-Dancer2-Plugin-Auth-Extensible/distinfo
new file mode 100644
index 000000000000..615965400052
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer2-Plugin-Auth-Extensible-0.303.tar.gz) = 9a691ce4427053bf11fc141e2589f3605f4e17cdf083ea63dd1757649c578b09
+SIZE (Dancer2-Plugin-Auth-Extensible-0.303.tar.gz) = 21730
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible/pkg-descr b/security/p5-Dancer2-Plugin-Auth-Extensible/pkg-descr
new file mode 100644
index 000000000000..b7c5b5924a78
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible/pkg-descr
@@ -0,0 +1,14 @@
+A user authentication and authorisation framework plugin for Dancer2 apps.
+
+Makes it easy to require a user to be logged in to access certain
+routes, provides role-based access control, and supports various
+authentication methods/sources (config file, database, Unix system
+users, etc).
+
+Designed to support multiple authentication realms and to be as
+extensible as possible, and to make secure password handling easy (the
+base class for auth providers makes handling `RFC2307'-style hashed
+passwords really simple, so you have no excuse for storing plain-text
+passwords).
+
+WWW: http://search.cpan.org/dist/Dancer2-Plugin-Auth-Extensible/
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible/pkg-plist b/security/p5-Dancer2-Plugin-Auth-Extensible/pkg-plist
new file mode 100644
index 000000000000..88844e783d81
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible/pkg-plist
@@ -0,0 +1,13 @@
+%%PERL5_MAN3%%/Dancer2::Plugin::Auth::Extensible.3.gz
+%%PERL5_MAN3%%/Dancer2::Plugin::Auth::Extensible::Provider::Base.3.gz
+%%PERL5_MAN3%%/Dancer2::Plugin::Auth::Extensible::Provider::Config.3.gz
+%%PERL5_MAN3%%/Dancer2::Plugin::Auth::Extensible::Provider::Database.3.gz
+%%PERL5_MAN3%%/Dancer2::Plugin::Auth::Extensible::Provider::Example.3.gz
+%%PERL5_MAN3%%/Dancer2::Plugin::Auth::Extensible::Provider::Unix.3.gz
+%%SITE_PERL%%/Dancer2/Plugin/Auth/Extensible.pm
+%%SITE_PERL%%/Dancer2/Plugin/Auth/Extensible/Provider/Base.pm
+%%SITE_PERL%%/Dancer2/Plugin/Auth/Extensible/Provider/Config.pm
+%%SITE_PERL%%/Dancer2/Plugin/Auth/Extensible/Provider/Database.pm
+%%SITE_PERL%%/Dancer2/Plugin/Auth/Extensible/Provider/Example.pm
+%%SITE_PERL%%/Dancer2/Plugin/Auth/Extensible/Provider/Unix.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer2/Plugin/Auth/Extensible/.packlist