aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Digest-JHash
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-18 00:16:24 +0800
committererwin <erwin@FreeBSD.org>2005-12-18 00:16:24 +0800
commit6181caba06d41e0e8104e4706949c26d231c2318 (patch)
treeea130d131a536c894b1208170d8af03e199b45ee /security/p5-Digest-JHash
parentca358c58e618eaa31cc837681165a650821f3011 (diff)
downloadfreebsd-ports-gnome-6181caba06d41e0e8104e4706949c26d231c2318.tar.gz
freebsd-ports-gnome-6181caba06d41e0e8104e4706949c26d231c2318.tar.zst
freebsd-ports-gnome-6181caba06d41e0e8104e4706949c26d231c2318.zip
The Digest::JHash module allows you to use the fast JHash hashing algorithm
developed by Bob Jenkins from within Perl programs. The algorithm takes as input a message of arbitrary length and produces as output a 32-bit "message digest" of the input in the form of an unsigned long integer. See http://burtleburtle.net/bob/hash/doobs.html for more information. WWW: http://search.cpan.org/dist/Digest-JHash PR: ports/90564 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security/p5-Digest-JHash')
-rw-r--r--security/p5-Digest-JHash/Makefile24
-rw-r--r--security/p5-Digest-JHash/distinfo3
-rw-r--r--security/p5-Digest-JHash/pkg-descr7
-rw-r--r--security/p5-Digest-JHash/pkg-plist7
4 files changed, 41 insertions, 0 deletions
diff --git a/security/p5-Digest-JHash/Makefile b/security/p5-Digest-JHash/Makefile
new file mode 100644
index 000000000000..a69c99c1c22d
--- /dev/null
+++ b/security/p5-Digest-JHash/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: p5-Digest-JHash
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-JHash
+PORTVERSION= 0.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for JHash hash algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::JHash.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-JHash/distinfo b/security/p5-Digest-JHash/distinfo
new file mode 100644
index 000000000000..5310afe4e5ff
--- /dev/null
+++ b/security/p5-Digest-JHash/distinfo
@@ -0,0 +1,3 @@
+MD5 (Digest-JHash-0.02.tar.gz) = eaf88ee120fc16277d0e047601445661
+SHA256 (Digest-JHash-0.02.tar.gz) = 99f0a8d9f6ba95671a78ab9b50eec19705529fc594176d39379a75db768805c1
+SIZE (Digest-JHash-0.02.tar.gz) = 7031
diff --git a/security/p5-Digest-JHash/pkg-descr b/security/p5-Digest-JHash/pkg-descr
new file mode 100644
index 000000000000..3f23c87787c5
--- /dev/null
+++ b/security/p5-Digest-JHash/pkg-descr
@@ -0,0 +1,7 @@
+The Digest::JHash module allows you to use the fast JHash hashing algorithm
+developed by Bob Jenkins from within Perl programs. The algorithm takes as
+input a message of arbitrary length and produces as output a 32-bit
+"message digest" of the input in the form of an unsigned long integer.
+See http://burtleburtle.net/bob/hash/doobs.html for more information.
+
+WWW: http://search.cpan.org/dist/Digest-JHash
diff --git a/security/p5-Digest-JHash/pkg-plist b/security/p5-Digest-JHash/pkg-plist
new file mode 100644
index 000000000000..64d0505070c7
--- /dev/null
+++ b/security/p5-Digest-JHash/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Digest/JHash.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/JHash/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/JHash/JHash.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/JHash/JHash.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/JHash/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/ 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Digest/ 2>/dev/null || true