aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Nmap-Parser
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-06-06 16:49:36 +0800
committerclsung <clsung@FreeBSD.org>2006-06-06 16:49:36 +0800
commit5bd2549d9a5fe0e0a92f3e7ea5843ed2c5835ec9 (patch)
treee106481226ad18741bb450aaacc5ed11fb6e030f /security/p5-Nmap-Parser
parentcb7fc4d7c618efbd934bcf9ee3b9fc33e19c08d9 (diff)
downloadfreebsd-ports-gnome-5bd2549d9a5fe0e0a92f3e7ea5843ed2c5835ec9.tar.gz
freebsd-ports-gnome-5bd2549d9a5fe0e0a92f3e7ea5843ed2c5835ec9.tar.zst
freebsd-ports-gnome-5bd2549d9a5fe0e0a92f3e7ea5843ed2c5835ec9.zip
Add p5-Nmap-Parser 1.05, parse nmap scan data with perl.
PR: ports/98576 Submitted by: Joshua D. Abraham <jabra@ccs.neu.edu>
Diffstat (limited to 'security/p5-Nmap-Parser')
-rw-r--r--security/p5-Nmap-Parser/Makefile29
-rw-r--r--security/p5-Nmap-Parser/distinfo3
-rw-r--r--security/p5-Nmap-Parser/pkg-descr7
-rw-r--r--security/p5-Nmap-Parser/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/security/p5-Nmap-Parser/Makefile b/security/p5-Nmap-Parser/Makefile
new file mode 100644
index 000000000000..88a6d0ac2b15
--- /dev/null
+++ b/security/p5-Nmap-Parser/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Nmap-Parser
+# Date created: June 3 2006
+# Whom: Joshua D. Abraham <jabra@ccs.neu.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Nmap-Parser
+PORTVERSION= 1.05
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/A/AP/APERSAUD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jabra@ccs.neu.edu
+COMMENT= Parse nmap scan data with perl
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Twig.pm:${PORTSDIR}/textproc/p5-XML-Twig
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ nmap:${PORTSDIR}/security/nmap
+
+PERL_CONFIGURE= yes
+
+MAN3= Nmap::Parser.3
+
+post-configure:
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/security/p5-Nmap-Parser/distinfo b/security/p5-Nmap-Parser/distinfo
new file mode 100644
index 000000000000..ba5f74b3f860
--- /dev/null
+++ b/security/p5-Nmap-Parser/distinfo
@@ -0,0 +1,3 @@
+MD5 (Nmap-Parser-1.05.tar.gz) = 5d5f113a9d166b07e041a5dc52f9c3ee
+SHA256 (Nmap-Parser-1.05.tar.gz) = 5979fa59078376ce752e9bd46fdc2b34b9a18199780412f5a3f257c82a31a759
+SIZE (Nmap-Parser-1.05.tar.gz) = 34451
diff --git a/security/p5-Nmap-Parser/pkg-descr b/security/p5-Nmap-Parser/pkg-descr
new file mode 100644
index 000000000000..f9a0959c245b
--- /dev/null
+++ b/security/p5-Nmap-Parser/pkg-descr
@@ -0,0 +1,7 @@
+This module implements a interface to the information contained in an nmap
+scan. It is implemented by parsing the xml scan data that is generated by
+nmap. This will enable anyone who utilizes nmap to quickly create fast and
+robust security scripts that utilize the powerful port scanning abilities of
+nmap.
+
+WWW: http://search.cpan.org/~apersaud/Nmap-Parser-1.05/
diff --git a/security/p5-Nmap-Parser/pkg-plist b/security/p5-Nmap-Parser/pkg-plist
new file mode 100644
index 000000000000..14660768a8bf
--- /dev/null
+++ b/security/p5-Nmap-Parser/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Nmap/Parser/.packlist
+%%SITE_PERL%%/Nmap/Parser.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nmap/Parser
+@dirrmtry %%SITE_PERL%%/Nmap
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nmap