aboutsummaryrefslogtreecommitdiffstats
path: root/security/pad
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-25 19:51:54 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-25 19:51:54 +0800
commit53c070c3e8ef618cbd4b571f1d925cae7e7463db (patch)
tree9b9350aff336c27602be39abccd83a4e27e680d7 /security/pad
parente7c87f6daabc889647c7e000c61b48563766ee0c (diff)
downloadfreebsd-ports-gnome-53c070c3e8ef618cbd4b571f1d925cae7e7463db.tar.gz
freebsd-ports-gnome-53c070c3e8ef618cbd4b571f1d925cae7e7463db.tar.zst
freebsd-ports-gnome-53c070c3e8ef618cbd4b571f1d925cae7e7463db.zip
Support staging
Diffstat (limited to 'security/pad')
-rw-r--r--security/pad/Makefile27
1 files changed, 7 insertions, 20 deletions
diff --git a/security/pad/Makefile b/security/pad/Makefile
index 8b16d4cd57af..a04768306ae0 100644
--- a/security/pad/Makefile
+++ b/security/pad/Makefile
@@ -7,36 +7,23 @@ PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://keyserver.kjsl.com/~jharris/distfiles/
-# http://www.lammah.com/pad/
EXTRACT_SUFX= .tgz
MAINTAINER= jharris@widomaker.com
COMMENT= A command-line utility to encrypt files
-DOC_FILES= COPYING README ChangeLog
GNU_CONFIGURE= yes
-MAN1= pad.1
-PLIST= ${WRKDIR}/pkg-plist
USE_OPENSSL= yes
-NO_STAGE= yes
-pre-install:
- ${ECHO_CMD} bin/pad > ${PLIST}
-.if !defined(NOPORTDOCS)
-.for i in ${DOC_FILES}
- ${ECHO_CMD} share/doc/pad/$i >> ${PLIST}
-.endfor
-.endif
- ${ECHO_CMD} "@dirrm share/doc/pad" >> ${PLIST}
+PLIST_FILES= bin/pad man/man1/pad.1.gz
+PORTDOCS= COPYING README ChangeLog
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pad ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/pad.1 ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${DOC_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/pad ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pad.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>