aboutsummaryrefslogtreecommitdiffstats
path: root/security/pear-File_Passwd
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-10 08:20:14 +0800
committerpav <pav@FreeBSD.org>2004-11-10 08:20:14 +0800
commitbe95e72f5bcc4f96a0e310e19e1affe753628a44 (patch)
tree5e7ff4afaaf2892517cd0c48db5122d0e1e64be6 /security/pear-File_Passwd
parent4342d2a5de0aedd8023fec102f27f9e6da490086 (diff)
downloadfreebsd-ports-gnome-be95e72f5bcc4f96a0e310e19e1affe753628a44.tar.gz
freebsd-ports-gnome-be95e72f5bcc4f96a0e310e19e1affe753628a44.tar.zst
freebsd-ports-gnome-be95e72f5bcc4f96a0e310e19e1affe753628a44.zip
Add pear-File_Passwd, class to manipulate and authenticate against standard Unix,
SMB server, AuthUser (.htpasswd), AuthDigest (.htdigest), CVS pserver and custom formatted password files. PR: ports/73716 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
Diffstat (limited to 'security/pear-File_Passwd')
-rw-r--r--security/pear-File_Passwd/Makefile30
-rw-r--r--security/pear-File_Passwd/distinfo2
-rw-r--r--security/pear-File_Passwd/pkg-descr5
3 files changed, 37 insertions, 0 deletions
diff --git a/security/pear-File_Passwd/Makefile b/security/pear-File_Passwd/Makefile
new file mode 100644
index 000000000000..7d9f35fb9a8a
--- /dev/null
+++ b/security/pear-File_Passwd/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pear-File_Passwd
+# Date created: 09 November 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= File_Passwd
+PORTVERSION= 1.1.1
+CATEGORIES= security www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class to manipulate many kinds of password files
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= File
+FILES= Passwd.php Passwd/Common.php Passwd/Unix.php Passwd/Cvs.php \
+ Passwd/Smb.php Passwd/Authbasic.php Passwd/Authdigest.php \
+ Passwd/Custom.php
+TESTS= testsuite.php test_file_passwd.php test_common.php test_unix.php \
+ test_smb.php test_cvs.php test_authbasic.php test_authdigest.php \
+ test_custom.php README.txt common.txt passwd.unix.txt \
+ passwd.cvs.txt passwd.smb.txt passwd.authbasic.txt \
+ passwd.authdigest.txt passwd.custom.txt
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/security/pear-File_Passwd/distinfo b/security/pear-File_Passwd/distinfo
new file mode 100644
index 000000000000..03cbd2ed882f
--- /dev/null
+++ b/security/pear-File_Passwd/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/File_Passwd-1.1.1.tgz) = 55275a4affd6734d56aaa25b6a8f5821
+SIZE (PEAR/File_Passwd-1.1.1.tgz) = 23200
diff --git a/security/pear-File_Passwd/pkg-descr b/security/pear-File_Passwd/pkg-descr
new file mode 100644
index 000000000000..90b7d55cfda7
--- /dev/null
+++ b/security/pear-File_Passwd/pkg-descr
@@ -0,0 +1,5 @@
+Provides methods to manipulate and authenticate against standard Unix,
+SMB server, AuthUser (.htpasswd), AuthDigest (.htdigest), CVS pserver
+and custom formatted password files.
+
+WWW: http://pear.php.net/package/File_Passwd/