aboutsummaryrefslogtreecommitdiffstats
path: root/security/pgp
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-09-22 09:59:06 +0800
committerkris <kris@FreeBSD.org>2000-09-22 09:59:06 +0800
commitcc2138f8872f35766e9eed08df7f940799f6989d (patch)
tree135ecc5c6f2aa6e70fad57b88e4dc5800c435b99 /security/pgp
parent86525b91dae5387ee33a49235af5a72d7c327c2a (diff)
downloadfreebsd-ports-gnome-cc2138f8872f35766e9eed08df7f940799f6989d.tar.gz
freebsd-ports-gnome-cc2138f8872f35766e9eed08df7f940799f6989d.tar.zst
freebsd-ports-gnome-cc2138f8872f35766e9eed08df7f940799f6989d.zip
Update all ports using OpenSSL and RSA to work without rsaref since
it is no longer required. Apologies to the various maintainers whom I did not yet hear back from, but the ports freeze is coming up in a few hours and I will be verifying all of these ports on a 4.1 machine myself to catch any problems.
Diffstat (limited to 'security/pgp')
-rw-r--r--security/pgp/Makefile63
1 files changed, 14 insertions, 49 deletions
diff --git a/security/pgp/Makefile b/security/pgp/Makefile
index 1f7bc50bcaa8..e2e7b5141299 100644
--- a/security/pgp/Makefile
+++ b/security/pgp/Makefile
@@ -5,76 +5,41 @@
# $FreeBSD$
#
-# Pick an initial default, else it doesn't get set in the INDEX.
+PORTNAME= pgp
+PORTVERSION= 2.6.3i
CATEGORIES= security
-DISTNAME= pgp262s
+MASTER_SITES= ftp://ftp.ifi.uio.no/pub/pgp/2.x/src/ \
+ ftp://ftp.kiarchive.ru/pub/unix/crypto/pgp/
+DISTNAME= pgp263is
MAINTAINER= ache@FreeBSD.org
-# Need to define USA_RESIDENT to YES or NO
-IS_INTERACTIVE= YES
-RESTRICTED= "Crypto"
+WRKSRC= ${WRKDIR}/src
+FILESDIR= ${.CURDIR}/files.non_usa
+PATCHDIR= ${.CURDIR}/patches.non_usa
+
MAKEFILE= makefile
ALL_TARGET= freebsd-${MACHINE_ARCH} OS_CFLAGS="${CFLAGS}"
PGPLIB= ${PREFIX}/lib/pgp
MAN1= pgp.1
do-install:
- cd ${WRKSRC}; install -c -o bin -g bin -m 555 pgp ${PREFIX}/bin
+ cd ${WRKSRC}; ${INSTALL_PROGRAM} -c -o bin -g bin -m 555 pgp ${PREFIX}/bin
cd ${WRKSRC}/../doc; \
- install -c -o bin -g bin -m 444 pgp.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} -c -o bin -g bin -m 444 pgp.1 ${PREFIX}/man/man1
-${MKDIR} ${PGPLIB}
${CHMOD} 555 ${PGPLIB}
cd ${WRKSRC}/..; \
- install -c -o bin -g bin -m 444 pgp.hlp \
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 pgp.hlp \
doc/pgpdoc1.txt doc/pgpdoc2.txt ${PGPLIB}; \
[ -f ${PGPLIB}/language.txt ] || \
- install -c -o bin -g bin -m 444 language.txt ${PGPLIB}; \
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 language.txt ${PGPLIB}; \
[ -f ${PGPLIB}/config.txt ] || \
- install -c -o bin -g bin -m 444 config.txt ${PGPLIB}
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 config.txt ${PGPLIB}
-${PREFIX}/bin/pgp > /dev/null 2>&1 # update .idx file
-.if !defined(USA_RESIDENT) || ${USA_RESIDENT} != YES && ${USA_RESIDENT} != NO
-pre-fetch:
- @${ECHO_MSG}
- @${ECHO_MSG} You must set variable USA_RESIDENT to YES, if you are USA resident
- @${ECHO_MSG} or to NO, if you aren\'t USA resident to build this package
- @${FALSE}
-.elif defined(USA_RESIDENT)
-.if ${USA_RESIDENT} == YES
-PORTNAME= pgp
-PORTVERSION= 2.6.2
-MASTER_SITES= ftp://utopia.hacktic.nl/pub/crypto/pgp/unix/
-DISTNAME= pgp262s
-
-WRKSRC= ${WRKDIR}/src
-BUILD_DEPENDS+= gmake:${PORTSDIR}/devel/gmake
-LIB_DEPENDS+= rsaref.2:${PORTSDIR}/security/rsaref
-USE_ZIP= yes
-FILESDIR= ${.CURDIR}/files.usa
-PATCHDIR= ${.CURDIR}/patches.usa
-
-post-extract:
- cd ${WRKDIR}; $(EXTRACT_CMD) $(EXTRACT_BEFORE_ARGS) -aa $(DISTNAME)i \
- $(EXTRACT_AFTER_ARGS)
- cd ${WRKDIR}; ${RM} -f *.zip
-
-.else
-PORTNAME= pgp
-PORTVERSION= 2.6.3ia
-MASTER_SITES= ftp://ftp.ifi.uio.no/pub/pgp/2.x/src/ \
- ftp://ftp.kiarchive.ru/pub/unix/crypto/pgp/
-DISTNAME= pgp263is
-
-WRKSRC= ${WRKDIR}/src
-FILESDIR= ${.CURDIR}/files.non_usa
-PATCHDIR= ${.CURDIR}/patches.non_usa
-
post-extract:
cd ${WRKDIR}; $(TAR) -xf pgp263ii.tar; \
${RM} -f pgp263ii.tar
-.endif
-.endif
-
.include <bsd.port.mk>