aboutsummaryrefslogtreecommitdiffstats
path: root/security/pktsuckers
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-12-10 13:32:00 +0800
committerak <ak@FreeBSD.org>2012-12-10 13:32:00 +0800
commit8d5c9f4a3b3508473441101c18c744b0d7563faa (patch)
tree974a5ef3e591c4488f6526a6f4317575060ef561 /security/pktsuckers
parent2d90f0d71a8b7b55ceca17079eeb39a424c0d5de (diff)
downloadfreebsd-ports-gnome-8d5c9f4a3b3508473441101c18c744b0d7563faa.tar.gz
freebsd-ports-gnome-8d5c9f4a3b3508473441101c18c744b0d7563faa.tar.zst
freebsd-ports-gnome-8d5c9f4a3b3508473441101c18c744b0d7563faa.zip
- Convert Makefile headers to new style
- Don't hardcode PORTVERSION in DISTNAME - Convert to PLIST_FILES - Fix build with clang PR: ports/174205 (based on) Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'security/pktsuckers')
-rw-r--r--security/pktsuckers/Makefile14
-rw-r--r--security/pktsuckers/pkg-plist2
2 files changed, 8 insertions, 8 deletions
diff --git a/security/pktsuckers/Makefile b/security/pktsuckers/Makefile
index b1d03f7f0006..f21748520458 100644
--- a/security/pktsuckers/Makefile
+++ b/security/pktsuckers/Makefile
@@ -1,19 +1,21 @@
-# New ports collection makefile for: pktsuckers
-# Date created: 31 May 1999
-# Whom: Warren Toomey <wkt@cs.adfa.edu.au>
-#
+# Created by: Warren Toomey <wkt@cs.adfa.edu.au>
# $FreeBSD$
-#
PORTNAME= pktsuckers
PORTVERSION= 1.2
CATEGORIES= security
MASTER_SITES= ftp://minnie.tuhs.org/pub/NetSecurity/
-DISTNAME= ${PORTNAME}1_2
+DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Log contents of unwanted UDP packets and TCP connections
+PLIST_FILES= libexec/tcpsuck libexec/udpsuck
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^void main|int main|' ${WRKSRC}/tcpsuck.c ${WRKSRC}/udpsuck.c
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcpsuck ${PREFIX}/libexec
${INSTALL_PROGRAM} ${WRKSRC}/udpsuck ${PREFIX}/libexec
diff --git a/security/pktsuckers/pkg-plist b/security/pktsuckers/pkg-plist
deleted file mode 100644
index a12d1c0c17eb..000000000000
--- a/security/pktsuckers/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-libexec/tcpsuck
-libexec/udpsuck