aboutsummaryrefslogtreecommitdiffstats
path: root/security/polarssl
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-07-18 19:38:06 +0800
committerdinoex <dinoex@FreeBSD.org>2010-07-18 19:38:06 +0800
commit3ec79659c0ab1c0defbf9014775f883256f77246 (patch)
treeed16728dc756a64caf2cbe4c9bd027c846059002 /security/polarssl
parentf69d55063d85b6dadec56f6ed9fc5340b5d27f6d (diff)
downloadfreebsd-ports-gnome-3ec79659c0ab1c0defbf9014775f883256f77246.tar.gz
freebsd-ports-gnome-3ec79659c0ab1c0defbf9014775f883256f77246.tar.zst
freebsd-ports-gnome-3ec79659c0ab1c0defbf9014775f883256f77246.zip
- fix excuteable bits
- do not use devel/cmake PR: 148617 Submitted by: Takefu
Diffstat (limited to 'security/polarssl')
-rw-r--r--security/polarssl/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/security/polarssl/Makefile b/security/polarssl/Makefile
index 5030493f203e..e633c71b18a3 100644
--- a/security/polarssl/Makefile
+++ b/security/polarssl/Makefile
@@ -17,11 +17,9 @@ COMMENT= Open Source embedded SSL/TLS cryptographic library
LICENSE= GPLv2
-USE_CMAKE= yes
USE_PERL5_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-CMAKE_BUILD_TYPE= release
PORTDOCS= ChangeLog LICENSE README
BINFILES= aescrypt2 benchmark dh_client dh_genprime dh_server hello \
@@ -34,7 +32,7 @@ do-install:
@${TAR} -C ${WRKSRC}/include -cf - polarssl | ${TAR} -C ${PREFIX}/include -xf -
${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.a ${PREFIX}/lib/
.for i in ${BINFILES}
- ${INSTALL_DATA} ${WRKSRC}/programs/*/${i} ${PREFIX}/bin/polarssl_${i}
+ ${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${PREFIX}/bin/polarssl_${i}
.endfor
post-install: