aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-certbot
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2017-08-06 19:28:15 +0800
committerkoobs <koobs@FreeBSD.org>2017-08-06 19:28:15 +0800
commit799d53ecd8794a3e328f911e512633daee6f2c39 (patch)
tree5debb3505d11967f50d84316f6d2456d6d690c00 /security/py-certbot
parentf54d1d916a6fbbba52e3234f3b7903cb6ba5d40f (diff)
downloadfreebsd-ports-gnome-799d53ecd8794a3e328f911e512633daee6f2c39.tar.gz
freebsd-ports-gnome-799d53ecd8794a3e328f911e512633daee6f2c39.tar.zst
freebsd-ports-gnome-799d53ecd8794a3e328f911e512633daee6f2c39.zip
security/py-certbot: Relax Python version-spec, support Python 3.x
certbot has supported Python 3 (3.3+) since the 0.14.0 release [1]. Update the USES=python:<version-spec> to match, allowing Python 3 builds. [2] Update acme (security/py-acme) RUN_DEPENDS entry to use PORTVERSION not PKGVERSION (that includes PORTEPOCH/PORTREVISION) which caused the dependency to be incorrectly reported as unsatisfied if either was defined. Further, since *_DEPENDS version-specifiers compare against installed package versions, only a version that includes PORTEPOCH and/or PORTREVISION is available, so use >= not ==. [3] While I'm here, enable 'concurrent' to automatically produce version-suffixed files. [1] https://github.com/certbot/certbot/issues/4507 PR: 220469 221043 [3] Submitted by: Kamigishi Rei <spambox haruhiism net> [2] Reported by: amdmi3 [3] MFH: 2017Q3
Diffstat (limited to 'security/py-certbot')
-rw-r--r--security/py-certbot/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/security/py-certbot/Makefile b/security/py-certbot/Makefile
index 51a69b373182..73b541feb383 100644
--- a/security/py-certbot/Makefile
+++ b/security/py-certbot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= certbot
PORTVERSION= 0.16.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
@@ -14,7 +15,7 @@ COMMENT= Let's Encrypt client
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme==${PKGVERSION}:security/py-acme \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${PORTVERSION}:security/py-acme \
${PYTHON_PKGNAMEPREFIX}configargparse>=0.9.3:devel/py-configargparse \
${PYTHON_PKGNAMEPREFIX}configobj>0:devel/py-configobj \
${PYTHON_PKGNAMEPREFIX}cryptography>=1.2:security/py-cryptography \
@@ -28,8 +29,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme==${PKGVERSION}:security/py-acme \
${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock
-USES= python:-2.7
-USE_PYTHON= autoplist distutils
+# Actually 2.7,3.3+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes