aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-crack/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2011-01-13 04:10:50 +0800
committergerald <gerald@FreeBSD.org>2011-01-13 04:10:50 +0800
commit2c4a30bf74f65d9944094db612516a2cf5fe4a5e (patch)
treebe2e8bbcade04e2992512f8cd4795532521858ad /security/py-crack/Makefile
parent0f280b2c391a4f56353ade0b8c7b021414978428 (diff)
downloadfreebsd-ports-gnome-2c4a30bf74f65d9944094db612516a2cf5fe4a5e.tar.gz
freebsd-ports-gnome-2c4a30bf74f65d9944094db612516a2cf5fe4a5e.tar.zst
freebsd-ports-gnome-2c4a30bf74f65d9944094db612516a2cf5fe4a5e.zip
Adjust MAKE_ENV and add CFLAGS to be more robust.
PR: 153625 Submitted by: Sofian Brabez <sbrabez@gmail.com> (maintainer) Feature safe: yes
Diffstat (limited to 'security/py-crack/Makefile')
-rw-r--r--security/py-crack/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/py-crack/Makefile b/security/py-crack/Makefile
index 98c6986113fb..39ce88fc7006 100644
--- a/security/py-crack/Makefile
+++ b/security/py-crack/Makefile
@@ -30,8 +30,9 @@ CONFIGURE_ENV= "CPPFLAGS=-I${LOCALBASE}/include" \
"LDFLAGS=-L${LOCALBASE}/lib" \
"DEFAULT_DICTPATH=${LOCALBASE}/libdata/cracklib/pw_dict"
-MAKE_ENV= "CPPFLAGS=-I${LOCALBASE}/include -fPIC" \
- "LDFLAGS=-L${LOCALBASE}/lib"
+MAKE_ENV= "LDFLAGS=-L${LOCALBASE}/lib"
+
+CFLAGS+= "-I${LOCALBASE}/include"
post-patch:
${REINPLACE_CMD} -e 's/setup(/setup(name="${PORTNAME}",version="${PORTVERSION}",/' \