aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-crack/Makefile
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /security/py-crack/Makefile
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'security/py-crack/Makefile')
-rw-r--r--security/py-crack/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/py-crack/Makefile b/security/py-crack/Makefile
index f8d3c1b0c206..e8772d7b821b 100644
--- a/security/py-crack/Makefile
+++ b/security/py-crack/Makefile
@@ -33,6 +33,10 @@ CONFIGURE_ENV= "CPPFLAGS=-I${LOCALBASE}/include" \
MAKE_ENV= "CPPFLAGS=-I${LOCALBASE}/include -fPIC" \
"LDFLAGS=-L${LOCALBASE}/lib"
+post-patch:
+ ${REINPLACE_CMD} -e 's/setup(/setup(name="${PORTNAME}",version="${PORTVERSION}",/' \
+ ${WRKSRC}/distutil.py
+
post-install:
${INSTALL_DATA} ${WRKSRC}/crack.py ${PYTHONPREFIX_SITELIBDIR}